Battery Cells not Loading, Greyed out Cells

GabGarfield
GabGarfield Member Posts: 2 Member
edited March 2023 in Battery 4

Hi everybody. I recently upgraded to a new MacBook and ran into an Issue with the Battery Instances in my projects. When I opened a project on my Macbook Pro M2, which I started on my Studio M1 Mac, I'm getting greyed out cells with the name of the sample still written in it, but no sound coming out. Not getting the missing files window, just opening Battery to the grey cells without any sound. After I replaced the grey cells with the same Samples from the browser so they get colored again and produce a sound, it worked a while, until I opened the plugin window of Battery again, which resulted in the samples that I just loaded being greyed out again. What is wrong here? Any Ideas?


Tagged:

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    Answer ✓

    @GabGarfield @Nkenge It looks like this is related to an older bug (BT4-2680). As there is no date on a fix at the moment, I will try to get more information and a confirmation it is the same issue.

«13

Answers

  • coworking
    coworking Member Posts: 3 Member

    It sounds like there may be an issue with the file paths for the samples in your Battery instance. When you move a project from one computer to another, the file paths for the samples may not be the same, and this can cause the samples to appear greyed out.

    One possible solution is to manually relink the samples in Battery. You can do this by right-clicking on a greyed-out sample cell and selecting "Show in Finder" (on macOS) or "Show in Explorer" (on Windows). This will reveal the location of the sample file on your computer. Then, in Battery, click on the "Cell" tab and select "Replace Sample". Navigate to the location of the sample file in the file dialog and select it. This should relink the sample in Battery.

    If relinking the samples manually does not work, you can try consolidating your samples. This will create a new folder with all the samples used in your project, and update the file paths in Battery to point to this new folder. To do this, go to the "File" menu in Battery and select "Collect Samples". Follow the prompts to consolidate your samples.

    If neither of these solutions works, you may need to contact Native Instruments support for further assistance.

  • GabGarfield
    GabGarfield Member Posts: 2 Member
    edited March 2023

    I never had this issue before. I always had my sample paths in differnet locations on my Macbook (external SSD) and on my Studio Mac (internal HD), but it worked out all the time. Usually I got asked via the samples missing window, which then made it easy to search the filesystem or spotlight and find the missing ones. Now I don't even get the samples missing window, they are greyed out in the cells BUT they appear in the Battery browser, as soon as I load them into the cells again, I can use the Porject, but If i close and open the plugin window once again, they get greyed out and don't play sound anymore. Also I don't get the meu point "show in finder" when right-clicking a sample cell.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    Answer ✓

    @GabGarfield @Nkenge It looks like this is related to an older bug (BT4-2680). As there is no date on a fix at the moment, I will try to get more information and a confirmation it is the same issue.

  • roman-s
    roman-s Member Posts: 1 Newcomer

    I have the same problem in Logic Pro since I upgraded from M1 to M2 Max. The only way I could solve it was by adding a new track with a new instance of Battery and moving the midi regions to the new track.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    Hey everyone, there's a coming update for Battery 4 that should fix sample location issues. I don't have date yet but it should come soon.

  • LaszloT
    LaszloT Member Posts: 3 Newcomer

    Hey, looking forward to that update!

    @coworking the only issue with manual relinking is that if you happened to make an edit on your sample, you won't have that back in this scenario.

  • nouxboux27
    nouxboux27 Member Posts: 2 Newcomer

    @Jeremy_NI I'm having the same issue on an M2 Pro Mac in Logic Pro X. Creating a new track does not solve the problem. Looking forward to the update.

  • One Track Brain
    One Track Brain Member Posts: 6 Member

    i am having the same issue !!! When is the update coming ?

  • One Track Brain
    One Track Brain Member Posts: 6 Member

    @GabGarfield did you find an elegant solution to the problem? Ofc each time separately saving the battery patch with samples is always going to work. but very tedious esp for the many older projects i have.

  • st-h
    st-h Member Posts: 9 Newcomer


    @Jeremy_NI Now, after this is a known issue for 3 Months, are there any updates on the planned fix? This is a pretty severe issue, which prevents me from working on any of my projects. More details: https://community.native-instruments.com/discussion/15364/battery-wont-load-any-samples-in-existing-projects-after-upgrading-to-komplete-14#latest

  • st-h
    st-h Member Posts: 9 Newcomer

    @coworking I don't see any "Show in Finder" item, when I right click on the cell which won't load. Am I missing something?

    I also don't see an option to collect samples in the file menu. Is this for the standalone version, or possibly a different version? currently using 4.3.0


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @st-h Unfortunately, I don't have a date for a fix at the moment, it's in the developers hands now. I understand the frustration, our apologies for the inconvenience.

  • st-h
    st-h Member Posts: 9 Newcomer

    @Jeremy_NI sure, I am a developer myself and I can understand the frustration and impediments that are created by someone asking for progress every hour. But after three months it shouldn't be an issue when they are asked when a fix for a major regression is available. Usually those things are prioritized to be delivered asap. Maybe your devs should be informed about the issues caused by this regression and that a fix should have high priority?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @st-h I hear you loud and clear. We're trying our best to inform the devs as well as POs and voice our users frustration on such issues. I can't really comment on a timeline but I can tell some progress is being made in that department. I will share updates when I have more tangible information.

Back To Top