[BUG] Battery 4.3.0 keeps asking for missing samples (even after pointing to new location)

mi-os Member Posts: 41 Member
edited January 24 in Battery 4

System: Win 10, Cubase 11 and Battery 4 (VST3), all latest versions

Problem: I can't get rid of the missing file dialog after renaming a samples folder.

If i open an old project, made before renaming that folder, i'm greeted with the missing files dialog as expected. I then locate the missing files and everything is working fine. But if i now save that Cubase project and load it again i get the missing sample dialog again which is not what i expect since i already replaced the missing files. I also tried deleting cells and loading the samples freshly but it's still asking for missing samples after saving/reloading the project.

I'm not talking about folders of factory library, kits or patches, just folders containing WAV files, which i load directly into cells.

It looks like the session data (aka state or snapshot) isn't updated and saved correctly with the Cubase project.



  • mi-os
    mi-os Member Posts: 41 Member
    edited January 16

    - edited opening post instead - sorry

  • mi-os
    mi-os Member Posts: 41 Member

    The problem was already there with 4.2.0. I assume older versions too but i also know it worked fine until some update which broke it.

    So please have a look into this since it's very annoying when one is working with many project files. I'm also in the process of restructuring my sample folders and need this functionality for that alone.

  • momos
    momos Member Posts: 18 Member

    This has been the case with Studio One for ages. I don't think they are interested in fixing this.

  • mi-os
    mi-os Member Posts: 41 Member

    Support has replied in the meantime and i hope there will be a solution.

    This bug is a little strange since some systems seem to work fine (disclaimer: i didn't test it on other systems/DAWs myself, just what i heard).

  • mi-os
    mi-os Member Posts: 41 Member

    Additional findings:

    If i just close the project but not Cubase itself and then reload the saved project it works (no missing samples dialog, replaced sample loads fine). Which leads me to the assumption that the session data (or whole project) is somehow cached and that cache holds the replaced paths correctly. It looks like just the session data actually saved with the project is faulty. Again just an assumption since i don't know how this is actually handled by Cubase/Battery and if such a cache even exists.

  • mi-os
    mi-os Member Posts: 41 Member

    Steps to reproduce this issue:

    1. Create a new Cubase project and load Battery 4

    2. Load a WAV sample into a cell by using Battery's file browser (don't load a sample from Battery's factory library or other kits, just a random WAV on your drive)

    3. Now save the project and quit Cubase

    4. Rename a folder somewhere in the path in which the WAV file you loaded is located in

    5. Start Cubase again and load the project.

    6. You should now get the missing samples dialog. Point Battery to the folder or parent folder in swhich the WAV file is located in. (Battery will load the missing file after that - make sure the sample is loaded)

    7. Now save the project again and, IMPORTANT, fully quit Cubase after that

    8. Now restart Cubase and load the project again.

    9. Battery shouldn't ask again for the missing sample if everything is normal. It should just load the replaced sample automatically. (if Battery asks again for the missing file there must be a bug somewhere)

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,823 mod

    Hey @mi-os Thanks for pointing this out again. I've mentioned it already in other posts, it's a known bug, we have an open thread on the matter already here: Battery 4 won't find samples on the same drive on new laptop

    It is an ongoing bug. If that's ok with you, I would close this thread, only to streamline communication.

  • mi-os
    mi-os Member Posts: 41 Member
    edited January 24


    Ok, you can close this thread. But please prefix the other thread with [BUG] and change the headline to something more fitting. It looks like a very specific issue otherwise. It also not really about Battery not finding samples. Maybe something like this "[BUG] Battery - I can't get rid of missing samples dialog even after pointing to new location". Thanks

    It would also help if the phase of the fixing process is presented directly in the headline. For example "[BUG][Fixing in progress] ..."

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,823 mod

    @mi-os You are right, I'll do this for the sake of clarity, thanks for pointing it out, it's actually really helpful.

This discussion has been closed.
Back To Top