Maschine CPU Overloading And I Can't Figure Out Why

Options
Joseph CR Vourteque
Joseph CR Vourteque Member Posts: 11 Member

Hey all,

So I'm working on a live project and want to use Maschine as the basis for it. For one of the tracks I've fully sequenced it out to play out live but I am completely stumped as to why - at a very specific point in the song - the CPU is overloading. Details below

-The track only 6 groups, drum group, FX group, synth lead, synth pad, bass and vox

-The synth lead and synth pad are far and away (as per usual) the most CPU intensive - I'm running Massive X and Pigments 3 on the lead group and Serum on the pad group. The Serum pad is a pretty big series of chords and also utilized the LFO - so yes this IS a CPU intensive load.

-BUT for 90% of the track it all works fine, at a specific time I take out the leads and only have Serum chords with the LFO going - it's once I switch to the next scene with a fade in by the lead(s) AND Serum that FOUR BARS after Maschine goes haywire - it is ALWAYS four bars after (even when I try different scenes) but only if the scene has Serum and the leads.

-Meanwhile my computer doesn't even flinch, at any point, Maschine acts like the CPU is being overloaded but my actual computer never goes about 20% on the actual CPU, I've even checked the different cores and they aren't red-lining.

So why is Maschine acting like my computer is overloading when it's not? I'm just totally flummoxed here and if someone could help that'd be great.

Specs on the Computer

-32GB Ram, Windows 11, UAD Apollo Twin Duo Interface

Thanks all!

«1

Comments

  • Kubrak
    Kubrak Member Posts: 2,836 Expert
    Options

    One core load is what Maschine shows. If everything runs on one core, Maschine might indicate 100% and PC 25% if one has 4 cores....

    There may be many reasons for your problem. What CPU do you have and at what clock it runs. Also how big audio buffer do you have. And have you allowed multithreading in Maschine?

  • Joseph CR Vourteque
    Joseph CR Vourteque Member Posts: 11 Member
    Options

    Hey Kubrik, thank you for your response!

    I'm running a i5-10060 something I believe. I have the PC overclocked at 21%. The buffer is 1024 (so should be more than enough).

    The last part I'm really interested in though, I'm not sure I've allowed multithreading - how do I go about that? I can't find anywhere in preferences that gives an option for it.

  • awol9000
    awol9000 Member Posts: 69 Advisor
    edited August 2022
    Options

    Try disabling Hyper threading in your PCs bios.

    Maschine utilizes 50% of a core and if you have hyper threading on then maschine is using only 25% of the core iirc.

    While in bios disable speed stepping as well. Then in Windows set power plan to maximum, eliminate any power saving if you haven't already.

  • Schmapps1
    Schmapps1 Member Posts: 135 Pro
    Options

    Interesting, I’ve never heard this before about Maschine.

    does disabling hyper threading on a Mac help with Maschine as well? Can you even disable hyper threading on a Mac? Haha sorry if it’s a dumb question..

  • Kubrak
    Kubrak Member Posts: 2,836 Expert
    edited August 2022
    Options

    @Joseph CR Vourteque

    Look at temperature of cores and if CPU speed does not change much. What might happen is thermal throtling. CPU speeds up too much to make more work, but overheats and must slow down very much to cool down. In that moment dropout may occure.

    Last few generations of Intel are prone to it. And if you overclocked CPU, it may make things even worse. Unless you have very good cooler...

  • Joseph CR Vourteque
    Joseph CR Vourteque Member Posts: 11 Member
    Options

    Okay so update - first off - I'm still annoyed that I need to tweak my computer to the extend I do to optimize Maschine - that said - I don't think that was ACTUALLY the issue I was having.

    So I kept running into the SAME issue exactly four bars after I ran one scene, I tried deleting various parts of the song to see if there was possibly a plugin not playing nice, and low and behold when I deleted the DRUMS of all things it seemed to solve it. The drums, though, are all Maschine native, samplers and drum synth (which is quite great I will say). Then I realized I was running a ducking program on a sampled drum line (called Duck actually) I love the program but it doesn't seem to want to work well with Maschine, as it runs continuously in the background while the song is playing I realized there may be some buffer conflict there. So I bypassed it and that seemed to help a lot.

    I still get CPU spikes, even after disabling speed step, disabling hyper threading and tweaking my overlock so... I am really at a loss, but I'm not getting drop outs so that's good. For now.

  • 6xes
    6xes Member Posts: 674 Pro
    edited August 2022
    Options

    On the cpu meter on the top right corner within the maschine software...

    if that bar is climbing... its telling you the issue is within your maschine plugins etc...

    if the bar indicator is not climbing and you are still having issues, usually it indicates a issue outside of the maschine software enviroment.

    im probably stating the obvious... just adding my 5cents of input *winks

  • 6xes
    6xes Member Posts: 674 Pro
    edited August 2022
    Options

    another consideration...

    is downloading the program monitor called lasso.. by bitsum.. it will essentially identify any programs in your windows OS that maybe problematic... and it will allow you to prioritise processes... and in some cases prevent other processes from executing..

    i believe there is a free version with a nag-screen enough to annoy you.... so you consider purchasing it...

    naturally i purchased the pro version... becos of its value & i like knowing whats going on in the background on the OS

    ... and given all the bloatware that windows11 comes with... you will eventually be dealing with processes when you invariably get updates!!

    keeping your windowsPC optimised will save you alot of headaches in the long run!!

  • August Alchemy
    August Alchemy Member Posts: 21 Member
    Options

    Process lasso is a savior. I thought my problems with Maschine was over with a brand new pc build and slowly the cpu spikes started creeping back up. I finally bought process lasso pro and dug deep into knowing how to use it and I set up a profile just for Maschine. I like being able to set a power plan, cpu group sets and process priorities for particular programs.It’s amazing what it can do. The difference in performance is like night and day and you create scenarios for each process.

  • MarkC_UK
    MarkC_UK Member Posts: 1 Newcomer
    Options

    Hi. I was having the same issue. Changing the following seems to have resolved the issue


  • Warren Postma
    Warren Postma Member Posts: 43 Member
    Options

    I am having the same exact issue and like the OP no other audio software on this machine has this issue.

    This is a core bug in maschine standalone's operation on windows machines.

    Note that authors of software (I am a developer) can set up priorities and prevent their apps from failing due to whatever kind of priority inversion is happening inside the Maschine DAW audio host causing the system to basically fall apart, consume 100% of one core without doing any actual real audio DSP work.

    This is a fundamental bug in this app. It may be the kiss of death for many people trying to use maschine.

  • Famous Rebel
    Famous Rebel Member Posts: 3 Member
    Options

    Sorry to open an old thread but this is an issue on Macs also for me at at least.

    I moved over to logic but then moved back to Maschine buying a new S49, to go with my studio, jam, mk2, mini etc ( Ive invested a lot in Maschine ) as I was so used and happy with the workflow, however when it comes to song arrangement ...it just falls apart....without overloading my cpu or ram ..my song basically goes from 174 bpm to half speed ..turning into an electronic noise mess...the only way I can actually hear the track is to export it ..and make changes after listening..even then selecting parts of the track ..lags to hell.. ...no issues on Logic with the same amount of plug ins etc ..ive tried two audio devices ..rebuilt the mac from scratch ...same issue

    Has anyone got an idea what causes this ....Ive read all the it could be a plug in etc ....it's not its been happening on various tracks for years with the same issues...my next thought is M2 mac ..but if the problem persists then what ?

    Mac intel I7 quad core

    4tb Fusion drive

    32GB RAM

  • D-One
    D-One Moderator Posts: 2,982 mod
    edited August 2023
    Options

    The first step to any issue like this is to delete/disable each instrument/fx at a time and figure out who is the culprit - At least in cases like the OP where the CPU is good enough to easily run the project at a moderate buffer size. Some plugins just don't play very well with Maschine.

    Another thing to understand is that a CPU doesn't need to hit 100% system usage for Audio glitches to happen, very far from it actually.

    I never had any of these issues of Maschine only using 1 core (!?), DAW's tend to use core-per-track so i cant see how this could happen to a full project, the only thing obvious to me is system usage showing only 50% overall usage, near 0% usage on the virtual threads which to me means Maschine does not support hyperthreading.

    @Joseph CR Vourteque said:

    I still get CPU spikes, even after disabling speed step, disabling hyper threading and tweaking my overlock so...

    No, you can't disable hyperthreading on Mac as they don't have a configurable BIOS like PC's do.

    Whether it's a Mac or PC disabling it won't do anything of value, it will just hurt the overall performance of your computer to everything else that might use hyperthreading. The only benefit would be more accurate % performance readings...

    I advise against disabling hyperthreading as a solution to poor performance, that's like using gasoline to put out a fire - Back in the day when hyperthreading was new disabling it could help but not in this era from my experience, even in the off case it helps it will be a small percentage gain for one specific app at the cost of all other moderns apps.


    It's a 10yr+ codebase with a bunch of outdated libraries, you can't expect much but I never had that sort of issue on Windows or Mac, something else is going on there. Try to debug which instrument/fx is causing it.

Back To Top