Hi NI.... I´m fighting to install my komplete 12 on a new mac mini. I have it on 2 other Macs. I v

OJuul
OJuul Member Posts: 5 Newcomer

Hi NI....

I´m fighting to install my komplete 12 on a new mac mini. I have it on 2 other Macs. I vacant find an explanation on how to... only that it seen to be necessary to uninstall on one of the old Macs.

I've read and tried everything, I think ;)

Kind regards Ole Juul


Answers

  • Sunborn
    Sunborn NKS User Library Mod Posts: 2,322 mod

    It is a known limitation. You can not install NI material on more computers. First, you have to de-authorize / uninstall from one of your other computers and then install on a new one.

  • OJuul
    OJuul Member Posts: 5 Newcomer

    Thank you Sunborn. I will de-authorize your product from one Mac.

    How do I de-authorize it?. That's one of the thing I can't figure out. Is it to un install everything . . It would be nice if you can somehow de-authorize, and leave the content be..... ?

    I can t find any thing reg. de-authorize in the "Native Access" program

    Best Reg, OJ

  • Sunborn
    Sunborn NKS User Library Mod Posts: 2,322 mod
    edited December 2023

    yes, unfortunately you have to uninstall all NI apps, and then logout from Native Access and uninstall it too (as last app)... that's all! ...oh, and that is the "de-authorization" btw

    then go to new computer, install Native Access and the other apps and libraries

  • mykejb
    mykejb Moderator Posts: 1,162 mod

    I've never had to uninstall NI software before installing on a new Mac/PC for all the time I've been using NI software and I've had it on lots of machines for software testing. I know the licence agreement says three but I've never seen it enforced up to now.

    Is that a new thing?

    -- Mike

  • OJuul
    OJuul Member Posts: 5 Newcomer


    Hello Sunborn....

    I have un-installed everything from the old mac. And in the order that you asked me to. And have folowed the guide "How to Uninstall Native Instruments Software from a Mac Computer"

    Plus un-installed the Native Access app last, as the guide somehow doesn't say! (you did)

    When trying to install on the new mac the exact same thing is happening. Just as the pictures in this thread shows.


    But...... the plugins does somehow install. I just cant use them.

    I can (like I can see others have experienced) see that even though the Native Access app says that the installation has faiIed, I kan open the plugins. And then choose to run them in demo mode, or activte them (from each plugin!).... when I try to activate it says: service center can not be found, please run the pruduct installer again


    The second "old mac", with an NI komplete 12 on is down... and I'm without all my Komplete 12 plugs in my work studio.

    So, I really hope that NI can be helpfull here!...

    As I understood from you're message. And from NI's "How to Uninstall Native Instruments Software from a Mac Computer" ... when de-authorize, the Native Access app/Mac needs to send some kind of message to NI that everything has been un-installed, including that the app Native Access itself har been uninstalled. That has to be the reason that I was told to erase it all. Right?.


    I never had a situation like this before. Please tell me what to do here


    Regards Ole Juul

  • Sunborn
    Sunborn NKS User Library Mod Posts: 2,322 mod

    I really don't know. It is what they say, so i mentioned it. Personally, i never used them on more than 2 computers either way

  • OJuul
    OJuul Member Posts: 5 Newcomer


    I actually thought that you were a NI employer. Sorry Sunborn 😣 I really apreciate your help here. Thank you. I will see if someone from NI is willing to help me.

    Kind regards, Ole 😊

  • Sunborn
    Sunborn NKS User Library Mod Posts: 2,322 mod
    edited December 2023

    ok lets take it step by step:

    First and most important: Make sure that you are using the latest update of Native Access 2 (not the old Native Access 1!)

    Then, your message "service center can not be found, please run the product installer again"

    Service Center is very-very old and never used since the arrival of Native Access. So, i assume that some of your plugins might have really old versions, for example, FM8. Please check that.

    Products shows as Demo: There can be several reasons, please check the articles they apply to your case.

    1. My Products Are Showing As DEMO in Native Access
    2. GUITAR RIG 5, KONTAKT and SUPER 8 R2 Open as Demo Versions on Apple Silicon / M-Systems

    Verify those steps first, especially from the first link, then we can go deeper.

    Always make sure that you: run Native Access as Administrator on Windows or grant it Full Permissions on Mac

    Btw, i noticed you mention Komplete 12 which is really old. Old things bring problems (at least in Native Instruments, as we all have seen). I believe you can get a brand new Komplete 14 update either for free either for a very low price.

    ________________________________________________________________________________

    If you are still in trouble, best contact with someone from Ni here. @Jeremy_NI is most helpful.

  • mykejb
    mykejb Moderator Posts: 1,162 mod

    I end up with random installations all over the place when I'm testing stuff 😂 I hope they don't start checking!

  • OJuul
    OJuul Member Posts: 5 Newcomer

    Thank you a thousand times. I do use N.access 2. But it makes so much sense reg updates of the individual plugins.

    I will try everything you mentioned. And nice that I have a name from NI to contact now.

    Have a great day. Thank you so much 🙏🏻🌟😊

Back To Top