Help Please! Upgraded to KK v3.0 and now missing 53 expansions in loop browser

musiccityLB
musiccityLB Member Posts: 19 Member

Greetings all,

Has anyone else upgraded to KK v3.0 and discovered that they now are missing expansions in KK browser?

I bought a KK s49 MK3 keyboard and upgraded software to Komplete Kontrol v3.0. Although KK browser (in both standalone & DAW plugin) show all of my instruments and one shots listed completely - under loops I am missing more than half of my expansions - 53 to be exact. Native Access properly lists all expansions.

I have tried uninstalling and reinstalling Komplete Kontrol software but same outcome. I have also tried all of the NI website troubleshooting suggestions - no help. I sent support ticket to NI and response from rep was "that's strange" and a link to website troubleshooting tips (support rep ignored the fact that I clearly noted in my ticket that I had already tried those suggestions).

I'm stuck. No option of reverting to KK v2.9.4 because new MK3 keyboard requires v3.0. This is untenable for me and looks like I'll have to return my new KK s49 MK3 keyboard for refund. (Are you listening Native Instruments???)

Thanks in advance for any productive advice and/or solutions!

Best Answer

  • Nilo_NI
    Nilo_NI Customer Care Posts: 23 mod
    Answer ✓

    Thanks musiccityLB,

    I've been able to reproduce this as you described it with Arcane Attic.

    I downgraded to KK 2.9.6 and indeed Arcane Attic appears there and I'm able to load the Construction Loops.

    I presume the issue is due to KK 3.0 not recognizing "Construction" loops as loop content. I'm informing the devs right now.

«1

Answers

  • mykejb
    mykejb Moderator Posts: 1,159 mod

    Possibly an obvious question, but did you wait while KK3 scanned all the loops and sounds? KK2 had a little "scanning" icon that showed while this was happening. KK3 doesn't have that so there's no obvious indication that the scan is still happening. The only way you can tell is that the count in the bottom right of the browser gradually increases.

    -- Mike

  • musiccityLB
    musiccityLB Member Posts: 19 Member

    Thanks, Mike. I appreciate your note. I was careful to let KK3 finish scanning. Unfortunately, same outcome.

  • Nilo_NI
    Nilo_NI Customer Care Posts: 23 mod

    Hi musiccityLB,

    Not all Expansions have the same type of content.

    For example, the expansion Arcane Attic doesn't have Loop content (it has however "Construction Loops"). The expansion Rare Vibrations however does for example have loop content that will appear under "Loops" in Komplete Kontrol.

  • musiccityLB
    musiccityLB Member Posts: 19 Member

    Hi Nilo. Thank you for your reply. However, ALL of the expansions that I am now missing since upgrading to KK v3 do in fact have loop content. I frequently used the loop content of these missing expansions when using KK v2.9.4. I have now loaded KK3 on three different computers - a new MacBook Pro, Mac Studio - both with Apple silicon and a 2020 IMac with Intel processor. The same issue occurs on all 3 computers when updating to KK3.

  • Nilo_NI
    Nilo_NI Customer Care Posts: 23 mod

    Hi,

    can you tell me an example of an expansion that you own but doesn't appear in the Loops section?

  • musiccityLB
    musiccityLB Member Posts: 19 Member

    Thank you for your quick reply!!

    No problem. Here’s a 10:

    Amplified Funk, Aquarius Earth, Arcane Attic, Astral Flutter, Basement Era, Byte Riot, Carbon Delay, Caribbean Current, Cavern Floor, Conan’s Gardens.

  • Nilo_NI
    Nilo_NI Customer Care Posts: 23 mod
    Answer ✓

    Thanks musiccityLB,

    I've been able to reproduce this as you described it with Arcane Attic.

    I downgraded to KK 2.9.6 and indeed Arcane Attic appears there and I'm able to load the Construction Loops.

    I presume the issue is due to KK 3.0 not recognizing "Construction" loops as loop content. I'm informing the devs right now.

  • musiccityLB
    musiccityLB Member Posts: 19 Member

    Thanks again for your help, Nilo. I’m not sure what a “construction” loop is and how it differs from other expansion loops?

    I’m also surprised that this hasn’t previously been brought up as an upgrade version bug for other users.

  • musiccityLB
    musiccityLB Member Posts: 19 Member

    I heard again from NI support ticket rep. Here's their latest note:

    "Unfortunately, the issue you are describing here is a known bug with Komplete Kontrol v3. The good news is that the devs are aware of it and expect to have the issue resolved in the next update, which will be available in Native Access very soon."

    Good to know. Would have been better to know this BEFORE spinning my wheels for days and utterly wasting countless hours trying to solve a problem that has no solution. And NO warning from Native Instruments. Surely I can't be the only customer that has had this issue!!!

  • Nilo_NI
    Nilo_NI Customer Care Posts: 23 mod

    Hey musiccityLB,

    yeah, it is a bit weird that there hasn't been more reports of this. It may not be the most used feature in KK I guess.

    We only found out as I was writing to you yesterday. I'm really sorry for the inconvenience. If we would have known, we would have been able to inform you as soon as you reached out. Thanks again for bringing it to our attention.

    I hope it's fixed soon anyway.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,700 mod
    edited November 2023

    It’s probably because you can’t really use samples properly anymore in the KK3 browser because the ability to drag and drop them into, say, Battery cells or Form or Kontakt has been removed. So tbh at the moment I guess hardly anyone is using them, not because they don’t want to, but because they can’t anymore

  • musiccityLB
    musiccityLB Member Posts: 19 Member

    I appreciate the replies and comments. However, it is unacceptable to me that I paid for a product - which I use frequently - and then it is omitted in a software update. With or without notice from product producer.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,700 mod
    edited November 2023

    The loops going in the wrong area is a bug, no one is saying you have to accept it, just that it’s being fixed which is the main thing. It wasn’t intended

    The changes to how KK functions in relation to samples requires a more fundamental change in my view, I think NI have misinterpreted usage data and imposed their own preconceptions on it, not taking into account how some people use it within their workflows. I think we have got their attention at least now.

  • musiccityLB
    musiccityLB Member Posts: 19 Member

    I disagree. A development choice was made. I don't accept that no one at NI was aware of the problem.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,700 mod
    edited November 2023

    We appear to have cross posted as I have amended what I wrote while you responded to clarify this. There are 2 different issues here, from what NI have said it doesn’t look like they were aware of the bug till users like yourself reported it. It’s not an obvious bug tbh and as KK3 is much harder to use samples with now due to the badly thought out browser, it’s clear less users were using it which would have generated more reports if they had been

    The actual changes to the browser on the other hand I agree was a design decision, and a poor one in my view. But bugs I’m afraid do happen and if they could all be anticipated then they wouldn’t be bugs.

Back To Top