Komplete Kontrol S88 Mk2 - Setup Freezes

GusFeder
GusFeder Member Posts: 6 Member
edited January 2023 in Komplete Kontrol

I'm having an issue with my new S88 MKII. Every time I click the Setup button on the keyboard to change the velocity curve the whole interface freezes. My System is MacOSMonterey Version: 12.5.1 (2.6 GHz 6-Core Intel Core i7). Latest firmware (0.6.0) is installed and everything except Velocity Scaling works fine.

Does anyone know how to fix this issue?

Thanks in advance.

Best Answer

  • GusFeder
    GusFeder Member Posts: 6 Member
    Answer ✓

    Hi @Jeremy_NI, No worries at all! I've figured out what was causing the problem, and it's fixed now.

    Thanks!

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,462 Expert

    I think this has been reported as an issue, seen a few reports of it and as usual, affects only mac users. Best thing would be to report it through in a ticket since I am pretty sure it is a software issue with macOS.

  • GusFeder
    GusFeder Member Posts: 6 Member

    Hi @JesterMgee Thanks for responding. I tested it on a friend's M1 and everything worked, but I can't get it to work with my Intel processor. I opened a ticket, but installing the Native Instruments Support Tool isn't something that makes me comfortable—hoping someone else has another solution.

    Thanks again for your reply.

  • JesterMgee
    JesterMgee Member Posts: 2,462 Expert

    Yeah it is possibly related to Intel based processors. I just recall a thread here where a few users all had the same issue you report. Not sure what the issue is installing the support tool??

  • GusFeder
    GusFeder Member Posts: 6 Member

    Hey @JesterMgee, It's strange that the solution they are proposing is to download and run an application, which will ask me for my password in order to "fix" whatever problem this program identifies.

    On top of that, I'm not sure what kind of information the program is collecting from my computer. If they know this issue affects Intel processors, wouldn't be easier to just provide a solution?

  • JesterMgee
    JesterMgee Member Posts: 2,462 Expert

    The program simply collects your system metrics and installed software since usually users are useless at giving this info and it can be difficult to even try and help without knowing what is on a system. You cannot just offer a "Fix" when you cannot be sure exactly of the issue.

    I also never said it was a "known issue" only that some others have reported the same thing and possibly they need to get details of different systems to troubleshoot the problem since if it was an actual wide spread issue there would likely be hundreds of reports, not just a few. Usually when you have ANY kind of issue, support request the details of your system and that tool just does quick work. I am also pretty sure it is not asking for any password, possibly you need to enter your macOS PW to allow it to run just like most other things on mac when you first launch them.

    I know in this day and age any time anyone askes for any info online it's a "red flag" but you kind of need to place some faith in some people/companies if you have issues and you want the help.

  • GusFeder
    GusFeder Member Posts: 6 Member

    Hi @JesterMgee, Thank you for your input! I found a solution: instead of connecting the keyboard via an USB hub, I connected it directly to my computer—and now everything works perfectly.

    It's too bad that I had to find this solution myself, when no one at NI has responded yet. And don't get me wrong—I love and trust the brand, but having waited more than a week for help with this issue is sad.

    Thanks again for your help.

  • JesterMgee
    JesterMgee Member Posts: 2,462 Expert

    Glad you got it sorted and actually reported your findings.

    on macOS especially, hubs can be hit and miss in regards to things working properly sometimes. No idea why, just sometimes that can be the cause of issues so always suggested if at all possible to either try a direct connection or a different hub.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @GusFeder I see in your ticket that you fixed the issue by connecting the keyboard directly to a USB port of your computer, right? Sorry we were a bit slow on this one. We have a lot of requests at the moment following the holiday season and a lot of our support agents were or still are out sick, myself included!

  • GusFeder
    GusFeder Member Posts: 6 Member
    Answer ✓

    Hi @Jeremy_NI, No worries at all! I've figured out what was causing the problem, and it's fixed now.

    Thanks!

Back To Top