Maschine+ with Studio One: Recorded MIDI notes are out of sync

Simon
Simon Member Posts: 9 Sine
edited February 12 in Maschine

I am unable to sync Maschine+ to my DAW (Studio One).

The image here shows 4 beats tapped exactly on beat but the recorded MIDI notes are way out of sync.

I've tried the obvious: modify the audio buffer and dropout protection size but this doesn't work.

There is additionally another related issue. I have to MUTE the channel while recording otherwise the tapped notes playback with a delay of about 100 ms.

Is there anyone who has experience with this problem?

I would appreciate any help thank you.

I can supply more information if necessary.

Best Answer

  • D-One
    D-One PortugalModerator Posts: 408 mod
    Answer ✓

    I just tried a Studio One 5 demo with my M+ and it all worked out fine, both on the MAS Instrument Track and on a separate MIDI Track, same settings as far as I can tell. Does your S1 metronome line up with Maschine-Plug if you turn them both On? It does here.

    Do you have anything else going on on this project? Heavy Plugins on the master or something?

    The Z thing doesn't make it better or worst for me, at least on low buffers (16 to 64) but it still shows up next to the latency even when OFF in the mixer, no idea why.

    Maybe a project setting might be causing it, I'll attach mine, not sure if it will open for you or not since I'm a version ahead due to the beta but worth a try.



Answers

  • starcorp
    starcorp Member Posts: 20 Sine

    i guess you are in control mode?

    how is M+ connected?

    is the M+ set as an controller or keyboard?

  • Simon
    Simon Member Posts: 9 Sine
    edited February 10

    the Maschine+ is connected with USB as a controller.

    I don't know how to set it as a keyboard...

    i.e. i'm not using Maschine in MIDI mode

  • Uwe303
    Uwe303 Moderator Posts: 357 mod

    This is really way off, what audio settings do you have? What mesure do you use, try to set it to 4/4 to test it? You don't use maschine in Midi mode, so you use the midi to host setting.

    Uwe

  • Simon
    Simon Member Posts: 9 Sine

    Yes i used 4/4 to test and I'm using the Maschine+ inside Studio One.

    And, yes I have Maschine in the HOST mode where Studio One is the HOST and running the Maschine VST inside Studio One. And using Maschine+ as the input controller.

  • Uwe303
    Uwe303 Moderator Posts: 357 mod

    Do you use S1 metronome or to what signal do you try to play in sync?

    Uwe

  • Simon
    Simon Member Posts: 9 Sine
    edited February 11

    yes I am trying to play against the Studio One Metronome as well as any other existing tracks.

  • D-One
    D-One PortugalModerator Posts: 408 mod

    @Simon try this:


  • Simon
    Simon Member Posts: 9 Sine
    edited February 12

    thanks @D-One i tried exactly as described.

    i used drop out protection 'Minimum' and removed green-z zero latency as described below.

    (at minimum dropout protection, the 'enable low latency monitoring for instruments' and 'hardware monitoring' options are disabled, these two options are different from the green Z on the master).

    i also set the audio buffer 'Device Block Size' to 16, 32 and 64 samples

    and disabled the green-z option on the master track

    but the issue remains exactly the same in each case. Studio One records each tap with a significant latency.


  • Fugazi81
    Fugazi81 RuhrgebietMember Posts: 21 Sine

    Hi, something looks weird. Could this be related to your MIDI routing? When you record, you send data to your Maschine plugin. Does your Maschine plugin also send data to your DAW? As you wrote yourself, you have to mute the channel while recording, almost sounds like a MIDI loop.


    You should definitely avoid that.


    Unfortunately, since I don't use Studio One, I can't test it.

  • Simon
    Simon Member Posts: 9 Sine
    edited February 12

    thanks Fugazi81 i think you have an interesting point.

    but i don't know how to avoid creating that loop.

    i don't know much about MIDI routing.

  • Fugazi81
    Fugazi81 RuhrgebietMember Posts: 21 Sine
    edited February 12

    Hi Simon,

    depending on how your settings are, there could be several reasons.

    The user manual definitely helped me, it is very detailed with the routing setting options.

    https://www.native-instruments.com/fileadmin/ni_media/downloads/manuals/maschine_2_8/MASCHINE_2.0_MK3_Manual_English_2_8.pdf

    I would check that first,

    12.2.1 Triggering Sounds via MIDI Notes + 12.2.5 Sending MIDI from Sounds

    make sure you don't send data in a loop. I think there is a problem with the midi channel settings.


    In S1 one must also check. There are definitely settings for input devices or MIDI channels. The principle of data feedback also applies here.


    great example of how to integrate maschine into your DAW. It´s for Cubase, but there you can also see, among other things, how to work around some obstacles in the settings that might suit your problem


  • starcorp
    starcorp Member Posts: 20 Sine

    Did you switch of midi thru?

  • D-One
    D-One PortugalModerator Posts: 408 mod
    Answer ✓

    I just tried a Studio One 5 demo with my M+ and it all worked out fine, both on the MAS Instrument Track and on a separate MIDI Track, same settings as far as I can tell. Does your S1 metronome line up with Maschine-Plug if you turn them both On? It does here.

    Do you have anything else going on on this project? Heavy Plugins on the master or something?

    The Z thing doesn't make it better or worst for me, at least on low buffers (16 to 64) but it still shows up next to the latency even when OFF in the mixer, no idea why.

    Maybe a project setting might be causing it, I'll attach mine, not sure if it will open for you or not since I'm a version ahead due to the beta but worth a try.



  • Simon
    Simon Member Posts: 9 Sine

    Fugazi81, starcorp, D-One

    thanks a lot for helping out.

    D-One's solution is working. :) i will mark his as the correct solution.

    Thank you again.

  • Antidote82
    Antidote82 Member Posts: 1 Noise

    In your original post, you mentioned possibly having some plugins on the Master that might be causing the issue. If you have any Post-Production/Mastering plugins engaged such as Ozone (iZotope), they will introduce some latency. My recommendation would be to bypass or remove those plugins and see if the issue still exists.

Back To Top