Is there a workaround for the ancient "Locked Deck" bug?

Options
ilove1981
ilove1981 Member Posts: 50 Helper

Yes again, last night I was hit by this ancient bug which is just ridiculous. Deck A was reported as "Locked" when no track was playing. I used the age-old technique of unchecking the settings option to allow loading a track into a locked deck.

Is there actually a better workaround for this bug? I'm aware it has been reported many times for years now. Mine was Deck A (I think it always is for me) and I'm using an S4 Mk3 and running TP3.6.2 on macOS 11.6.8. I know the Official Support advice will tell me to upgrade which has never fixed this bug in all my time using Traktor. I will upgrade now that all my gigs are done for this year but I bet it will happen again sometime soon :-(

Comments

  • lord-carlos
    lord-carlos Member Posts: 2,496 Expert
    Options

    I think someone suggested to uncheck the setting and do it with midi mapping. You can block the load track mapping form working if a track is playing.

  • fsiracusa
    fsiracusa Member Posts: 12 Member
    Options

    Also happened to me last night, also on Deck A after using a Flanger effect on my D2 (but I used effects before and this is the first time it happened to me). Luckily it was at the 2 hour mark in my show, so I had a convenient stopping point. I could have continued to play by unchecking the Load track only in stopped deck setting, which is not ideal. I tried to work my way out of the jam by changing the flavor of Deck A, but that did not work. It would be nice if N-I worked out some sort of "soft-landing" that did not require DJs to restart the software in the middle of a gig.

  • Herrr Stuke
    Herrr Stuke Member Posts: 3 Member
    Options

    Hi there!

    Also happened to me last night (deck A) :-(((

    Changing deck flavor, unplugging the controller (S4MK3) didn´t solve the problem.

    I then switched to playing with decks C+D then - it was "ok", unused, felt no good...

    This bug should be SOLVED!!!!

    Traktor Pro Plus 3.8.0 46

    MacBook Pro mid 2015 /i7 2.8GHz/16GB RAM/2TB SSD/Monterey 12.5.1

  • clouston
    clouston Member Posts: 11 Member
    edited March 2023
    Options

    I think you might be onto the reason this happens as I had this happen to me for the first time ever since I started using traktor in 2007!

    Deck A showing as locked after I put an effect over the playing track on Deck A once, using FX bank 1 and thereafter I had the deck locked issue only on that deck.

    I am using a MacBook Pro M1 and a S4 MK3 hardware setup on newest Traktor 3.8


    Hoping someone from NI will see this and put this issue to bed finally as it’s been there for many on releases for years now.

Back To Top