Native Access failed to install new library to portable disk on macOS 13 (Ventura)

Candinya
Candinya Member Posts: 3 Member
edited December 2022 in Native Access

Hi there,


Sorry for the disturbance. Recently I've upgraded my MacBook to macOS 13 Ventura, and today I found it failed to install new library onto my portable disk drive.

Updating an existing library is fine, and I've given NativeAccess and NTKdaemon full disk permission in system privacy settings, still no luck. The downloaded install image can mount, but it just unmounted quickly before the failed message was thrown.

One more noticeable thing is that Native Access deleted the downloaded install image after (or alongside with) the failed installation, I don't know if this is fine or abnormal (as far as I can remember, when installation failed, the image file seems to be kept rather than deleted).

Since it only has a general "Installation failed" notice and didn't produce any more logs for debugging (I'm not sure if they are in somewhere), I can't identify the detailed installation progress issues and find out what's the problem indeed.

Don't worry, it's not your problem. MacOS Ventura has changed a lot fundamental APIs so it's common to have compatibility issues like cannot read or write portable disk, some other software products have this compatibility issues too. This is just a bug report.

My system is macOS 13.0.1, and my Native Access version is 3.0.1 (9679536 / 1.8.0.6), wish this can help.


Thanks for your hard work and concern.


Yours sincerely,

Nya Candy

Best Answer

Answers

  • GospelBass
    GospelBass Member Posts: 1 Newcomer

    Hello,

    same problem here, on my both my Mac mini M1 and my Macbook Air M1 running MacOS 13.0.1 Ventura and Native Access 3.0.1 (Apple Silicon version) I'm unable to install Hypha on an external drive. The installation fails with "Installation failed" I've unable to find any information in logs pointing to the source of the problem.

    Best regards

    Arnd

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,916 mod
    Answer ✓

    @Candinya @GospelBass

    First of all make sure that the external hard drive is formatted to APFS: Notes on Hard Drive Formats on Mac Computers

    Then give Full Disk Access to Native Access and NTKDaemon: How to Enable Full Disk Access on macOS

    If they do not appear in this list, click the + icon and add the following apps:

    Macintosh HD > Applications > Native Access

    Macintosh HD > Library > Application Support > Native Instruments > NTK > NTKDaemon


    If none of the above worked out, you can try to install on the default location, on your system's drive and then move the libraries like this: Moving a Native Instruments Product to Another Location on Your Computer

  • Candinya
    Candinya Member Posts: 3 Member

    Hi there,


    Thanks for the reply, I'll try reformatting my drive to APFS format (it's now ExFAT for compatibility concern). But before that, by manually executing the installation wizard, I found that it thoughts my drive don't have enough space to proceed installation, but it's weird because it actually has about 2.69TB not occupied, which is enough for Hypha (1.88GB).


    So it's neither a problem with Native Access nor NTdaemon, it's actually a question triggered by maybe the space detect method of the installation wizard?


    Hope that will help. Thanks for your help and hard work.

  • Candinya
    Candinya Member Posts: 3 Member

    Hi there,


    Here are the latest updates :D

    By reformatting my portable disk to APFS format, the installation problem was fixed. So it must be macOS Ventura's compatibility issues with exFAT partition mode, no worry for Native Instruments.


    Thanks for the help!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,916 mod

    @Candinya Thanks for the update!

Back To Top