S88 NKS data to screens not automatic with Ableton

J_roger
J_roger Member Posts: 12 Member
edited December 2022 in Komplete Kontrol

Windows 10, Latest Live Suite, Push 2, S88

Loading KK into different tracks, S88 doesn't load up the synths on its screens automatically when I switch tracks. Worked out I need to press the keyboard button in the plugin each time. Real pain.

What am I possibly doing wrong?

Tagged:

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,891 mod
    Answer ✓

    @J_roger it seems your issue was fixed by installing the last update of Ableton.

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert

    Post a screenshot of your midi preferences in Live as a start, I suspect you probably have something wrong there at a guess.

  • J_roger
    J_roger Member Posts: 12 Member
  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert

    These are issues for a start:

    If you cannot answer why any of these should be checked on then you should uncheck these because none of this is a required setting, especially the DAW control port should not be set for ANY of the MIDI ports when set as a control surface device. May not solve your issue, but needs to be corrected anyway, not sure why I see so many people checking all these ON.

  • J_roger
    J_roger Member Posts: 12 Member

    Many thanks for this mate, I've made the changes. I can't explain why I had them on tbh, it's all a bit confusing.

    Unfortunately it doesn't change things i.e. I still need to click the keyboard connect button every time I switch tracks.

    Really appreciate the help though.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,891 mod
    Answer ✓

    @J_roger it seems your issue was fixed by installing the last update of Ableton.

  • J_roger
    J_roger Member Posts: 12 Member

    Yes thank you. I meant to update this but didn't get round to it.

    For anyone else searching this issue, yes updating to the latest version of Ableton sorted it.

    Doesnt explain really why the slightly older version of Ableton 11 had this problem and it's unclear if that version per se was problematic or simply a fresh install in itself was what fixed it.

    So I'd say to anyone with this issue 1) make sure you have the latest Ableton version and if you already do then 2) reinstall Ableton.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,891 mod

    @J_roger I'm also curious why this was the case. When you install an Ableton update it usually acts like a fresh install so any wrong remote scripts get overwritten. Now the process for the Ableton's Komplete Kontrol integration is totally automatic, in the past users needed to install remote scripts, use AU or VST racks, etc...maybe you had done something like this in the past?

  • J_roger
    J_roger Member Posts: 12 Member

    No I didn't. I guess things mess up over time so fresh installs are always helpful.

Back To Top