Cubase 12 vs Maschine 2 Plugin High CPU Load

Options
manassas77
manassas77 Member Posts: 13 Member

I'm experiencing a lot of CPU spikes in Cubase 12 which seem to be caused by the Maschine 2 plugin.

It could be many things at play, but I'm trying to isolate the issue as I think it may be connected with the move to vst3 - so I'd like to see if I can replicate the problems using the vst2 version.

Problem is, Cubase is not showing both versions as available. If I temoprarily remove the vst3 dll Cubase makes vst2 available - but then opening it up in a previously saved project removes all the kits etc and just opens as an empty instance.

Two questions - has anyone else experienced the CPU spikes (to a point where Cubase grinds to a halt), and has anyone an idea how to make bother versions available?

I should say that the projects that are causing issues ran fine until recently.

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,994 mod
    Options

    What's your operating system? Do you have a M1 mac?

  • manassas77
    manassas77 Member Posts: 13 Member
    Options

    Hi. No, Windows 10 with the latest patches installed, and I am on Cubase 12.0.52. Let me know if you need more information.

  • manassas77
    manassas77 Member Posts: 13 Member
    Options

    Looks like the problem is Maschine 2 related, but not vst3 particularly.

    Just temporarily removed vst3 and booted up Cubase. As before vst2 opens, but empty. Loaded project (saved earlier from vst3 version) but still will not play the project (Using Komplete Audio 6 Mk2 at 256 samples).

    Noise, interference and silence after a few seconds as the CPU load goes through the roof.

    (BTW, a fairly simple Maschine project without any external vsts involved)

    Disable the Maschine track and the project plays fine. I am sending most of the sounds to individual tracks on Cubase - I will try routing everything through the groups and see if that makes a difference.

  • manassas77
    manassas77 Member Posts: 13 Member
    Options

    Just tested same project re-routing all the sounds to 'Group' and same result, CPU overload stops playing.

    However, de-activated all Cubase VSTi outputs - all output now going through Maschine Out 1 (Stereo) and hey presto, project plays without any problem !

    Hopefully you can replicate this at your end ....

Back To Top