Installing Native Access/Traktor on Steam Deck using Bottles?

djrobzilla Member Posts: 1 Newcomer
edited December 2022 in Traktor Software & Hardware

I know this is an obscure use case, but you have to admit it'd be pretty cool to be able to DJ off of a portable game console! I have been trying to figure this out, and so far the advice I received on the Steam Deck Reddit was to use a Wine Prefix loader called "Bottles". I created a new "Bottle", named it Traktor, and then ran the "Native Access" installer. At first everything was going smoothly until it reached the "Installing Dependencies" stage. At this point, I received an error that said:

"please grant permission to Native Access to install dependencies. please restart native access and try again"

So then I searched Native Instruments help desk and found this page:

Ugh, the forum post writer wont let me post the link due to a "security check" (its from NI's own website what the heck lol) but the title of the article is Native Access Freezes on “Installing Dependencies“ at Startup.

Anyway, this article directed me to install NTKDaemon 1.x.x Setup PC.exe, so I ran that exe inside the bottle. However, halfway through installation it crashed.

Has anyone successfully installed Traktor on Linux or maybe even Steam Deck specifically? I'm looking for any advice that might help me get even one step further in this process. I know what I am trying to do is not technically supported by NI officially, but it'd be awesome if I could figure it out anyway. Thanks in advance for any advice you might have!


  • Epexion
    Epexion Member Posts: 7 Member

    Hi man!

    This is not an obscure use case from my point of view. Because of the powerhouse that Steam Deck is it's more than suitable for DJ:ing and music creation. That is the one use case that I had in mind when I bought the whole thing and so far the ableton has quite the community around this matter already. I think they are working mainly on Proton interface (the one that bottles also uses) and they can be found through the "Community releases" of Proton.

    I have a software development background and altough this all seems like a hassle I think it's fully worth it after you get it up and running.

    So the problem with the steam deck is to get the programs to actually run (even after you have done it once or twice..) Another problem is updating the program which takes you all over the installation progress again.. I would try to use software that does not need updating (ie. something else than NI software) however I would love to use my NI synths and software in Steam Deck.

    Even tough I have had this in mind for a while I haven't still looked into it.. I mean I have run bottles and on the deck succesfully now for a while I haven't yet installed Ableton or tested my Push with it (That's my other use case).

    As it is, I would try to contact the people from the Ableton group and ask them what revision of Proton should be used for the Traktor and if they have any tips with installation of the dependancies. I'm a little afraid that the only solution would be to build another revision just for Traktor that fixes these problems or have something setup with preinstalled dependancies without the need to run NTKDaemon.

    (Now when I checked it out google tells me that: "it is a background application that serves a specific purpose, and has no impact on users who do not wish to use the integration features.". However it might have some needed dependancies and must be installed in multiple cases)

    The problem is probably that Native Instruments Software do not recognize being run in a virtual environment and acts off because of that.

    I did some more googling (all this done in 15 minutes) that the Wine apparently has better support for Traktor. ("Traktor 3 itself works quite well on Wine, confirmed by winehq. The splashscreen doesn't vanish, but that's the only problem I've noticed.")

    Further googling took me to youtube video with title "Installing Traktor Pro 3 on Ubuntu" which uses the FL Studio Asio Drivers, as the guys from Fruity Loops have somehow made the only working Asio drivers that works on both mac and Linux, as they run through FL-Studio which was somehow virtually ported to Mac and Linux.

    There is also this guy on the forums that has it already up and running:

    Let's try to put something together shall we? Have you made any progress?

    I'll try to install the traktor to my steam deck tonight and let's see how it goes.

  • Epexion
    Epexion Member Posts: 7 Member

    Ok. So naturally I ended up having the same problems as you described with the Native Access 2 but I experimented a little with the settings and legacy installer of Native Access 1 which can be found from the "Legacy Downloads" section here in Native Instuments site.

    So it felt like whenever I tried to run NA2 every second time I encountered a Java error message on top of the original error message from the installer.

    I changed the Runner to sys-wine-7.0.1 as I saw images and proof of Traktor running on a wine standalone on ubuntu. Of course the SteamOS differs from the Ubuntu and I couldn't even run the stand-alone wine at all at the time being. I also turned off DXVK and VK3D3 to see if it makes an impact and I'm currently using "Windows 7" as the windows version.

    I also turned on the virtual desktop as the bottles have a note that it might help with running some programs. When I did I once again saw the Java error message (I can post the message here in time) but then the installer (NA1) started as it was supposed to. It installed some of the C++ redistributables without no problem but in the end the installer stopped to "Installing the Native Instuments ISO drive". It's still loading but it has been going on for 30 minutes or so and I'm fairly sure it does not proceed.

    After going for google once more I found from LinuxMusicians a tidbit of info that the installation process of ISO Drive must be terminated. You can access it through System Monitor. It seems to be NI-drvinst.exe. I terminated it and the installation says it was succesfull. After closing the window the virtual desktop shutted itself down..

    No success when starting up again.. Java error appears every time.

    Changed back to Caffe-7.18. Bottles tried to run NA2 from the memory I think.. Changed to NA1 installer. Turned DXVK and VK3D3 back on again. (dxvk-1.10.3 and vkd3d-proton-2.6-1-5b). Not totally sure if I got the Java error message but the installer ran succesfully once again and prompted that I have newer version of NA and asked if I want to downgrade. Clicked yes and the installer went through WITH the ISO Driver process. (I already went for it and then it just disappeared and the installation was ready) and once again when clicked the prompt to continue after succesfull install the virtual desktop disappears.

    (Not during this instance but on one of the times before I actually got the Native Access logo on the taskbar on the right in Linux. Can't reproduce while using virtual desktop for fairly obvious reasons)

    At the current point bottles is now opening two virtual desktops with different titles. The first one says "Default - Wine Desktop" and the lower one has some kind of identification instead of "Default" text. What is interesting is that the first window with "Default" DOES NOT bring up the Java error when the second one does... After closing it up both virtual desktops stay alive..

    I tried to locate to locate the installation of Native Access.. You can find your bottles from:


    Keep in mind that .var is a hidden folder so you need to type it seperately to proceed. (Unless you show the hidden folders which I haven't done)

    When opening the actual executable (not the installer) I now get only the Java Error message which made me realize that in the virtual desktop mode it is indeed trying to open the software itself but it ends up crashing upon the Java..

    Wait a second.. Java error in a clean installation of a windows.. Which does not have Java. So into the installation of Java..

    To be continued..

  • Epexion
    Epexion Member Posts: 7 Member

    So I downloaded the latest JRE and tried to install it multiple times through bottles. Every time I failed I needed to restart bottles.

    For some reason the UI of the Java installation does not appear. For this you need to do "Silent Installation" which can be achieved by adding /s to the "Launch Options" from the gear right to "Run Executable".

    I made sure that I had my virtual desktop on again and when I (once again after failed installation restarted bottles) ran the JRE executable I had no prompts and went for the program files I saw Java had popped up there. I was really getting my hopes up.

    I started the NA with virtual desktop with no errors and files loading in the background. I was already hyped to the max but also at the same time I knew I actually had no idea what I was doing. So after couple of restarts changed back to Caffe (Runner) and turned off the Virtual Desktop and once again here we are with the Java Script error.

    Starting to doubt myself if the error has anything to do with Java as the Java Script is totally different thing from JRE.. Found a page from Native Instruments: which instructs you to install all the needed Visual C++ redistributable packages (2015, 2017 and 2019) Usually these are installed by the software wizards as the NA installer did install one of them but any case..

    I move back to the bottles, choose dependacies (These are the one mentioned in my first post. You might want to install them before anything else if you want to try and replicate my steps).

    I only found 2015 and 2019 and went on with the installation.. No effect. Still the same Java Script error message.

    I went on with everything I found interesting (vcredist2013, vcredist6, vcredist6sp6). You should be able to install all of these without any problem. They are usually more useful than in a way. No Effect.

    Went through the dot nets I saw necessary: dotnet35, dotnet46, dotnet48, dotnetcore3. Actually failed in the first installation.. Not worth it. Let's continue..

    Getting pretty hopeless and joining some guy from india for a video tutorial. Moving to the point where we need to make changes to the registry.. (I don't like this) Oh it's the services.. And the tutorial is for the Discord. Waste of time..

    Getting back to basics and trying to install ALL the dotnets.. Usually they need to be installed in order and before doing anymore debugging I decided to go with all of them and see what happens. If (when) this fails I will get deeper into the Java Script error.

  • Epexion
    Epexion Member Posts: 7 Member

    So I managed to install couple of the dot nets (2.0 and 2.0sp1) but couldn’t go through with 3.5 or 4.5. I also installed the microsofts’ media package from the bottles dependancies with no effect.

    I figured out that the two virtual desktops came up because I created a shortcut for the NA client and the installer window (which bottles seems to set ”default” as a title) didn’t give me the java message as it’s not necessarily trying to open the client as I have a separate shortcut for it.

    as for the Java error message I know have two different length logs inside the steam deck which I cannot copy here for the moment but I took a picture out of the virtual desktop to share it with others.

    At this point we might need some help from the NI staff as this does not seem to be generic error.

    However these kind of errors and the error NA2 installer is giving might be able to be passed by changing the ”compatibility mode” through some instuctions online. However with bottles you cannot run the software in compatibility mode.. you can however change windows version from the settings so I’m wondering if this also tries to fool windows.

    The bottles site told me that bottles always starts the software with administrative rights so that should not be it.

    For the virtual desktops I have custom resolution set (native deck resolution so currently around 1280x720 etc). I wouldn’t be surprised if this affects the programs’ ability to start so I might need to start testing with Full HD resolution to avoid further problems.. If this is even possible for the screen being lower density..

    The actual problem might lie in the way that bottles handles the ”home” folder. As in windows these lovely folders we all know under ”documents” are symlinks instead of actual folders. Many programs save data and settings to these folders and if I remember correctly the Native Access is no exception.

    I found an article from bottles’ creators about how to change these symlinks back to the way they work in native windows. I think they forced the current way around bottles 2.0 or something for it being more secure way to handle the folder structure. I will link the instructions here later on after I have tested it.

  • Epexion
    Epexion Member Posts: 7 Member

    Great Success! I was able to login to the Native Access. The icons didn't show up (edit: until 10 minutes or so) but I have Traktor Pro 3 installing now through Native Access 1.14.1.

    I downloaded couple of the dotnets but apparently their (or one of their) installations corrupted the system files and I couldn't start the virtual computer anymore. I resinstalled the dotnet 4.5 and it started up again but Javascript error was still showing up. Decided to scratch evertyhing and start a new bottle.

    So let's try to go through this as carefully as we can..

    I installed the bottle as a "Custom" bottle using Wine (sys-wine-7.0.1) instead of the two other options. I left everything as it is (named it Native Access) and installed vcredist 2015 and 2019 from the dependecies window before turning anything on. Then I started the Native Access 1.14.1 installer and when I was about to set the parameters I realized it was already running the installation.. So I went through with the installation and no error messages popped up. Not even the ISO driver freeze that was apparent during the last iteration.

    The installation window closed so I thought it would be time to create the shortcut for the Native Access.

    I went to /home/deck/.var/app/com.usebottles.bottles/data/bottles/bottles/Native-Access/drive_c/Program Files/Native Instruments/Native Access/ and chose the Native Access.exe without any parameters this time either. Native Access showed up so I logged in and started installing Traktor Pro 3.

    Repeated the steps to add Traktor Pro 3 as a shortcut and keeping the Native Access on the background (it has appeared to the right side corner in SteamOS). I started the Traktor Pro 3 and it's working!

    I've been meddling with the settings but don't seem to be able to get any sound out of the device. The Pulse Audio device should be the one used with the built-in speakers but when I choose them as audio devices (L & R) it says "Disabled". Maybe something else is using the device (OS Maybe?) as I'm running the bottle in desktop mode.

    Unfortunately I cannot continue testing for the moment as I don't have my usb-c adapter with me but I would imagine that with the hardware handling the sound everything should work as supposed.

    As an extra I set up Warpinator (Winpinator for windows) for Steam Deck to transfer any music files WIRELESSLY to Traktor. (Set the path to the bottle C drive and create a folder for your songs) It uses your LAN network with you can setup also without 3rd party programs but this being more or less an open source project it seemed legit. You could also install the Winpinator inside the bottle (which I tried but the deck didn't find my computer even though my computer found the deck) but with Warpinator being native Linux and the fact that you can set the path straight to Traktor folder makes it meaningless and more tedious than necessary. Also you can run Warpinator without the bottle which speeds up the pre-production phase as you can only choose to move some files without opening the bottle itself.

    Interesting note that while skimming the audio properties Traktor managed to install virtual Midi drivers on the background with no hassle. However installation of the plugins is a little too fragile as half of them seem to fail. Take note that I'm working with all kinds of thing at the same time which might affect the installation process. I'm able to download plugins nonetheless.

    If you use this workflow I would maybe name the bottle "DAW-ENVIRONMENT" and try to install Ableton and FL-Studio on the same bottle as that would enable me to use all the installed NI plugins in a daw environment. However if we some day have a robust audio forwarding system on top of this all, the different programs could be run in a different bottles and be connected to each other by audio and midi only. This would need a midi sync implementation too so probably we won't be seeing this anytime soon.. However this would free us from the wonky windows sound drivers as every bottle would be using a different sound card (virtual or physical).

    I will keep this topic alive with the future findings in this reddit post:

    I will also post here the results after testing the actual hardware as that's the only viable use case.

Back To Top