Will Session Guitar work in older versions of Kontakt Player?

robbocop
robbocop Member Posts: 3 Sine

Hi there! First post on here.

I'm interested in buying one of the Session Guitar packs, but for now I cannot upgrade past OS X Mojave and Kontakt Player 6.6.1. The Specifications for SG refer back to those for Kontakt, and only Version 7 is mentioned.

Does anyone have experience running Session Guitar instruments in Kontakt versions older than the current 7.x? Will it work?


Thanks

Tagged:

Best Answers

  • Monochrome
    Monochrome GermanyMember Posts: 357 Saw
    edited November 2022 Answer ✓

    Which 'Session Guitarist' instrument shows Kontakt 7 as a requirement?

    I'm asking because none of them actually requires it? For instance, 'Electric Vintage' says "For use with: Free KONTAKT PLAYER version 6.5.2 and higher, or KONTAKT version 6.5.2 and higher." on its product page way down below. Other 'Session Guitarist' instruments may have different version requirements, but if you're on 6.6.1, all of them - except 'Electric Mint' and 'Prime Bass' - should work with your version.

    Edit: Actually, 'Electric Vintage' does say "requires Kontakt 7" on the buy now page. Interesting... @Jeremy_NI, what's the correct version for it?

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 3,811 mod
    edited November 2022 Answer ✓

    @robbocop Yes, some info is missing on the Electric Syunburst product page. Since it's an older library it is probably ok for Kontakt 6 (looking into that).

    @Monochrome Once you hit the BUy button you just get a reminder that Kontakt or Kontakt Player is needed to load the library. The current version of Kontakt is then showed, it's not a system requirement.

Answers

  • robbocop
    robbocop Member Posts: 3 Sine

    I answered my own question. when I added Session Vintage electric to my shopping cart the checkout page told me that yes, this will work in Kontakt 6.

  • Monochrome
    Monochrome GermanyMember Posts: 357 Saw
    edited November 2022 Answer ✓

    Which 'Session Guitarist' instrument shows Kontakt 7 as a requirement?

    I'm asking because none of them actually requires it? For instance, 'Electric Vintage' says "For use with: Free KONTAKT PLAYER version 6.5.2 and higher, or KONTAKT version 6.5.2 and higher." on its product page way down below. Other 'Session Guitarist' instruments may have different version requirements, but if you're on 6.6.1, all of them - except 'Electric Mint' and 'Prime Bass' - should work with your version.

    Edit: Actually, 'Electric Vintage' does say "requires Kontakt 7" on the buy now page. Interesting... @Jeremy_NI, what's the correct version for it?

  • robbocop
    robbocop Member Posts: 3 Sine

    Thanks for replying. Yes it did hint that Kontakt 7 was the required version in that on the Session Sunburst product page the link to System Requirements only goes to the Kontakt 7 page. But after I added it to the checkout, the sidebar on THAT page says it works in Kontakt 5 or higher. Anyway, I purchased Session Vintage guitar and it works fine in Kontakt Player 6.6.1. Screenshots of the Product page and the Checkout page attached.


  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 3,811 mod
    edited November 2022 Answer ✓

    @robbocop Yes, some info is missing on the Electric Syunburst product page. Since it's an older library it is probably ok for Kontakt 6 (looking into that).

    @Monochrome Once you hit the BUy button you just get a reminder that Kontakt or Kontakt Player is needed to load the library. The current version of Kontakt is then showed, it's not a system requirement.

Back To Top