Komplete Kontrol 2.8 Logic Pro: Mute and Solo keys don't work

ChicagoBob
ChicagoBob Member Posts: 6 Member
edited November 2022 in Komplete Kontrol

I noticed after the update that the Mute an Solo keys don't work-- they only M or S the top track. This didn't work in native mode but did work in Rosetta. Now it doesn't work in either mode. Seems like the other transports work so far.

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,832 mod
    Answer ✓

    We couldn't reproduce the issue. Let's check a few things.

    Do you have any other devices connected ? Control Surfaces ? keyboards ?

    Make sure to add Logic and Komplete Kontrol to the list of programs with Full Disk Access: How to Enable Full Disk Access on macOS

    Deleting the this file can also help:

    Macintosh HD/Users/your user name/Library/Preferences/com.apple.logic.pro.cs

    Accessing the Hidden User Library (macOS)

    Restart your computer, open Logic, connect the keyboard again.

    Does that fix the issue?

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,832 mod

    @ChicagoBob What model of keyboard, what Mac and what MacOs are you using?

  • ChicagoBob
    ChicagoBob Member Posts: 6 Member

    Using S88mk2 with latest logic and MacOs

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,832 mod
    Answer ✓

    We couldn't reproduce the issue. Let's check a few things.

    Do you have any other devices connected ? Control Surfaces ? keyboards ?

    Make sure to add Logic and Komplete Kontrol to the list of programs with Full Disk Access: How to Enable Full Disk Access on macOS

    Deleting the this file can also help:

    Macintosh HD/Users/your user name/Library/Preferences/com.apple.logic.pro.cs

    Accessing the Hidden User Library (macOS)

    Restart your computer, open Logic, connect the keyboard again.

    Does that fix the issue?

  • ChicagoBob
    ChicagoBob Member Posts: 6 Member
    edited November 2022

    Thanks-- I was able to get it to work but had to delete KK within Logic as well as what you suggested

Back To Top