Is there a “global edit” in the Auto Sampler?

OhulahanBass
OhulahanBass Member Posts: 135 Pro
edited November 2022 in Maschine

I have been building some great instruments from my analog hardware mapped over several octaves, often with velocity layers. The number of samples is in the hundreds. All I want to do is select all so I can turn loop on and off but when I ctrl-A every sample is selected but the edit will only effect one of them.

What am I missing here? I feel like this use to be possible.

Tagged:

Comments

  • OhulahanBass
    OhulahanBass Member Posts: 135 Pro

    Anybody find a work around for this?

  • OhulahanBass
    OhulahanBass Member Posts: 135 Pro

    Hmmm, I assume no one has an answer to this question. What is the best way to report bug or request a fix to NI?


    I assume this is a bug, why would you allow a select all if you can’t use it to edit all?

  • D-One
    D-One Moderator Posts: 2,755 mod
    edited November 2022

    Humm.... It's always been like this so not sure it's a bug; IMHO it's just the lack of a feature/functionality that is made more obvious by introducing another feature (Auto Sampler in this case).

    None of the parameters even within the Zone menu can be applied to all selected Samples, the real issue is that it's not technically multiple samples we are selecting if we hit CTRL/CMD+A, it's the velocity ranges... That's what we are truly selecting.

    Basically, multi-selection only serves the purpose of dragging the GUI handles that change the Vel range, and nothing else.

    On the Sample list only the file highlighted in the Pad Color (orange) is the one we can actually change parameters in, the other selected ones in white color are unaffected due to the explanation above but dragging the range be works while the grey ones arent.

    NI tends to release features and quickly move on, I doubt this will be addressed now but it should. ☹️

    Anyway, @OhulahanBass I think the fastest way to do what you want manually is to click thru the sample list, one by one while your HW is focused on the Sampling>Zone Menu Page 3 and turn the Loop Knob.... Quite the hassle to click and turn a knob hundreds of times but hey... it's the Maschine way.

  • OhulahanBass
    OhulahanBass Member Posts: 135 Pro

    Nooooo!


    I was really hoping I was doing something ignorant and that the solution was there. I guess I will have the default to no loop unless there is a supper consistent and long sustain tail. I'd say about 40% of the time I try a sound that should loop fine the loops are useless and terminate with artifacts regardless of xfade. It would be a much smaller issue if we could just use the shift button to switch the toggle to a global toggle.

    Is there anyone at NI we can @ to get into the conversation?

  • D-One
    D-One Moderator Posts: 2,755 mod
    edited November 2022

    @OhulahanBass When creating your multi-sample patches the Find Loop option doesn't work for you?

    There's free apps out there to mass edit wavs and add loop points, not sure if MAS can read that metadata info tho.

  • OhulahanBass
    OhulahanBass Member Posts: 135 Pro
    edited December 2022

    Auto Loop work well some times, but on some sounds it struggles to find a loop that doesn't sound glitchy as it retrigs, this would be fine if I could simply turn the loop feature off in retro. Unfortunately you can only do this one sample at a time.

    The less harmonically rich the tail of your sampled sound the less likely you are to have an issue with auto loop. The work around is to thoroughly check each velocity layer of samples through the octave range to see if you get allot of those glitches, and resample with auto loop turned off. But if I could just kill the auto loop problem solved. Also, sometimes the tail of the patch is so characterful that I regret auto looping it in the first place because it isn't worth loosing the natural release, but in retro there is nothing that can be done.


    Thank you for engaging on this thread, sorry if it seemed I ignored your response, I haven't been back here in a while.

Back To Top