Guitar pro 6 crashes on startup. Help!

Options
Stefd
Stefd Member Posts: 2 Member
edited October 2022 in Guitar Rig & FX

Hi,

I have a problem with guitar rig 6 version 6.2.4 on Mac OS 12.6

It keeps crashing both when i load it in my DAW (logic version 10.7.4) or when i launch it as a standalone.

I tried deleting the GR6 files in the Application Support folder, the Preferences folder, and i tried reinstalling several times. I also gave both Native Access and GR6 full disk access in my security and privacy settings. All of that didn't work and i'm at a dead end.

Can somebody help me get GR6 running again?


Error message below:

Exception Type:    EXC_BAD_ACCESS (SIGSEGV)

Exception Codes:    KERN_INVALID_ADDRESS at 0x00002f746e65846c

Exception Codes:    0x0000000000000001, 0x00002f746e65846c

Exception Note:    EXC_CORPSE_NOTIFY


Termination Reason:  Namespace SIGNAL, Code 11 Segmentation fault: 11

Terminating Process:  exc handler [1247]

Tagged:

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod
    Answer ✓
    Options

    @Stefd To be clear you deleted those files:

    Macintosh HD > Users > Username > Library > Application Support > Native Instruments > Guitar Rig 6

    Macintosh HD > Users > *Your User Name* > Library > Preferences > com.native-instruments.Guitar Rig 6.plist

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:

    What soundcard are you using with Guitar RIg 6? Is your Mac Intel or M1?

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod
    Answer ✓
    Options

    @Stefd To be clear you deleted those files:

    Macintosh HD > Users > Username > Library > Application Support > Native Instruments > Guitar Rig 6

    Macintosh HD > Users > *Your User Name* > Library > Preferences > com.native-instruments.Guitar Rig 6.plist

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:

    What soundcard are you using with Guitar RIg 6? Is your Mac Intel or M1?

  • Stefd
    Stefd Member Posts: 2 Member
    Options

    @Jeremy_NI

    Thanks a lot Jeremy!

    I didn't know the Library folder was hidden. I deleted the files in another Library folder so I just assumed I deleted the correct files. Boy was i wrong.

    I installed GR6 again after deleting the correct files this time and it all works again. Thanks for the reply!

Back To Top