Wine about NA2

royleith
royleith Member Posts: 5 Member
edited October 2022 in Native Access

I have been running Komplete in Linux wine for some time, for the occasional quick and dirty demo . I use the winehq development branch and have used Native Access 1 to install items (installs fail, but leave installation isos that can be mounted and run in Linux). I used to use Reaper in wine (lovely bouquet!), but now use native Linux Reaper and yabridge.

I still use a Windows 10 desktop for serious work and a Windows 11 laptop for recording elsewhere. I use Izotope and Waves on these machines.

Native Access 2 seems to install OK in wine, but stops loading with the following message,

__________________________________________________________________________

Please grant permission to Native Access to install dependencies. Please restart Native Access and try again.

Release: 2.6.2

__________________________________________________________________________

I've tried installing NTKDaemon 1.5.0 Setup PC.exe, and running NA2 in a Windows 10 and a Windows 7 environment, but it still stops at the, above, message. If anyone knows of a way around this, I would be very grateful.

Comments

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,887 mod

    Hey @royleith Linux or Wine is not supported. Maybe a Linux user in the house can help. 🤞

  • GoaSkin
    GoaSkin Member Posts: 25 Member

    I tried to find out the reason why the NTK daemon doesn't start but the debugging information doesn't helps me.

    Maybe anybody should start a thread at a lively linux audio forum or at the WINE project site.

  • GoaSkin
    GoaSkin Member Posts: 25 Member
    edited December 2022

    There is a thread on the WINEHQ forums now and somebody figured out that the only reason why the NTK daemon does not start is a missing 'Downloads' folder inside the WINE user homes.

    https://forum.winehq.org/viewtopic.php?t=36977

    I had to dive into ~/.wine/drive_c/users/Public and to call 'mkdir Downloads' there.

    But like written in the thread, only the login screens of NA2 appears now. After entering your credentials, the login procedure requires an infinite time.

    Maybe, anybody finds out how to fix this also.

  • drahcirj
    drahcirj Member Posts: 3 Member
    edited October 2023

    @royleith Did you get this to work? I'm trying to install Native Access, any version, in a Bottle, but it keeps crashing. I don't know what dependencies to install.

  • GoaSkin
    GoaSkin Member Posts: 25 Member

    Native Access 2 works now on linux if you follow this instruction:


    https://appdb.winehq.org/objectManager.php?sClass=version&iId=41820

Back To Top