Kontakt 7 player opens black window

2

Answers

  • jay001
    jay001 Member Posts: 1 Newcomer

    Can someone tell me if rolling back to an older version solves this issue as well?


    I am have issues with Kontakt loading with blank screen and also the Glaze instrument attempting to load, then crashing the Maschine DAW application. I think it tied to the same issue.

  • DavPeMa
    DavPeMa Member Posts: 7 Member

    Hi Jay001

    This answer only applies to Windows as I don't have a Mac so can't comment on that. But on my machine v7 was a separate install to v6 and as such they work side by side. If v7 doesn't work for you and none of the suggested fixes already given don't fix the issue (which I'm afraid they didn't for me) then you can just go into your windows apps settings and uninstall v7 (not from inside the Native Instruments app). Or you can just leave it unused and use v6 instead, but it does mean you're wasting around 432 mb disk space if you take that approach.


    HTH

  • jps56
    jps56 Member Posts: 1 Member

    Hi I created a Kontakt7.bat file with the following text and it works for me. I also renamed the Kontakt 7.exe to Kontakt7.exe.

    cd..

    cd..

    cd..

    set QSG_RHI=1

    set QSG_RHI_BACKEND=opengl

    cd Program files\Native Instruments\Kontakt 7\

    start Kontakt7.exe

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,850 mod
    edited November 2022
  • kitekrazy
    kitekrazy Member Posts: 6 Member

    Could you further elaborate? Do I just copy and paste your text and rename it .bat?

  • Peter Hintze
    Peter Hintze Member Posts: 9 Newcomer
    edited November 2022

    How about giving the user the option to use OpenGL or another graphics standard in the options menu? instead of fiddling around with cmd and bat files?

    and an information window during install or start up - like Dave described - telling the user to try dxdiag and to change to openGL via the menu

  • Peter Hintze
    Peter Hintze Member Posts: 9 Newcomer

    @Jeremy_NI

    A friend of mine has the same problem, and the openGL hack does not work. He upgraded to Kontakt 7 only knowing it needed "Direct 3D 11.1" . The Feature Level requirement "(Feature Level 11_0)" was added after he upgraded, on the website FAW as far as i understood him. What can he do?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,850 mod
    edited November 2022
  • donnydee
    donnydee Member Posts: 1 Newcomer

    There's still no fix for this issue. I crashed into this problem headlong after updating Kontakt a day ago. I have the exact same graphic specs as that screenshot above. Everything else about my PC is good. I'm not using my PC for gaming so I really didn't give much thought to graphics in the first place. It seems like there's always something weird going on with Maschine nowadays. I'm scared to load it up because of what may or may not be working. I just came out of a 2 week long crash that involved tech support. All because I switched to a different computer. I am tired of this. Give us some backwards compatibility options or rollback update feature.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,850 mod

    @donnydee I'm a little confused here. You mention this issue with Kontakt and then Maschine. You also mention that our tech support was involved but I can't find any requests with your email address/NI account. In any case if you need assistance on this, please get in touch with my colleagues here: http://bit.ly/NIsupport_kontakt

    To speed up things, please include a screenshot of that:


  • VidarScreamed
    VidarScreamed Member Posts: 1 Newcomer

    I am having similar issue. Only I am on Mac and k7 loads black screen but functions to a degree if you’re lucky enough to click on correct spot on blackness. “Start from .cmd file” as mr monotone suggest. This can be done in Mac also? I run i5, I run basic gpu, support metal 2, support directx11.1, but no features section in Mac specs so I don’t know how proceed

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,850 mod

    @VidarScreamed What kind of Mac is it? M1, Intel, Macbook? and what operating system do you have? Do you use a second monitor?

  • NRB
    NRB Member Posts: 1 Newcomer

    Hi everyone, the same here Mac 14.1 OS 13.3.1, kontakt 6.7 work fine. K7 black screen ... also in Komplete Kontroll all NI-produkt with black screen. In KK Vendors like Arturia working fine ....

    Thank you all for the help.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,850 mod

    @NRB What model is it exactly? Do you use external monitors? Can you post a screenshot?

  • Chachor
    Chachor Member Posts: 2 Newcomer

    Hi, i have the same problem. I have OSX 13.3.1, Imac 15.1.


Back To Top