Automation turns off when pausing audio. (KK, Ableton)

TomerBass
TomerBass Member Posts: 8 Member
edited October 2022 in Komplete Kontrol

Hey guys,

I am struggling with a really annoying problem lately, hope you could help:

1. I record a (beautiful) track using my KK M32 and the KK plugin.

2. during the record I play with the midi knobs to record automations. (Which works fine!)

3. as soon as I stop recording, one automation becomes disabled, rest of the automations are just fine.

4. I re-enable it, and play the track, it runs flawlessly.

5. as soon as I pause again (space bar or the squared stop button), the *same* automation goes disabled

6. repeat 4 and 5 for eternity


Some more info:

  • It happened to me in several midi files, in several projects.
  • I suspect it is only KK, since it never happened in any other plugin I have as reactor or waves plugins.
  • I am 90% sure that the automation that turns off is the automation of the parameter that is assigned to the left-most rotator knob I have on my midi keyboard.
  • I have updated the plugin to the latest version.
  • I use Windows 10, Ableton Live 11, KK M32.


REALLY annoying, any suggestions?

Thanks in advance. I am willing to give more details if I only knew what the exact details you need =]

Best Answer

«1

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,916 mod

    @TomerBass Could you check in the Komplete Kontrol standalone application, keyboard disconnected if there are any MIDI assignments

    Click the little cross to cancel the assignment.

  • TomerBass
    TomerBass Member Posts: 8 Member
    edited October 2022

    I have checked this screen while the keyboard disconnected, and yes, there is midi assignment on this specific knob and I have canceled it.

    But when I opened Ableton the problem still existed.

    Is there any "save" button I should have pressed? whenever I open Komplete Kontrol standalone again the assignment is still there. (Keyboard is still disconnected, and I repeat the process several times.)


    Thank you for your reply!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,916 mod

    What CC number on this assignment ? Do you have other MIDI devices connected ? Can you check with only the keyboard connected and no audio software if the keyboard emits MIDI information even when not touching anything ? How to Monitor the Input of a MIDI Controller

  • bobbyduracel
    bobbyduracel Member Posts: 28 Member

    I have the same issue. I can set up a new project, with ZERO midi controllers connected, NO midi mappings in ableton live saved… and when i hit “STOP” the orange button up top lights up - indicating i have to re-enable automation. The automation it refers to is often the first knob to the left, or the cutoff freq… in Diva (within KK) it drops the cutoff to 30hz every time hit stop - however i hit stop, midi controller, space bar, mouse…

    In Analog dreams it moves the left-most knob to blend A/B, down to 0/100%.

    This only started with the new KK14Ce update and live 11.2, and now my projects which contain a lot of KK instances are generally unplayable. My only workaround is to write automation lanes for the knob involved and quickly “re-enable” automation after hitting play… and this needs to be written for EVERY instance of KK, based on whichever knob is inaccurately being affected.


    The same plugins without the KK wrapper function perfectly, stock plugins function perfectly… just KK.

  • TomerBass
    TomerBass Member Posts: 8 Member

    The CC number is 123 (every time). I don't have any other MIDI devices connected, and I have checked with MIDI-OX, no emitted midi happened without me pressing a key.

    I have checked it both for Komplete Kontrol M32 MIDI and for Komplete Kontrol M DAW , (Both names refer to the same device). there is nothing else connected but the M32.

    Thanks again! Anymore ideas?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,916 mod

    @TomerBass CC 123 is the message for All Notes Off. Ableton shouldn't send these messages when stopping. Some Ableton users use a Max4Live patch to enable this. Is it the case for you ? Is there anything loaded than the Komplete Kontrol plug-in loaded on the track ? Can you reproduce the issue in a default Ableton project, not a template ?

  • TomerBass
    TomerBass Member Posts: 8 Member

    Hey!

    I'm just refining, in case I wasn't clear: the problem I described happened in Ableton. But after you asked me, I also checked the KK standalone without opening Ableton at all, and whenever I re-opned the standalone, the cc123 was there on the leftmost knob even if I canceled it in the previous opening.

    I have never used Max4Live, but I will check if anything there is activated.

    I will also try to reproduce the issue and update soon.


    Thanks again!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,916 mod
    edited October 2022

    @TomerBass Ok, thanks for that clarification. If it also happens outside of Ableton, check MIDI assignments in the Komplete Kontrol standalone application, both when the keyboard is connected and disconnected. Look for a 123 CC or unusual assignment, check the assignments for pedals, modwheel, buttons.

  • TomerBass
    TomerBass Member Posts: 8 Member

    When the keyboard is disconnected this is my screen when opening KK (even if I cancel the CC 123).

    When my keyboard is connected, where should I look for such assignments? (I don't think there are any..)

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,916 mod

    When disconnected check the buttons section too:

    When connected, check every section here:

    Etc....

  • TomerBass
    TomerBass Member Posts: 8 Member

    Thanks, it seems like there are no assignments at all

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,916 mod

    @TomerBass When the keyboard is connected, there are assignments by default, can you post a screenshot showing the absence of assignments ?

  • TomerBass
    TomerBass Member Posts: 8 Member

    Does it look ok?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,916 mod

    It does look ok, have you checked under the 8 knobs, pedal ring ? So when does this 123 message arrive exactly ? If you only open the Komplete Kontrol standalone application, unassign CC123, open the MIDI monitor, at what moment does the CC123 appear ?

  • TomerBass
    TomerBass Member Posts: 8 Member

    Ill describe the flow both in ableton and in the standalone:

    Ableton

    As described in the thread starter post, with some more information I found lately:

    1. I record a track using my KK M32 and the KK plugin.

    2. during the record I play with the midi knobs to record automations. (Which works fine!)

    3. as soon as I stop recording, one automation becomes disabled, rest of the automations are just fine.

    4. I re-enable it, and play the track, it runs flawlessly.

    5. as soon as I pause again (space bar or the squared stop button), the *same* automation goes disabled

    6. repeat 4 and 5 for eternity


    More important information:

    • I have opened Ableton with my keyboard disconnected, reached the MIDI page in the KK plugin (as you showed me), and the CC123 was there. *I canceled it, and it fixed the issue for the session*
    • when I opened the same project again, the same problem returned.


    Standalone

    Usually I don't use the standalone so I dont really have problem there, I just did the checks you told me:

    so whenever I open it, there is the CC123 assigned to the leftmost knob as shown in previous photos.

    If I cancel it, than close the program, and open it again, the CC123 is there again.

This discussion has been closed.
Back To Top