M1 - "installation failed"



  • likenokevin
    likenokevin Member Posts: 1 Newcomer

    Thanks, Jeremy! Giving NTKDaemon full disc access is what worked for me. I had given Native Access full disk access but it kept failing until I added the second app to the list.

  • Julzantoine
    Julzantoine Member Posts: 2 Newcomer

    Hi. I gave all the permission but it didn't solve anything. Is there another turnaround which might help? Native access fails to install libraries and don't find some which were already installed (invalid path).

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 5,319 mod

    @Julzantoine Have you installed these missing libraries installed on an external hard drive, what's the format of that drive?

  • Monochrome
    Monochrome Member Posts: 622 Guru

    Ventura isn't fully supported yet. The only NI software that is are KOMPLETE KONTROL and MASCHINE (at the time of this writing):

  • GrettaDog
    GrettaDog Member Posts: 1 Newcomer

    Jeremy_NI comment seems to have resolved the issue for me. Fighting this for a couple day with my new MacBookPro M1. To summarize the fix:

    1) Check all folders in Download, Application and Content locations by doing Get Info in Finder for full Read and Write access permission. Click lock at bottom right to make changes.

    2). Be sure Full Disk Access is granted for NI applications under System Settings> Privacy and Security> Then under "Privacy Section" scroll down to "Full Disc Access" right arrow. Will open up the NI apps, and you slide them all to "on".

    If it fails immediately on download, it is probably disc write privileges, if it fails at last point in installation, probably Full Disc Access. When all is working you will see the temporary install folder for the app you are installing show up on your desktop. If you get that far, it should complete.

  • Partylifemusic
    Partylifemusic Member Posts: 1 Newcomer

    Happy Holidays friends!

    I believe Jeremy from NI solved the issue that we are all having.

    Here's what I'm working with:

    Apple 1 Max

    Ventura 13.0.1

    32 GB of Ram

    1TB SSD

    Issues: Installation would run and then stop. Error Message in terms of file path. Error Message for installation. Re-installing still not working. Changing file-paths.

    Solutions I've Tried: I tried moving folders in other locations. Under the applications tab I installed those folders within the internal drive but for the expansions I tried to install on an external hard drive just because it's a huge amount of space that it requires.

    Previously I had an Intel I7, 8GB of ram, 500 SSD, running Monterrey and took me forever to. move everything. As I was having issues on the new Mac book pro I purchased, I decided to just delete everything and start from scratch.

    Final Solution: For new MacBook Pro users or anyone using the M1 & M2 chips, Native Access will work as long as you have the permissions turned on under the privacy and security. So if you see Native Access and the other NTKDaemon on your list, make sure they are turned on and you see blue after you check them. If you don't see blue and if they don't appear in your drop down list under FULL DRIVE ACCESS then you will continue to have installation issues.

    New Mac Users: If you previously were running Native Access on older Mac's, the look is different and the only thing we had to focus on was making sure they were on that list. For new Mac Users, not only do we need to see them on our list, but you need to make sure that both Native Access and NTKDaemon is turned on or it won't work.

    I installed a few folders in the MB region of space, and one folder in the GB, now I am installing all folders right now and will report on what happened.

    Like you all I don't have the time to go one by one so I hope this work, but for the 5-6 folders I tried one by one it worked.

    Hope this helps ease the frustration. Happy Holidays!

    Hey people, make sure to give Full Disk Access to Native Access and to NTKDaemon as well. If the NTKDaemon is not listed, click the symbol to add it from this folder: Macintosh HD > Library > Application Support > Native Instruments > NTK

  • Svein
    Svein Member Posts: 1 Newcomer

    Did everything explain above. Stil problem. Then formatting external disk to APFS. Everything works fine 👍

  • Shorty
    Shorty Member Posts: 1 Newcomer

    Today I upgraded to Komplete 14 Collectors Edition.

    I have the same problems on Mac. Installation failed all the time. And yes, NI has Full Disk Access. I also reformatted the disk to apple filesystem.

    The next problem is that nothing is installed, there is no folder for the new failed instruments on disk, but I can not re-instal! I only have the option to select the installation folder, which does not exist, or to press the "Locate" button. Problem is, there is nothing to locate!

    I need help very fast...NI! I paid a lot of money and would like to use the software NOW!

  • adamboy
    adamboy Member Posts: 1 Newcomer

    This same issue is occurring with me. I am performing a clean install on a new laptop. It is a MB Pro, M1 Pro Chip running OS 13.0 (Ventura). Aside from the installation failure messages I am receiving-- with only three ever being successfully downloaded, I am seeing several more issues:

    • Upon opening NI Access, it takes ~1-2 minutes "Activating Products" and then ~3 - 5 minutes "Loading Products".
    • After the first few times restarting the NI Access app attempting to resolve the core issue, the number of "Available Products" varied each time and at the present moment, I am only seeing two. Having Komplete 14, I should have many more than this.
    • The "Application location" within the Preferences tab in NI Access has an error message that says "Installation failed, please check if that folder exists...ensure the folder has read/write permissions". This is the default location and was never touched. Both NI Access and NTKDaemon have Full Disk Permissions.

    Any help is appreciated.



  • Andy Comfort
    Andy Comfort Member Posts: 1 Newcomer

    Same issues here. Trying clean installs on macOS 13.0.1 via Native Access 3.0.1. Did everything mentioned here, nothing helps. I'm so fed up, i think i will sell everything i own from Native Instruments.

  • TQ
    TQ Member Posts: 1 Member

    I had the same issue here, and there was one additional step that solved this: I had to change the permissions for the desktop. For some reason, "everyone" did not have read and write permissions for the desktop, and that somehow prevented the dmg to do its thing.


    (a) I gave full disk access for NI Access and NTK

    (b) changed the permissions to read/write for the destination folder

    (c) changed the permissions to read/write for the desktop

    and then it worked. Good luck guys!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 5,319 mod

    @Shorty Have you checked that part?

    Hey people, make sure to give Full Disk Access to Native Access and to NTKDaemon as well. If the NTKDaemon is not listed, click the symbol to add it from this folder: Macintosh HD > Library > Application Support > Native Instruments > NTK

    I also see you didn't contact our support, feel free to do so when that doesn't help.

  • Isak Nordh
    Isak Nordh Member Posts: 1 Newcomer
    edited December 2022

    This is really expensive software, so a warning to everyone out there. I hope this is just a matter of user friendliness and feedback on what is not working from the software. It seems that way to me.

    Apart from expecting that it should work to install my purchased products (Komplete 13 Ultimate) out of the box, I've now wasted soo many hours on system manipulation and re-installation attempts. I've tried:

    • Changing the folder rights for the application location (previously no rights for the "everyone" user). Why would I need to do this? I've installed so much software in my days? Anyways, it solved the error message (red mark) next to the application location folder setting. Content are then able to proceed from only downloading, to also installation. It then fails at the end of the installation process. No error log or message, nice. Just the obvious - it fails.
    • Changing the folder rights for the desktop --> everyone user: R&W.
    • Disk access to NKT Deamon and NI Access
    • Numerous restarts
    • Finally, what seems to be making the difference for me; Formatting my external drive to Mac-specific file format. When doing this, one library install actually worked!! An error message explaining just that would be lovely.

    My actual error messages though, or rather vague pointers, send me in the direction of fixing issues with me application folder. However, the real error for me then, was the library folder and the ability for the installer to first install and then move content from my internal drive to my external one. At that stage, it failed.

    On the other hand, there seem to be something fishy with the application folder as well. Why in the world do I also need to change its folder settings to allow the "everyone" user have R&W access? Must be the first time an installer software needs the admin to manually do that, eh?

    Good luck out there!

  • nick_gva
    nick_gva Member Posts: 1 Newcomer

    I'm stuck with the fking permissions. Running Monterey OS with M1 Pro. Was anyone able to solve it? Tried everything and still doesnt work.

  • robinibbo
    robinibbo Member Posts: 1 Newcomer

    This works - change your designated File Management folders in Native Access Preferences to a drive that is Mac OS Extended (Journaled) format. If you, like me, are trying to install using ExFat Samsung T7 SSD it will not work.

    You can prove this by formatting a memory stick to Mac OS Extended (Journaled) and change Native Access File Management folders preferences to point to it, then install something small like Phasis or Raum and it will work. Change it back, try again, it will fail.

    I can appreciate everyone's frustration, I've only been using a Mac for a month, it's just too hard some days!

    This oldie but goodie video will provide some light relief https://youtu.be/8AyVh1_vWYQ

Back To Top