M1 - "installation failed"

Options
LamainMusic
LamainMusic Member Posts: 7 Member
edited September 2022 in Native Access

Good afternoon!

I recently purchased a Mac mini (M1, 2020; OS 12.5.1) and have been slowly rebuilding my libraries and plugins.

One of the last to finish is Kontakt. The screenshot below is of the items that will not install. When the download finishes, it will say, "Installing" that eventually changes to "Installation failed."

I have tried running Logic on Rosetta. I have tried uninstalling and reinstalling Native Access. I have tried restarting the computer.

According to this article, these items should work with my OS.

native instruments /hc/en-us/articles/360014683497-Apple-Silicon-M1-M2-Compatibility-News

Any help is appreciated.


Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod
    edited December 2022 Answer ✓
    Options

    Hey people, make sure to give Full Disk Access to Native Access and to NTKDaemon as well. If the NTKDaemon is not listed, click the symbol to add it from this folder: Macintosh HD > Library > Application Support > Native Instruments > NTK

    How to Enable Full Disk Access on macOS

«13

Answers

  • Ronny Bangsund
    Ronny Bangsund Member Posts: 71 Helper
    Options

    Those are server issues, most likely. As long as you're using Native Access 2.6.2, there isn't much else you can do but retry, even restarting the app in some cases. This must be especially painful for people trying to install CE!

  • LamainMusic
    LamainMusic Member Posts: 7 Member
    Options

    This is super helpful.

    I did check--yes, I was using Native Access 2.6.2.

    I've tried a few times today and am still getting the same "installation failure" message.

  • Nico_NI
    Nico_NI Administrator Posts: 1,124 admin
    Options

    I'd suggest not to install all the products at once. Maybe pick the ones you want to try first!

  • LamainMusic
    LamainMusic Member Posts: 7 Member
    Options


    At this point, I've installed what would install and restarted my computer multiple times to see if that helps. And I'm still receiving the "Installation failure" message for Komplete Kontrol and Kontakt.

  • LamainMusic
    LamainMusic Member Posts: 7 Member
    Options

    Just went one by one, and Kontakt and Komplete Kontrol fully installed. Appreciate the help!

  • AMarie
    AMarie Member Posts: 1 Newcomer
    Options

    Same here. New computer, tried installing one by one... still have "Installation failed" message. I reboot the computer many times in between attempts...

    I changed the permission in my computer preferences to all access to NI softwares. Still not working


    Any ideas?

  • DJ RX-78
    DJ RX-78 Member Posts: 11 Member
    edited November 2022
    Options

    I've been running into the same issue on my new macbook. Some will install, while others will continue to fail installing. I've personally tried installing one at a time, but it's not a guarantee, even with all the access permissions being open.

    Hoping that the folks at Native Instruments' support can help me because it would be a shame to have dropped some serious coin to not even be able to use everything I've bought.

  • Marc_68
    Marc_68 Member Posts: 1 Newcomer
    Options

    I have similar issues. I have an intel iMac, updated to OSX 13.01 Ventura. Updated Native Access.

    Some "old" instruments still run perfectly, however any new seem to require KONTAKT and that is then shown as a "dependency" but fails to install. I have been able to update all installed items a few days ago, but since then I can't install any newer items from the list. In The Software folder I had KONTAKT 5 and KONTAK (6 I assume) listed. I have deleted them to try to re-install them, but this fails as well.

    I have not been able to find information on a more detailed error log - something that may tell my what the exact cause of the error is. As a well aged (54) IT-Professional I may even be able to understand logs, if they existed. But left with only two words "Installation failed" and a red button and the only option to "try again" (and again and again), I'm a bit fed up with this.

  • Sajan K
    Sajan K Member Posts: 7 Member
    edited November 2022
    Options

    I have a M1 MacBook Pro.

    I have set the power to be never turned off.

    I have an excellent internet connection (500+Mbs)

    Download location: /Users/name/Downloads

    Application Location: /Users/Shared

    Content Location: /Volumes/External Drive name/NI Libraries

    I have 229 items I am trying to download and install with Native Access 3.0.1

    Successfully installed 35 items.

    Now getting Installation Failed messages in all my other items to install.

    Tired installing individual items and still same message.

    Marc68 I am with you ... getting frustrated .... It shouldn't be this hard... it never was...

    Please help....

  • PatchesFlows
    PatchesFlows Member Posts: 1 Member
    Options

    yooo ****** native instruments, fix your totally ****** software. you finally got a new installer and it still sucks?! seriously waht is your problem... YOU CANT WRITE AN INSTALLER?!?!? ughhh so frustrating. im getting the exact same error, have checked all permissions and even deleted the temp download files. FIX YOUR TRASH INSTALLER!

  • kellsmadeit
    kellsmadeit Member Posts: 4 Member
    Options

    Im getting the exact same error on a iMac Pro Intel running Monterey

  • 6ixmélo
    6ixmélo Member Posts: 1 Member
    Options

    Hello Guys, exactly the same problem.

    Can not install my komplete 13 ultimate...

    I hope this problem will be fixed fastly ******

  • BMac
    BMac Member Posts: 1 Newcomer
    Options

    I’m having the exact same issues for a few weeks now. I have the M1 MacBook air on the Ventura system. NA Downloads read failure every time. Its very frustrating, especially when NI help can’t even figure it out.

  • adarkerflame
    adarkerflame Member Posts: 2 Member
    Options

    Exact same problem and got so frustrated. I found a fix that should work (though it's not a pretty fix!). I'm on MacOS Monterey btw.

    First, I had to download the older Native Access version (1.14.1). Then I selected the folder where I want the downloads to go. Installations don't happen anyway, so I ignored that.

    Once your downloads are done, you'll find an .iso file in the folder you selected for downloads. On the new Native Access, these files get deleted immediately after failed installation. On the old Native Access these files remain on your computer! Open this file with the disk image. Now open this new "disk" (you'll see it in Locations). Then open the .pkg file (or .exe if you're on a windows machine), and you can manually install the library to a location you want it to go!

    This seems to be working for me - hope this helps some folks out here as well! :)

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,314 mod
    edited December 2022 Answer ✓
    Options

    Hey people, make sure to give Full Disk Access to Native Access and to NTKDaemon as well. If the NTKDaemon is not listed, click the symbol to add it from this folder: Macintosh HD > Library > Application Support > Native Instruments > NTK

    How to Enable Full Disk Access on macOS

Back To Top