Busy season in progress... Please note that due to a high volume of requests, the response time from our support is currently longer than usual. Chat is temporarily not available. We thank you for your understanding.

Komplete 13 Failure

royleith
royleith Member Posts: 5 Sine
edited September 28 in Komplete General

I have three machines with Komplete 13, an elderly Intel i5 desktop with Windows 10, an elderly i3 desktop with Windows 10 and a handle to make it 'transportable' and a Dell XPS 15 laptop with Windows 11. The i3 is now relegated to a standby for the Dell laptop.

The two Intel desktops have had several iterations of Komplete and have been upgraded from Windows 7 and a lot of legacy software. Both have worked very well with Reaper and Komplete. The Intel i3 and the Dell laptop continue to be fine, but the Intel i5 started an existing Reaper project with,

************************************************** **********************

Microsoft Visual C++ Runtime Library

Runtime Error!

Program C:\Program Files\REAPER (x64)\reaper.exe

This application has requested the Runtime to terminate in an unusual way.

Please contact the application's support team for more information.

************************************************** ***********************

I checked with Native Access and all was reported up to date. I checked the plugin paths in Reaper, made sure the paths matched Native Access preferences and did a complete rescan. Kontakt VST and Kontakt and Kontakt 5 dlls loaded, but no other Komplete VST3s loaded and most came up with the c++ errpr. I re-installed via Native Access and nothing changed. I un-installed the old versions of Komplete (8 and 9?) and the failing individual components via Control Panel and installed and authorised them via Native Access. One or two earlier VSTs started working.

I thought this was a Reaper problem until I tried the stand-alone applications. Only Kontakt and Kontakt 5 worked.

<lots of research> I un-installed the Microsoft c++ redistributables down to Studio 13 and re-installed them and uninstalled the Komplete failing components and re-installed, once again, and some older stand-alones and dlls started to work. I uninstalled the Dirt plugin and checked that there were no Dirt VST3s or dlls left in C\:. I reinstalled Dirt and it failed to scan.

This is the current position:

Working Standalones: Reaktor 5, Battery 4, Absynth 5, Kontakt 5, Kontakt. Guitar Rig 5.

Non-working Standalones: Massive, Guitar Rig 6, Reaktor6 (with a small notification window containing a 'close' X in a red circle), FM 8,

Working VST3s: Kontakt (64 out)

Working VST2s: Absynth 5 VST, Absynth 5 (2-6ch) VST, FM8 VST, Guitar Rig 5 VST, Reaktor 5 VST, Reaktor 5 (2->8ch) VST, Reaktor 5 (6ch) VST, Reaktor 5 (16ch) VST, Absynth 5 VSTi, Absynth 5 (2-6ch) VSTi, Battery 4 (32 out) VSTi, FM8 VSTi, Kontakt (64 out) VSTi, Kontakt 5 (8 out) VSTi, Kontakt 5 (16 out) VSTi, Kontakt 5 (64 out) VSTi, Reaktor 5 (2->8ch) VSTi, Reaktor 5 (2->16ch) VSTi

(Note: some appear as VSTs and some as VSTis.)

VST3s that fail a scan with the c++ error: Bite VST3, Choral VST3, Dirt VST3, Driver VST3, Flair VST3, Freak VST3, Guitar Rig 6 VST3, Massive X VST3, Massive VST3, Phasis VST3, Raum VST3, Replika VST3, Solid Bus Comp VST3, Solid Dynamics VST3, Solid EQ VST3, Super 8 VST, Supercharger VST3, Transient Master VST3, 

DLLs that scan, but are not added to the Reaper FX list: Bite DLL, Choral DLL, Dirt DLL, Driver DLL, Flair DLL, Freak DLL, Guitar Rig 6 DLL, Massive X DLL, Massive DLL, Phasis DLL, Raum DLL, Reaktor 6 FX DLL, Reaktor 6 DLL, Replika DLL, Solid Bus Comp DLL, Solid Dynamics DLL, Solid EQ DLL, Supercharger DLL, Transient Master DLL, 

So, older Komplete apps seem to work, but those that came with K13 seem to fail.

Any ideas? Sorry to burden this list with it, but there does not seem to be any other way to kontakt NI support.

Tagged:

Comments

  • royleith
    royleith Member Posts: 5 Sine

    I decided to go the nuclear option. I uninstalled all the apps and just retained Kontakt content. I deleted every .vst and .dll plugin that I could find. I rebooted and ran a registry cleaner.

    I rebooted and installed Native Access. To my surprise, it was a completely new version. It appears that the updater has not worked. (This also happened to me some years ago and a reinstall got things working again) I installed all of the items that were useful to me (e.g. nothing about Komplete Kontrol or Maschine). I closed Windows and rebooted a couple of days later.

    Nothing significant has changed. I deleted all of the old files in App Data and the like and rebooted.

    Still no change. I will resist the urge to update to Komplete 14 until I have some confirmation that it will install on my main machine.

  • Ronny Bangsund
    Ronny Bangsund Home on the flangeMember Posts: 71 Tri

    The updater doesn't install NA2 from NA1. That's intentional, since it's all new under the hood. And also highly problematic :/

    Your errors look like a deeper problem though. It's possible you're looking at a full OS reinstallation to sort them out. Or perhaps all that's needed is one of the C++ runtime packages from Microsoft. Search around for just the error, rather than as it relates to music software. There might be some better solutions when you widen the search field.

  • royleith
    royleith Member Posts: 5 Sine

    @ Ronny Bangsund

    Thanks for the NA comment. I have found some glitches and bugs (e,g, after installing, say, Kontakt, it refuses to install content without also installing Kontakt. If you click 'skip' it then installs the content), but it can be encouraged to do the installs.

    I had, already, uninstalled all the Visual Studio requirements and reinstalled them and it did not resolve the problem.

    My difficulty is that I have some CNC machine software installed that I can no longer re-install and the equipment is worth thousands. Also I have old projects and their related Cubase and Adobe programs that, again, I am likely to lose.

    Nevertheless, I imaged the C drive and Reset Windows 10 whilst keeping my personal data. I installed Dirt and it failed in a portable version of Reaper.

    I reset Windows 10 without preserving the data and Dirt installed without problems. The VST3 appeared in Reaper without problems. So, it is something in my personal data that is causing the problem.

    I restored the saved image and,

    uninstalled every NI program except for Kontakt content.

    ran a registry cleaner

    rebooted and deleted every NI related file including in C:\Users\Public\Documents

    ran the registry cleaner

    rebooted

    ran the registry cleaner and did a complete system search for NI files.

    On finding just one or two I needed to keep and that were only in Program Files (X86)., I installed NA2 and installed all the NI stuff.

    The results were very similar. Only the Kontakt VST3i was loaded: but the c++ warnings seemed fewer.

    Only the early VST2s loaded, as before. More recent programs like Massive, Guitar Rig 6, Dirt etc produced no c++ warnings, appeared to scan OK but failed to appear in the Reaper FX list. Massive X produced the c++ warning for both the VST3 and the dll. Scanning just the 64 bit dlls does not solve anything. Even old favourites like Solid EQ and Solid Bus Dynamics do not fail the scan, but neither do they appear in the Reaper FX list. The same stand-alones failed and so it is not a Reaoer problem.

    I soft-linked as many of the My Documents and Public Documents folders from the C:\ drive to D:\. That way I can completely reinstall Windows without losing personal files. However, Resetting Windows with data retention causes failure and this would also retain the soft links. Resetting without data does not maintain the soft-links.

    On the other hand, The Intel i3 machine is soft-linked in exactly the same way and has no such problems.

    I promised myself during the Windows 7 era that I would never buy another Windows computer and would stay with this one, off-line if necessary. Don't make me keep this one for the legacy software and buy a new one with Windows 11 for the studio work! Although, it would be nice. But, there is nothing wrong with this one! It cannot be un-fixable. But, Christmas is getting nearer!

    My next test is to back up the D:\drive, do an NI uninstall, delete everything from the D:\ drive except for the empty Windows System folders and reinstall NI. If that does not work: Christmas present!

  • Ronny Bangsund
    Ronny Bangsund Home on the flangeMember Posts: 71 Tri

    Oof. That's a lot of weird problems. If the CNC hardware is fairly well known, perhaps the 3D printing community can help with finding replacement software which won't cost you.

    I've never had deeper problems with NI products which couldn't be solved by removing a few stray/outdated files and trying again, but I only use macOS for that. I'd try a clean installation of Windows at this point. Unless I really wanted to buy me a present :)

  • royleith
    royleith Member Posts: 5 Sine

    I looked at the CNC community freeware, especially for Linux. Unfortunately, the CNC machine runs a reduced command set and also has axis reversed and datum points all over the place. I thought of a Python program to translate, but gave up. So, I can't give up on the old installations.

    That did not stop me from taking an image of the C:\ drive and resetting Windows 10, saving my data. I installed Native Access 2 and installed one of the VST3 FX plugins, Dirt. It failed to scan with my test portable copy of Reaper. Then I reset with a clean version of the OS and it worked. So, it was my data that was causing the problem.

    I restored the image of C:\, uninstalled everything Native instruments, deleted any files or folders with a Native Instruments connection including the files in Public Documents and App Data. Reg cleaned and rebooted. Reinstalled. Failed, but a few more old products seemd to appear.

    Googled.

    OMG, Windows 10 is borked. When I upgraded from Windows 7, Windows 10 came with a different arrangement of System folders (e.g. Download, Desktop, Video, My Documents etc.). The Intel i3 'transportable' managed to translate all of the soft-links, but the i5 did not. 

    Depending on which folder icon one clicked, one might get something on C, something on F (the documents partition) or a message saying unable to find folder. I clicked on properties and found they were pointed to the correct folder. I attempted to move the link. Windows reported that the system could not find the folder it had just allowed me to select.

    I tried 'Restore Defaults' and it failed. After Googling, it transpired that the whole issue was a mess. The only fix was a registry file to reset to the defaults. There was a suggestion to manually change the keys in regedit, but I was not in the mood!

    I saved the target files and folders on F, uninstalled everything Native Instruments, deleted connected files and folders and installed the key file.

    Rebooted and installed NA2 and a sample FX, Dirt. It scanned in the portable Reaper. I clicked on an NI icon that had appeared on the desktop. It ran.

    I am going through yet another NI install, but everything I tried out seems OK.

  • Ronny Bangsund
    Ronny Bangsund Home on the flangeMember Posts: 71 Tri

    You should be paid for all that work!

Back To Top