BUG: Kontakt using higher than expected CPU usage on Mac in Cubase or Standalone

Magolor
Magolor Member Posts: 5 Member

First please allow me to copy the post from the old forum:

I've been trying to use Tokyo Strings patch (around 10 to 14 GB RAM consumption) in Kontakt Player for days, and I found that:

When using Kontakt Player as standalone, as a Cubase Pro 11.0.41 plugin, or as a Vienna Ensemble Pro 5 instance, all gets CPU meter peaked and audio cut, while the activity monitor displays only around 5% of CPU usage, small RAM usage in terms of percentage, and megabytes of disk/SSD read operation. Also, the environments and settings I've been using are listed at the bottom, which are definitely good enough.

The weird thing is that only when using Kontakt Player as a Pro Tools plugin, it works as expected, being able to play the patch smoothly, with way more than sufficient CPU and RAM. So this ruled out the possibilty of having BUG on the VST, DAW, VE pro, hardware or anything else, lefting Kontakt Player the most suspicious source of this behavior.


Things tried:

Multiprocess setting

Buffer size setting (barely enough for 512, not working for anything below, which shouldn't be happening since the hardware configuration is definitely good enough for lower buffer size, as shown in Pro Tools)

DAW setting (e.g.: power scheme, ASIO-Guard, etc.)

Output device setting

etc.


Thank you! Have been working on this for days, and I would really appreciate your help!


Envrionment:

2 Computers, both using Kontakt Player 6.6.1

computer1: Mac Pro macOS Catalina 10.15.7 3.3GHz 12 cores Intel Xeon W, 640GB RAM. SSD around 7G/s reading speed.

computer2: Mac Pro macOS Big Sur 11.5.1 3.3GHz 12 cores Intel Xeon W, 128GB RAM. SSD around 2G/s reading speed.

Test settings:

All kinds of ASIO drivers, including Built-in, Dante Virtual, RME, HDX, Pro Tools, etc.

All sample rates set to 48k and all buffer size set to 128.


Problem Solved. But this is definitely a BUG.


Does not work:

Cubase + Kontakt Player

Standalone Kontakt Player

VEPro5 + Kontakt Player

Cubase + KOMPLETE KONTROL + Kontakt Player


Does work:

Pro Tools + Kontakt Player

KOMPLETE KONTROL + Kontakt Player

VEPro7 + Kontakt Player

VEPro7 + KOMPLETE KONTROL + Kontakt Player


Above contents are copied from old post. Now I am running into probably the same problem on my personal laptop:

Cubase 11.0.20

Kontakt 6.6.1 (NOT Player)

Mac Pro macOS Monterey 12.1 10 cores Apple M1 Pro, 16GB RAM. SSD around 4G/s reading speed.

Buffer size 2048

Cremona Quartet

I am trying to open all four multi-mic instruments from Cremona Quartet (around 13GB RAM in total). However, it has no problem loading but is taking way higher CPU usage than the same setting on a Windows computer, or outside of Cubase. Though personal laptop is not as powerful, as the same as previous problem, there is still abundant CPU resource available on activity monitor while the Kontakt instance peaked its CPU usage. The same thing happens with fewer instruments (2 out of 4), it can be run smoothly then but the CPU usage is still about 2x or 3x higher than expected, compared to the same setting on a Windows computer.


The problem is, for the previous post, the problem was solved by using VEPro7 or KOMPLETE KONTROL as an intermediate container. However, my personal laptop does not have VEPro7, and KOMPLETE KONTROL does not have a VST3 version required to run in Cubase 11 on Mac with Apple M1 chip. So currently I have no solution to this problem and can not do anything on my new personal laptop.

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,473 Expert
    edited January 2022

    Something suggests it's processor related and how different combinations of software handle the processor. Remember, mac is not always "reliable old mac" when there are different processors involved. Possibly there are some issues with the Xeon with certain combinations of software. Just a guess, but it is the common link I see.

    To condense what you have detailed there:

    You have 2 mac machines having this issue:

    computer1: Mac Pro macOS Catalina 10.15.7 3.3GHz 12 cores Intel Xeon W, 640GB RAM. SSD around 7G/s reading speed.

    computer2: Mac Pro macOS Big Sur 11.5.1 3.3GHz 12 cores Intel Xeon W, 128GB RAM. SSD around 2G/s reading speed.

    No amount of changing audio settings helps (tho no mention of an audio interface which could help). Seems the common thing in these is the processor.

    Now you have a new shiny expensive M1 and have seemingly the same issue and you believe it is using more CPU than it should because a Windows computer uses less??

    First, again the M1 is yet another processor from Apple which devs have to actually develop for properly. There is compatibility ways you should be running things currently but it may take YEARS for all developers to have everything sorted and working to make things as efficient as you feel they should be. The reason a PC seems "better" in this example is probably due to the architecture remaining the same over a decade so things are properly refined.

    Gone are the days where mac is the industry standard for plug-n-play efficiency and reliability. There are just as many things that can/do go wrong as PC, it is just a choice of what to use and for a reasonably new processor there is probably still some ways to go. Maybe running things in Rosetta mode may help you?

  • EvilDragon
    EvilDragon Moderator Posts: 1,021 mod

    Using larger buffer sizes on M1 will move your audio workload onto the efficiency cores, tanking down your performance. This is normal and to be expected on these newfangled big.LITTLE CPUs.

  • Magolor
    Magolor Member Posts: 5 Member

    Well, I was using the term "Windows" as a comparison just for convenience. As I've said in the previous post, the tricky part of this problem is performance difference between in Cubase and in other DAW or container. Please let me state that again:

    Normal CPU usage: on Windows, in Pro Tools on mac, in KOMPLETE KONTROL on mac, in VEPro7 on mac, in KOMPLETE KONTROL in Cubase on mac

    Higher CPU usage: standalone on mac, in Cubase on mac, in VEPro5 on mac

    This is the main problem, and in deed a strange one.

  • Magolor
    Magolor Member Posts: 5 Member

    Definitely. I am now using maximum 2048 buffer size, since I don't actually care about latency, on my personal laptop. However, that is not sufficient and also does not reach to the core of the problem: when using the same buffer size, same device, same operating system, same instrument, standalone Kontakt and Kontakt in Cubase has a higher peak CPU than other situations, and is now unbearably slow on my personal laptop.

Back To Top