Default Audio Device Problem - I have to change it manually every time

Options
Asengee
Asengee Member Posts: 2 Newcomer

Updating to BigSur I have to set manually the Audio Device every time i start Traktor (see image).

The Audio Device that works is "DJM 850 (Core Audio)" but when I open Traktor every time is set on "PIONEER DJM 850 (Core Audio)".

There is a way to set "DJM 850 (Core Audio)" as default when opening Traktor?

Traktor version is 3.6.0 325

NOTE:

  • I don't see PIONEER DJM 850 on mac "Midi Audio configuration" but only DJM 850
  • I don't see PIONEER DJM 850 on mac "system preference --> sound" but only DJM 850
  • I try to delete "com.apple.audio.DeviceSettings.plist" but it doesn't solve the problem


Tagged:

Answers

  • Sunborn
    Sunborn NKS User Library Mod Posts: 2,523 mod
    edited October 2022
    Options

    It makes no sense... unless if you always disconnect your audio device and then plug it on a different usb port... if this is the case DON'T DO IT! If not the case then i give up... it makes no sense

    You also wrote: "I don't see PIONEER DJM 850 on mac "Midi Audio configuration" but only DJM 850" which also makes no sense, because dude... it's the same device! I assume that PIONEER DJM 850 is an older name for an older driver, that somehow is still in your system, and DJM 850 is the newer version. So, i suggest that you completely uninstall your audio device, check Traktor to see what it says (it should says Built in output only) and then install your audio device again.

  • kaotik78
    kaotik78 Member Posts: 5 Member
    edited October 2023
    Options

    Trying to find an answer to this myself cause I have been dealing with it for years.

    Spend more time each time, fiddling with routing settings that worked previously and saving the settings does nothing.

    Have a usb hub with two cdj-400’s going into a MacBook Pro’s usb-a port and a Komplete audio 6 going into the other on the MacBook.

    Last time it was all working fine, packed it up for a move and put it back together exactly and of course Traktor couldn’t figure out the audio device or the routing.

    Is there any order of operations with this software? Meaning plug cdj’s and audio card in prior to starting the software? I’ve already made an audio device in the Mac Audio/midi settings to recognize deck a and b and the sound card.

    I can’t seem to find any logical pattern for plug and play ease of use with this software.

  • Sunborn
    Sunborn NKS User Library Mod Posts: 2,523 mod
    Options

    "Is there any order of operations with this software? Meaning plug cdj’s and audio card in prior to starting the software?"

    This is more than obvious and it is mandatory for things to work! Is the most basic rule, if any hardware is not connected and powered on, then of course software can not recognize it!

    Always: First, turn on audio card, second, turn on CDJs, and only after turn on software.

  • Asengee
    Asengee Member Posts: 2 Newcomer
    Options

    Thanks but it didn't work.

    Delete:

    • DJM-850 Setup Utilities --> from application folder
    • DJM-850 USBAudio.driver --> from Library - Audio - Plug-ins - HALL Folder
    • Run Unistall from djm850 driver removal program
    • Restart

    Re-install DJM-850 Audio Driver version 4_0_2 (last version in pioneer site)

    Same problem on Trakor

Back To Top