StemCreator not working on Mac - anyone else got the same problem?

proventrackrecords
proventrackrecords Member Posts: 2 Member

I was using StemCreator for a while with no problem, a couple of years ago. I loved it, and was able to create and use/DJ stem mixes of my own music. I bought an S4 controller which really brought it all to life.

But about a year ago, using exactly the same setup on exactly the same MacBook Pro it just stopped working. Export would quit at 3%. It exports the three json/xml files, but then stops. I've tested lots of iterations of exports, and even re-tried audio stem exports which have already converted successfully as stems in the past. But it just doesn't work any more.

NI support have been really helpful over the last few months. They have gone through the issue in detail. They've taken the stem audio files from me via Dropbox, run it through their StemCreator, and they say it all works fine. So what is going on? Is anyone else having this same issue? I want to get back to creating and mixing my stems again!

Help!

Tagged:

Comments

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,525 admin

    Hi @proventrackrecords I think you're not the only one with this issue here. 😕 Check out one of the comments in this post.

  • proventrackrecords
    proventrackrecords Member Posts: 2 Member

    Thanks - interesting that some people have been able to fix it. But it seems a shame that NI can't fix it themselves, and then issue an updated version of StemCreator. I'll try to track through the various posts and see if I can follow them to fix it myself. Thanks for getting back to me!

  • Ninesense
    Ninesense Member Posts: 70 Helper
    edited October 2023

    Here's how to get the Stem creator to work passed 3% on newer OS


    1 - Download and install the patched software from "rutierut" from this thread (link bellow). https://mega.nz/file/0FR2RLRI#JbcGO8nLJ3AsMYrXUMAHr52kDgF1geJWma06waLZiVY


    2 - Open Terminal and run the Terminal Command. xattr -cr /Applications/stemcreator.app

    3 - Open STEM Creator Try to make a STEM. I received a failed message. But then was prompted to download and install the command line developer tools. Which I did. https://developer.apple.com/download/all/

    4 - Quit STEM Creator.

    5 - Reopened STEM Creator and created a STEM file with out any issues.

  • Koningwoning
    Koningwoning Member Posts: 2 Newcomer

    When I download this software it tells me 'StemCreator is damaged and can't be opened. You should move it to the Bin'....

    When I use the Terminal it tells me 'No such file: /Applications/stemcreator.app'

    I've also tried this with the regular Stem Creator... it doesn't work

Back To Top