How come the Komplete M32 switches me out of midi mode when I switch tracks in my daw.

10noremac10
10noremac10 Member Posts: 3 Sine
edited August 16 in Komplete Kontrol

I prefer to use the keyboard in Midi mode because I find Komplete Kontrol to be a slower workflow than just using my daw. What would be cool Is if you could keep it in track mode but assign the knobs to cc or smart controls. But there is no way to change them from their locked in volume and pan controls which are really slow for some reason. So I put the keyboard in midi mode to edit the knobs how I like. But it doesn't seem to like that because moving to any track will switch it out of midi mode. Now why it won't just stay in the mode you pressed is beyond me but I think either the first thing I suggested or making it so it only switches to the browser mode when using Komplete Kontrol would solve the issue here.

I know I'm not alone on this. I guess people have been requesting it stay in midi mode for a while but why not just make the track mode have midi assignable knobs. Track mode feels really useless right now. Or maybe there is a work around I'm missing.

Best Answer

  • JesterMgee
    JesterMgee AustraliaMember Posts: 672 Saw
    Answer ✓

    If you switch to a track that has KK on it, the keyboard will switch to that instance in Smart mode. If you switch between tracks that do not have an instance of KK on them then it will stay in MIDI mode. I guess in the programming they figured people would mostly want to auto enable smart mode for tracks with KK.

    So switching to MIDI on the keyboard will only remain until you switch to another track with KK on it.

Answers

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 1,331 Pulse

    Which DAW are you using?

  • 10noremac10
    10noremac10 Member Posts: 3 Sine

    Logic. Same thing happens in Ableton. I've heard people complain about this with other various daws as well

  • JesterMgee
    JesterMgee AustraliaMember Posts: 672 Saw
    Answer ✓

    If you switch to a track that has KK on it, the keyboard will switch to that instance in Smart mode. If you switch between tracks that do not have an instance of KK on them then it will stay in MIDI mode. I guess in the programming they figured people would mostly want to auto enable smart mode for tracks with KK.

    So switching to MIDI on the keyboard will only remain until you switch to another track with KK on it.

Back To Top