Kontakt starts out nicely but beings to get increasing dropouts and other anomalies

Mark Wesse
Mark Wesse Member Posts: 17 Sine
edited August 2022 in Kontakt

Seems to be with any library but I have the SC hang drum with some KSP to make use of the positional data of HPD20.

1.If I play a lot of fast stuff its seems to start getting laggy and the more I play the worse it gets. If I restart Kontakt, it starts out fine again, if I play very slow non complex stuff its also fine...is there a way to measure the peformance of the script?

2.If I play for more than a couple of minutes fairly moderately it starts to drop out. If I restart Kontakt its starts out well again but then slowly starts degrading.

Im on w10 i5 mini pc, debloating and daw optimised. It runs eg Ableton surprisingly well without any of these issues.

I have tried various interfaces and buffer settings but it doesnt seem related

Have tried various multicore settings

CPU in task manager and KT is max 20%

Total ram usage is 48%

Im on kontakt 5 or 6, identical behaviour


Any ideas welcome...took me a long time to get the script and sounds right...is amazing but cant play it for any length of time...

Tagged:

Answers

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 3,586 mod

    Do you have an antivirus active when using Kontakt? Are your libraries installed on an external hard drive ? What format is that drive ?

    Since it seems to happen after hitting a lot of notes, have you played around these settings ?


  • Kubrak
    Kubrak Member Posts: 1,493 Pulse

    And what kind of i5 do you have? If it is 12th gen, you should use Win11. Win10 thread scheduler does not work satisfactory with 12th gen Intels...

  • Mark Wesse
    Mark Wesse Member Posts: 17 Sine
    edited August 2022

    No, as mentioned, it is completely debloated and only run as a mini pc attached to it purely for live performance.

    I have played with those as well.as reducingv polyphony to 32 voices

    They use ssd 256 split into 2 partitions and libs load into the non sys

    Have also tried sampler vs dfd

    Thanks

  • Mark Wesse
    Mark Wesse Member Posts: 17 Sine
    edited August 2022

    Its a 9th gen. I have an imaged duplicate of this machine on my live keys rig.and it uses kontakt for the piano engine with 72 voices without issue (these are not daws per ae, i run an i7 127k for that and i have no intention fo w11 but interestingly fface now has intermittent issues although everything else is solid). I also use another mini pc i7 6700 as the synth engine with a helix and it seem to also be fine although its actually mg2 that is the punishing element on that

    But

    The hpd is sending FAR more data than a piano with positional controllers and percussion is firing double stroke rolls etc

    Thanks

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 3,586 mod

    You mentioned added KSP scripts, if you are using the library without the scripts, do you also have these performance issues?

    You can sometimes improve performance by doind a batch and re-save: How to Resolve Issues with Missing Samples for a KONTAKT Library (Batch re-save)

  • Mark Wesse
    Mark Wesse Member Posts: 17 Sine
    edited August 2022

    Thanks...i installed properly from a disk image that was setup well (i use it for all my live boxes ie perc, git synth, keys etc).

    But

    It was my first real go at ksp so thanks for the remind...ill try it with a version using ni scripts and check it. It was a bit tough getting the positional data and pressure to work with the hpd20 pads and needed to hack poly pressure in the end...was a number of years ago now

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 3,586 mod

    The batch and resave thing can really help, even if the title doesn't fit your symptoms and even if the library was set up properly, you should definitely try it.

Back To Top