Can't play The Grandeur Virtual Piano with Yamaha P-45

Jecurl
Jecurl Member Posts: 2 Newcomer
edited August 2022 in Kontakt

Hello, guys i am new here and i have some question about The Grandeur.

I have a numerical piano Yamaha P-45 and i wanted increased the quality of the sound with a great piano.

I bought kontakt and The Grandeur.

All work perfectly but when im playing on my p45 the sound dont look so great, like nothing change just the sound of the p45.

But when i press keyboard input on the Grandeur (the virtual keyboard down to kontakt ) the sound are insane and deep.

Someone know how i can have this sound when im pressing my p45 input ?

Tagged:

Best Answers

  • ShelLuser
    ShelLuser Member Posts: 240 Pro
    Answer ✓

    Your question is a little bit too vague to comment on... we need more info.

    I looked up the P45 and I assume you connected it to your PC through USB? So how are you using Kontakt? Stand alone or inside a DAW of some sorts?

    My assumption (!) is that when you press the keys on your P45 they don't register on your PC and as such you only get the sounds from the P45 and not those from Kontakt.

    Assuming Kontakt stand-alone: check the options (see the File menu), then open the MIDI tab: is the P45 listed there and actually enabled?

    When playing your P45 be sure to keep an eye out for this indicator:

    Is that lighting up? If not then your problem is caused with Kontakt not getting any actual MIDI input.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,887 mod
    Answer ✓

    @Jecurl If you press the keys harder or faster, do you get a better sound? You should check if there are different velocity curves available on your keyboard and experiment with them to find the best fit between the library, your keyboard and your playing.

Answers

  • ShelLuser
    ShelLuser Member Posts: 240 Pro
    Answer ✓

    Your question is a little bit too vague to comment on... we need more info.

    I looked up the P45 and I assume you connected it to your PC through USB? So how are you using Kontakt? Stand alone or inside a DAW of some sorts?

    My assumption (!) is that when you press the keys on your P45 they don't register on your PC and as such you only get the sounds from the P45 and not those from Kontakt.

    Assuming Kontakt stand-alone: check the options (see the File menu), then open the MIDI tab: is the P45 listed there and actually enabled?

    When playing your P45 be sure to keep an eye out for this indicator:

    Is that lighting up? If not then your problem is caused with Kontakt not getting any actual MIDI input.

  • Jecurl
    Jecurl Member Posts: 2 Newcomer

    Hello, thank you for your help.

    Yes my p45 are usb connected to my pc.

    On kontakt i got the midi connexion and the link work fine. I can see the P45 input working.

    Also i can configure the grandeur and modify the sound of the p45 ont the grandeur all work fine. But my problem are, when i press the keyboard on down off kontakt the sound are beautiful and deep.

    When i press MY p45 the sound are low and not good as the down keyboard.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,887 mod
    Answer ✓

    @Jecurl If you press the keys harder or faster, do you get a better sound? You should check if there are different velocity curves available on your keyboard and experiment with them to find the best fit between the library, your keyboard and your playing.

  • stephen24
    stephen24 Member Posts: 257 Advisor
    edited August 2022

    What is actually playing when you press P45 keys?

    1. Is the Grandeur playing? (watch audio meter top RH corner)
    2. Is something else playing too? (mute the Grandeur and listen)

    Remember the Kontakt keyboard plays at maximum velocity at the bottom of the key. Listen when clicking the key higher up.

  • andyorozco
    andyorozco Member Posts: 2 Newcomer

    I have the same issue with my digital piano. Have you found the solution yet?


    Everything looks like it works fine. When I push the keys on my usb keyboard the keys from the keyboard section on Kontakt get highlighted. However the sound produced is not from the Grandeur is from my keyboard or maybe from the midi driver of windows. When I click with the mouse the keys from the keyboard section on Kontakt, the sound produced is from the Grandeur. All my settings are in Midi Ch1 [A].

    Also, in FL Studio happens the same thing I can hear the Grandeur only when I click with the mouse and FL Studio detects it (see the SS). When I press the keys with my digital keyboard I hear just the regular piano.


  • andyorozco
    andyorozco Member Posts: 2 Newcomer

    Found the solution, you need to install the ASIO driver. Then on Kontakt, go to settings, audio, driver, select ASIO, go to device, select ASIO4ALL v2, change sample rate at your preference, and latency. Close and restart the program.

Back To Top