Native Access v2.1.0 needs to setup and install dependencies daily on macOS...

victorp.sg
victorp.sg SingaporeMember Posts: 27 Sine

I am currently using Native Access v2.1.0 on a MacBook Pro 2017 model running macOS Big Sur 11.6.8.

I have noticed that if I run Native Access 2 for the first time on a day, it says it needs to setup and install dependencies, and then activating products and loading products.

Subsequent runs within an hour or so after this will cause Native Access 2 to just activate products and loading products.

However, after an hour or more, Native Access 2 will then again requires to setup and install dependencies again, prolonging the wait time for Native Access 2 to load my products.

Is this normal for Native Access 2 to setup and install dependencies that many times?

Comments

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,797 mod

    Hey @victorp.sg It's not normal, please make sure to give Full Disk Access to Native Access 2 and ntkdaemon as well. How to Enable Full Disk Access on macOS

    Here is where you can find the ntkdaemon:

    Macintosh HD/Library/Application Support/Native Instruments/NTK/NTKDaemon.app

    Does that fix the issue?

  • Tony Jones
    Tony Jones UKMember Posts: 216 Saw

    I have the same issue (on Monterey 12.5) and every time I run I have to go through the rigmarole of downloading installers / running scripts. I didn't know about the access for the Daemon, just tried it, still have a problem. Good job I've still got NA1!

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,797 mod

    If you still experience this issue without finding a solution, please get in touch here: http://bit.ly/NIsupport_install

  • victorp.sg
    victorp.sg SingaporeMember Posts: 27 Sine

    The issue still persists even after giving Full Disk Access to both app and daemon (and rebooting system). I am going to file a support ticket.

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,406 admin

    Update: The issue is resolved with the help from support. The solution is to run a command line on terminal. A bug report has been filed internally.

Back To Top