Missing file locations assumed at

Tyr
Tyr Member Posts: 11 Sine
edited July 2022 in Kontakt

Hi,

I have an issue with some of the native instruments libraries.

I have had everything set up for about a year on my PC (Windows) for about a year and everything has been working pretty much fine. I have recently bought MacBook and have been installing all my plugins and music software etc on my MacBook, (I use both Studio One and Ableton for reference) and I have got most things set up and working well. However I am having an issue with some Native Instruments plugins unable to locate some samples libraries / files, showing an error message in Kontakt "missing files assumed at" and I have come across missing samples files in Battery as well so far. Would anyone be able to advise on this issue? What I don't understand is the sample libraries aren't even in a different file pathway / location from my PC to my MacBook as I have all the libraries installed on an external HDD which I just connect to either my PC or MacBook.

Thanks.

Tagged:

Best Answer

Answers

  • Uwe303
    Uwe303 Moderator Posts: 1,390 mod

    Hello,

    have you started all apps stand alone first before you use them as plugin?

  • Tyr
    Tyr Member Posts: 11 Sine

    Hi, yeah I have started all the standalone apps first before opening up my up a project in my DAW, it's only doing it for existing projects, not if I create a new project then open up an instrument in Kontakt or Battery.

    Basically when I open up a pre-existing project in my DAW it pops up with a message saying one or more instances of Kontakt cannot be recalled correctly. Then when the project is open, I select a track containing Kontakt and it pops up with a further dialog box "Kontakt content missing assumed at" and it's a dialog box with a lost samples it is unable to locate it looks like this.

    I can do a manual scan for the plugins but it takes ages, it does find them and I can resave the project and they load up with no error message the next time I open the project but I don't understand why they are missing in the first place. Like I say this happening opening op the projects on my MacBook whereas the songs have been created on my PC, but I don't get it can't locate the files / samples as they aren't even located in a different place on my PC or MacBook because they are installed onto an external HDD that I just connect to either my PC or MacBook .

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 1,504 Pulse

    Quick question, if you open the project on the PC, what is the "Assumed" location listed for the same instrument in the screenshot you posted?


    and when you manually search the samples, the locatrion you choose is "Exactly" the same as the "Assumed" location?

    This has happened to me, but the new location is different than the assumed location because I added a new SSD and moved the libraries there.

  • Tyr
    Tyr Member Posts: 11 Sine

    That screenshot was just the one from this website in regards to fixing the error. I am not sure on my PC what it says the assumed location is as it doesn't pop with this error message, but the sample libraries are all on the same place. They are installed onto my external HDD which I connect to my PC when I'm working on my PC and I connect it to my MacBook when I'm working on my MacBook, but I am getting this error message about the the samples not being in the assumed location when open the songs on my MacBook.

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 1,504 Pulse

    There must be some difference based on what is saved with the Kontakt instance in the DAW project. Really the only way to correct it is to manually locate the samples folder each time you receive the message.

  • Tyr
    Tyr Member Posts: 11 Sine

    Ok so there is a different folder pathway showing in Kontakt even though the libraries are in the same place like I say on the External HDD.

    On my PC the pathway shows as this. I am not sure why it's showing some libraries on my C: drive because everything is on my external HDD. But most of the do show pathway E:\plugin Library\Native Instruments plugins\


    On my MacBook the pathway is showing as /Volumes/Seagate/Plugin Library/Native Instruments Plugins/


    I am not sure why this is different all I can assume is it's just some weird difference between Windows and Mac. Is there anyway to fix this?

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 1,504 Pulse
    Answer ✓

    There is no way that I know of, Mac and PC handle drive/directory structure differently and since I don't have a Mac, I have never had to deal with this issue... and... NI does not recommend using a single drive for 2 different operating systems as stated in this Article...

    Storing Libraries on an External Drive for both Mac and Windows – Native Instruments (native-instruments.com)

  • Tyr
    Tyr Member Posts: 11 Sine
    edited July 2022

    If I had two separate external drives to store my sample libraries, one for Windows one for Mac, is this not gonna just still cause the same problems? When I open up a song that I have started on my PC and then open the song on my MacBook is it not just going to search for the libraries in the folder path that it is on my PC and then show up with the same missing location error message? Also if I have two separate drives both formatted differently isn't that gonna cause issues in being able to store my songs on an external drive to use back and forth between my Windows PC and MacBook? (I understand this a bit off topic from just the Native Instruments sample libraries)

Back To Top