Traktor Kontrol S4 MK1 and Mac OS Monterey & Ventura (succesed tests)

DimaSpider Member Posts: 3 Member

Hello guys! I'm test my favorite S4 MK1 on Monterey (12.4) & Ventura beta 2 and all works fine. Official drivers v.2.8.0.

On Monterey i'm tested pure instrall and update from Big Sur - all fine.

On Ventura beta 2 after update from Monterey all work's fine too.

Succesed work on Ventura on screenshots.

And finaly, i'm not test it on Traktor Beta now, maby later with more upper beta or RC of Ventura.

All drivers installed as on Big Sur (more info you can find here ).


  • ThorAdam
    ThorAdam Member Posts: 5 Member

    I installed Ventura in the middle of last week (25th or 26th October). It worked fine with my Kontrol S4 (apart from the exFAT / Fat32 formatted hard drives). I used my S4 the last time on Sunday, 30th (several days after I updated to Ventura). I wanted to use S4 again today. But all of a sudden I was asked for "USB-Connection-Permission" (deutsch: Verbinden des Zubehörs erlauben) but S4 is not connecting to Traktor any more.

    I would blame it on the Ventura compatibility problems (NI statement of October 24th). But it has worked for about 5 days and without doing any changes on my soft- and hardware, it just stopped working.

    Any ideas?

  • Indi
    Indi Member Posts: 2 Newcomer

    Hi Guys,

    I really appreciated your posts as it gives me hope I can get my S4 Working on my mac.

    The v2.8.0 driver does not install, saying that "the installation has failed"

    Did you have this issue? Or did you have the drivers installed before updating to Monterey?

  • Indi
    Indi Member Posts: 2 Newcomer

    update, I tried Paul Chabots method for manually extracting and placing the driver files but its still not recognising the controller

  • diskjockeymeyln
    diskjockeymeyln Member Posts: 2 Newcomer

    I would love to visit Paul Chabot's website but the link is no longer active, is there any other way i could acces that information? Thanks!

  • ishikawa
    ishikawa Member Posts: 4 Newcomer

    Any luck with getting the complete instruction set?

    I am trying to get my Kontrol S4 Mk1 working on a new Mac Mini running with Apple M2 Pro and OS 13.2.1

    Traktor simply does not recognize the controller by the looks of it

    My old Macbook runnig OS 11.X is working fine with the controller

  • ishikawa
    ishikawa Member Posts: 4 Newcomer

    For those trying to get to the Paul Chabot website - you can still access the instruction set here:

  • diskjockeymeyln
    diskjockeymeyln Member Posts: 2 Newcomer

    Thank you, i hope this helps and i will let you know if it worked!

  • ishikawa
    ishikawa Member Posts: 4 Newcomer

    Update - it did not work for me and it looks like the my S4 Mk1 is at the end of the line

    I tried the steps from Paul's website and it did not work - complaining that the drivers did not support the right cpu architecture (x64 or some such)

    Assuming that more than an Apple silicon issue - this is more just an OS level issue per:

    • macOS 10.15 (Catalina) terminated the operability of some legacy NI hardware. The same applies to macOS 11 (Big Sur), macOS 12 (Monterey), and macOS 13 (Ventura). This includes MASCHINE MK1MASCHINE MIKRO MK1AUDIO 2 / 4 / 8 DJTRAKTOR AUDIO 2 MK1, and TRAKTOR KONTROL S2 / S4 / X1 MK1.

  • SergioAguirre
    SergioAguirre Member Posts: 1 Newcomer

    It worked for me.

    Thank you for the help.

  • Notorious B
    Notorious B Member Posts: 1 Newcomer

    hello all.

    Sorry to be the guy with the bad news but after long time in front of my macbook air M2 from 2022 i came to the conclusion that who as any newer mac with intel chips the old S4 mk1 like the one i have will still work but if you have a mac with the new M1 or M2 chip the drivers will just not install because they are for intel based pc´s.

    Please correct me if i am wrong but tell me who has intel or apple chip and if it works or not the instalation with your chipset.

    Hope native will correct this and give us all hope for our loved mk1´s

    Thanks all

  • DeffoJeffo
    DeffoJeffo Member Posts: 1 Newcomer

    Is there a credoible fix for this yet? Just bought a second hand Mk1 and it doesnt work with monterey. Think ive got a paperweight.

    Alarm bells are rining though if theyre turning off support - Because this means any future update may render your gear useless just before a gig.....

  • Taylor Boehm
    Taylor Boehm Member Posts: 1 Member

    Anyone found a fix for this? I'm running a brand new M3 Max MacBook Pro with Sanoma and tried everything in the video and kept getting:

    Unsupported Error: one or more extensions are unsupported to load: Kext com.caiaq.driver.NIUSBTraktorKontrolS4Driver v2.8.0 in executable kext bundle com.caiaq.driver.NIUSBTraktorKontrolS4Driver at /Library/Extensions/NIUSBTraktorKontrolS4.kext}

    whenever I ran the terminal commands. I just bought a s4 mk1 as it was such a good price and got it working on an old Intel Mac but can't on my new one.

    Surely even if NI don't support this anymore there's a way to still map knobs to something in 3rd party software or something.

  • dedit
    dedit Member Posts: 9 Member

    Hey all,

    This worked for me. Installed as per paul's video. Big thanks for putting this together Paul!

    Running big Sur. I was on Monterey but rolled back. I was ready to throw the s4 out but it has new life. Everything on the controller works fine.

    I have been having playlist issues on 3.10.1 with them not saving and when reopening traktor the playlists are empty. I have tried everything and traktor support was looking into it but a lot of back and forth and nothing seems to work except for creating smart playlist and organizing either through colour coding or specific keywords. The problem with the smart lists is you can't reorder the tracks except through bpm or date added. I am unable to roll back traktor versions because I haven't used traktor in ages and this was the only version within native access to download.

    Anyone else having playlist saving issues?

Back To Top