Beatport tracks - cannot detect BPM

Rootsy
Rootsy Member Posts: 2 Noise

Whenever I import a track from Beatport in Traktor Pro 3 on my S8, it downloads the track OK but then says "Cannot detect BPM due to missing transients! Please analyze first." I've tried uninstalling and reinstalling Traktor, looked through every setting related to analysing tracks etc. Is this a known issue and is there a fix?

Tagged:

Best Answer

  • zephry
    zephry SeattleMember Posts: 93 Tri
    Answer ✓

    Maybe this is an issue since someone else is also having trouble. But please confirm this page in preferences. And that you have the "analyze new tracks when loading into decks" option selected.

    I have not tried to right click and analyze Beatport tracks. They shouldn't be able to be analyzed that way since they haven't actually been downloaded yet. Hence the missing transients.

    So loading to a deck downloads the track, then that selected option should analyze.

    Also to get Auto Gain. You need to load and let analyze again. (Twice per track)


Answers

  • Sunborn
    Sunborn GreeceMember Posts: 64 Tri
    edited June 10

    There is no point to uninstall Traktor, this is not an issue, the answer is obvious and stated on the message "Please analyze your tracks first". Without analyzing your tracks, it is impossible for Traktor to know the BPM, or any other info.

    Select the tracks you want, right-click on them and choose Analyze. Make sure that you will choose all analyze options (not just the BPM).


  • yves707
    yves707 Member Posts: 1 Noise
    edited June 18

    I have the same issue. Analyzing my tracks leads to the above error. So, this is not the answer!

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,119 admin

    @Yves @Rootsy Can you play those audio files outside Traktor?

    Can you go to Preferences, then Mix Recorder and make sure the source is Internal?

  • Rootsy
    Rootsy Member Posts: 2 Noise

    Hi @Kaiwan_NI yes, the Mix Recorder Source is set to internal.

    Please note, this error only occurs when downloading tracks from Beatport, other tracks that I load into the decks from my local hard drive seem to work fine.

  • zephry
    zephry SeattleMember Posts: 93 Tri
    Answer ✓

    Maybe this is an issue since someone else is also having trouble. But please confirm this page in preferences. And that you have the "analyze new tracks when loading into decks" option selected.

    I have not tried to right click and analyze Beatport tracks. They shouldn't be able to be analyzed that way since they haven't actually been downloaded yet. Hence the missing transients.

    So loading to a deck downloads the track, then that selected option should analyze.

    Also to get Auto Gain. You need to load and let analyze again. (Twice per track)


  • zephry
    zephry SeattleMember Posts: 93 Tri

    Ok after testing, I cannot right click to analyze from the Beatport Link tabs. The option is not there. Loading from the S8, I assume you get the error on the S8 screen?

    Once again double check the option is selected in preferences. As you can see when I don't have the analyzing option selected there is no grid and no stripe.

    The only other thing I can think of is maybe your connection is slow and the track isn't fully downloaded?


  • zephry
    zephry SeattleMember Posts: 93 Tri

    There are 2 similar options one is.

    Analyze new imported tracks. This one is for tracks you import to collection. This will bring up a box for analysis but it doesn't actually analyze the track. The track is added to the collection, but it has not yet been downloaded or analyzed.

    The other is as I mentioned above.

    Analyze new tracks when loading into deck.

    This is as I explained, it immediately starts analysis when the track is down downloading after loading.

    Here is a closeup of the options.


  • zephry
    zephry SeattleMember Posts: 93 Tri

    Clicking Auto on the grid area will also analyze the track if you prefer not to select the option.

Back To Top