Why would previews suddenly not be working in Kontakt, but they work in Komplete

Options
Anthony H
Anthony H Member Posts: 47 Member

Hi

Today seems to be one of solving NI mysteries.

The audio previews are not working while browsing the libraries in kontakt 7 - not for any libraries/instruments. They did work previously. This is happening in Kontakt standalone and plugin. The previews works for all libraries in Komplete Kontrol. The Previews pack has been installed in NA (version is 1.1.0, no updates available).

Any ideas why this should have worked before but not anymore? Thanks

Best Answer

  • Anthony H
    Anthony H Member Posts: 47 Member
    edited July 10 Answer ✓
    Options

    @Jeremy_NI Hi, I tried step 2 (reseting the Kontakt db) and that had no effect. Then I tried Kymeia's suggestion with the memory server…

    @Kymeia This seems to be where the trouble is! Disabling the memory server (and restarting) brings previews back to the Kontakt library. And after re-enabling the server (and restarting), the previews no longer work. I can replicate this repeatedly back and forth.

    So I don't know what the solution is here - I have always used the memory server because I have projects with a heavy instrument load. It used to work, and I can't say exactly when it stopped.

    EDIT: additionally, resetting the outputs as per a previous suggestion doesn't cause a crash Kontakt if the mem server is disabled. (But this doesn't change the no-preview behaviour once the server is reenabled, and resetting the outputs with server again causes a crash.)

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    Options

    Just to be 100% sure, when you're in Kontakt, the preview volume is up?

    Does Kontakt and your DAW have full disk access? How to Enable Full Disk Access on macOS

    What audio driver have you chosen for Kontakt 7 in standalone?

  • Anthony H
    Anthony H Member Posts: 47 Member
    Options

    Hi Jeremy

    Thanks for replying. I understand you need to ask these questions, so

    Yes. Volume is up.

    Yes. All NI apps (and my DAWs of course) have full disk access.

    Audio driver is CoreAudio, output is my interface.

    Komplete Kontrol allows previews for all installed libraries, pre 2017 and current.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    Options

    Thanks, if you select your onboard soundcard, is it the same?

    In Kontakt, if you show the outputs and select this box, do you get soud for the previews back?

  • Anthony H
    Anthony H Member Posts: 47 Member
    edited July 5
    Options

    If I do that, Kontakt stops responding and I get the spinning rainbow beachball of doom and have to force quit.

    edit: yes, it's the same with the built-on audio selected. and resetting outputs similarly causes kontakt to freeze up with this selected.

  • Anthony H
    Anthony H Member Posts: 47 Member
    Options

    Here's an update:

    I reinstalled Kontakt to see if that helped. After loading, an error popped up saying "Could not start memory server". I clicked through anyway, set up the audio to output to my interface and found the previews working! So I restarted Kontakt to see if that memory error popped up again. It didn't, and I can see the memory server appear in the toolbar above…and the previews no longer work. Back to square one. 🤦‍♂️

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    Options

    @Anthony H That's really a strange behaviour. Did you setup a different output routing (multiple outs) at some point in time and saved it as default?

    Please follow steps 2 and 3 of this article: Kontakt Crashes

    Dos that fix the issue?

  • Kymeia
    Kymeia NKS User Library Mod Posts: 4,057 mod
    edited July 8
    Options

    Have you tried disabling memory server?

    That should fix it (after a restart) - I was able to replicate this issue by temporarily turning memory server on

    My guess is this is an unexpected by-product of memory server handling the samples rather than Kontakt (because it is a seperate app)

  • Anthony H
    Anthony H Member Posts: 47 Member
    edited July 10 Answer ✓
    Options

    @Jeremy_NI Hi, I tried step 2 (reseting the Kontakt db) and that had no effect. Then I tried Kymeia's suggestion with the memory server…

    @Kymeia This seems to be where the trouble is! Disabling the memory server (and restarting) brings previews back to the Kontakt library. And after re-enabling the server (and restarting), the previews no longer work. I can replicate this repeatedly back and forth.

    So I don't know what the solution is here - I have always used the memory server because I have projects with a heavy instrument load. It used to work, and I can't say exactly when it stopped.

    EDIT: additionally, resetting the outputs as per a previous suggestion doesn't cause a crash Kontakt if the mem server is disabled. (But this doesn't change the no-preview behaviour once the server is reenabled, and resetting the outputs with server again causes a crash.)

  • Kymeia
    Kymeia NKS User Library Mod Posts: 4,057 mod
    Options

    Did previews ever work with memory server though? I have not tried it before I tested the hypothesis that it was the cause but from my understanding of how memory server works am not surprised if it bypasses previews. However if previews definitely worked before some update point then it’s a bug and identifying when the point was where it stopped working will help fix it

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    edited July 10
    Options

    Well @Anthony H and @Kymeia Thanks to you I was able to reproduce the issue. If I turn the Memory Server on, previews don't work, if I disable it, previews are back. I'll try to get more info and file a bug if needed. Thanks for flagging this.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    Options

    The Kontakt team got back to me on the topic. The memory server is a relic feature needed on 32 bit systems. It's not really of any use on current computers and operating systems.

  • Anthony H
    Anthony H Member Posts: 47 Member
    Options

    @Jeremy_NI and @Kymeia thanks so much for helping figure this out!

    I'm quite sure I would have activated the memory server out of habit when reinstalling my DAW (I've been on hiatus from music production for a while). It is a useful tool to track RAM usage, and on occasion purge loaded samples if necessary - interesting to learn that it's not of any use anymore? I'll leave it off and see if performance changes. Not being able to preview sounds before loading is a major workflow hindrance.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 4,057 mod
    edited July 10
    Options

    already filed it ;)

    Although sounds like it’s more what I thought and just a by product of the architecture (outmoded)

Back To Top