S88 Mk2 not playing sounds keyboard mode

DJ Go-iLL
DJ Go-iLL Member Posts: 19 Sine

Hi I’m experiencing a problem with my S88 Mk2 midi controller. I have a 2020 MacBook Pro that has 4 thunderbolt ports as the hub of my production studio and use a Universal Audio Apollo Twin X Quad as the center of my production studio. Recently started to record so I installed Protools as my DAW. Now my S88 midi controller does not play in keyboard mode with my Maschine studio and I’m totally confused as to why. I am able to use it with FL Studio but when I want to use it now with my Maschine Studio I can’t use it in keyboard mode. I also have a A25 as well and that does not respond either but works when I use Protools or in FL Studio. Could there be some conflict with a setting in my I/O configuration or is it possibly a conflict with a avid plugin that disabled my settings? I’m am really frustrated at this point and need some assistance. Has anyone else encountered this issue before please let me know.

Answers

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,163 mod

    Some AVID / FB360 have caused issues with the integration of our devices. You can try this:

    Go to this location:

    Macintosh HD > Library > Application Support > Avid > Audio > Plug-Ins

    Move all these plug-ins to the unused Plug-ins (unused) folder

    • FB360-Mix-Loudness-ambiX.aaxplugin
    • FB360-Control-ambiX.aaxplugin
    • FB360-Stereo-Loudness-ambiX.aaxplugin
    • FB360-Spatialiser-ambiX.aaxplugin
    • FB360-Converter-ambiX.aaxplugin

    Restart your computer and open ProTools.

  • DJ Go-iLL
    DJ Go-iLL Member Posts: 19 Sine

    Jeremy I found this information on other message threads and tried it already still is not working. The problem isn’t using it when I open Protools it’s when I try to use it with my Maschine Studio. It does not work in keyboard mode

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,163 mod

    Ok, so I didn't get it the first time. The problem only occurs within the Maschine plug-in, there is no MIDI communication from the keyboard to the Maschine plug-in. Try to open Maschine in standalone, is it the same? Can you browse and load instruments from the S88 when in the Maschine software ? Is the S88 selected as a MIDI input ?

    Also make sure to give Full Disk Access to Komplete Kontrol, Maschine and your DAWs: How to Enable Full Disk Access on macOS

    Make sure to install the latest versions of Komplete Kontrol and Maschine (2.7.2 and 2.15.2)

    You mention a 2020 Macbook, is it a M1 computer ? If it is and your DAW is supporting M1 processors natively, then you would need to run it in Rosetta mode: How to Open Your DAW Using Rosetta

  • DJ Go-iLL
    DJ Go-iLL Member Posts: 19 Sine

    @Jeremy_NI no I have a 2020 MacBook Pro running on a 2 Ghz Quad Core Intel Core i5 processor. I have the latest versions of all my Native Instruments software installed and have enabled full access already. My OS is Big Sur 11.6.6. When I use my S88 in FL Studio or Protools it works as it should however when I try to use it with my Maschine Studio all of the functions of the S88 work but the keys do not respond when I load a 1-shot, instrument or kit. I tested it on an older MacBook Pro I have and it works perfectly as it should and the only thing I did recently was download protools to my laptop recently. I've already disabled the FB360 plugins and restarted and that does not resolve the issue.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,163 mod

    @DJ Go-iLL Can you give this a try?

    1. Open Finder and navigate to the folder:
    2. macOS 10.14 (or older): Macintosh HD > Library > Audio > Plug-Ins > HAL
    3. macOS 10.15: Macintosh HD > System > Library > Audio > Plug-ins > HAL
    4. Copy the "Avid CoreAudio.plugin" to another location, for example the Desktop.
    5. Delete the "Avid CoreAudio.plugin" from the HAL Plug-in folder.
    6. Type in the admin password when prompted.
    7. Restart your computer.

    Any luck this time ?

  • DJ Go-iLL
    DJ Go-iLL Member Posts: 19 Sine

    @Jeremy_NI I've done a fresh install of my Mac OS to remove all the programs including deleting Avid Protools and everything is working fine now. I'll now have to decide on the DAW I'll record with now and may have to invest in another computer strictly to dedicate to recording on for my studio so I don't end up in this situation again.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,163 mod

    That's pretty extreme, Pro Tools should work with our devices, sometimes only these files in the HAL folder or the FB360 plug-ins can cause problems.

Back To Top