Please be advised that due to scheduled infrastructure maintenance, we anticipate downtimes for the Native Instruments websites and Native Access on February 28, 2024 starting at 06:00 CET. For more details, click here.

Kontakt voice management and midi problem

Pjotter
Pjotter Member Posts: 6 Member
edited May 2022 in Kontakt

When using midi in Kontakt, voices keep piling up. They go the max and then starts from start. The Kontakt keyboard keeps the keys suppressed. If I lower voices, Kontakt starts missing notes. Kontakt CPU goes to 100% and then it sounds ugly.

If I stop my Daw, it takes a while until all voices are cleared. Or use the panic button.

I thought maybe it could be there is no note off value, but I have no problem in Opus.

Any ideas?

Tagged:

Best Answer

  • EvilDragon
    EvilDragon Moderator Posts: 1,019 mod
    edited May 2022 Answer ✓

    Note on velocity 1 works just fine over here. Reaper did have an issue with note on velocity 0 at some point a few months ago, with VST3 plugins only. Are you using the latest version of Reaper? Sounds like you might not be.

Answers

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert

    What DAW and OS? also what Kontakt library are you using (or does it happen with all of them?) And yes, it seems MIDI off is being ignored or not sent properly.

  • Pjotter
    Pjotter Member Posts: 6 Member

    Reaper 5.99

    W10

    Latest Kontakt.

    Most have this problem. Chris Hein library voices seems okay, but keys keep supressed and doesn't sound good anymore after a while.

    Kirk Hunter library loaded with File menu, looks okay, but a few keys are supresed too long.

  • Pjotter
    Pjotter Member Posts: 6 Member

    Found the problem and a workaround.

    The midi files from my source with problems, have many notes with velocity=1. Note off messages can be a note off message or velocity=0.

    Opus does not have a problem with velocity=1 somehow, but Kontakt does. Some Kontakt libraries more as others.

    I can solve this in Reaper by selecting all notes and add a value for note off in properties. Works fine. So I can move on.

    But it is extra work. So if someone has a solution in Kontakt, let me know.

  • EvilDragon
    EvilDragon Moderator Posts: 1,019 mod
    edited May 2022 Answer ✓

    Note on velocity 1 works just fine over here. Reaper did have an issue with note on velocity 0 at some point a few months ago, with VST3 plugins only. Are you using the latest version of Reaper? Sounds like you might not be.

  • Pjotter
    Pjotter Member Posts: 6 Member

    This could be the reason, otherwise I cannot explain it.

    I am working with Reaper 5.99

    Found the Reaper tool for reading midi messages and here it looks fine. So it could be the bug.

    Thanks.

  • EvilDragon
    EvilDragon Moderator Posts: 1,019 mod

    Yes, this was fixed in version 6.something. So that's definitely it.

  • Pjotter
    Pjotter Member Posts: 6 Member

    I know now for sure, because I just upgraded. Problem is gone. Otherwise I had too much work working around it.

    But now I have to study all new Reaper goodies. And there are a lot. But that is a luxury problem.

    Thanks again for pointing it out.

Back To Top