Traktor update fails - Native Access nightmare

doohickey
doohickey Member Posts: 5 Sine

I have been using Traktor Pro for over 10 years. I use it on stage and I've only ever had one issue with it in a live setting. I originally purchased Traktor because my Pioneer CDJ-400's were "Traktor Certified". Even though that certification went away when NI started making their own controllers, I've kept using Traktor with Pioneer CDj's. It's a simple and elegant setup. Just about every gig I show up to has Pioneer CDJ's. All I need is my laptop and 2 usb cables. I simply plug into the cdj's and away I go, I don't even need to look at the laptop with the newer cdj models. It has worked very well for me, until now.

I've stuck with Traktor Pro 2.6.4 because it was stable, had colored wave-forms and all the features I will ever need. Except, now I cannot connect to the newest cdj's such as the CDJ-2000NXS2. So, after researching, I now find I have to have at least the 2.11 update to connect. Simple, right? Let's update, uh, no Service Center any more? Ok, download the newest version of Native Access. Worked on my home pc where I prepare my sets, let's get my performance laptop updated. FAIL! "Searching for latest update" "Download failed"

I have tried every solution I could find on the internet including every solution NI suggested. No dice. I have been trying for 5 straight days to update the software I paid for. I've put in a service ticket at NI. They just keep repeating all the suggestions I've tried at least 30 times now. I have spent at least 15 hours trying to update this software and I am in the same place I started. I have 3 gigs the weekend after next at venues using the CDJ-2000NXS2 so I must be able to update Traktor, somehow.

For the record, Native Access is a terrible solution if it's not going to work because there is no option to download the update and just install it offline. I really want to be able to use Traktor. I love it when it works. I want to buy an S4 controller for remote gigs, but I would not be able to install or update the software with Native Access.

Attention Native Instruments, I am not the only person having this problem. There has to be a solution.

Comments

  • Kubrak
    Kubrak Member Posts: 1,044 Pulse

    Maybe firewall, antivirus?

    Or what about to uninstall NA, download new version from NI web? Also you may download Traktor installation file on your home PC and install it on performance laptop. Just one has to copy file from download folder, before it is erased.

    I use NA on 3 computers and no problem...

  • doohickey
    doohickey Member Posts: 5 Sine

    I made firewall exceptions, disabled the firewall, uninstalled antivirus, reinstalled NA like 30 times, literally. There is no installation file, that's the problem, Native Access now handles the installation and updates and since I cannot connect to the NA server, no updates, no installations.

    I'm at my wits end, I've tried every solution I could find, multiple times. I am not exagerating, I've spent at least 15 hours in the last 5 days trying to figure this out.

  • Sûlherokhh
    Sûlherokhh GermanyMember Posts: 245 Saw

    As a stop-gap i could provide you with the install exe file. I've got almost every single Traktor install file since TP 2.65. Just tell me which version you need and i will upload it to a cloud service for you. You will still need to register via Native Access though.

  • doohickey
    doohickey Member Posts: 5 Sine

    I need the 2.11.2 update. You are correct though, it's not gonna work without Native Access, at least that's my assumption as well.

    NI sent me the latest Native Access software, version 2.0.2. Unfortunately, it will install, but will not login to the Native Access server. The nightmare continues.

  • doohickey
    doohickey Member Posts: 5 Sine

    And now it appears NI may be ghosting me. I am so frustrated and so angry at this point. Really, really trying to stay calm, but this is utter nonsense.


  • Stevan
    Stevan MIDIMember Posts: 238 Saw

    Sounds like an account issue, did you try to create another account to login?

    If that works then they can transfer the license.

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,120 admin

    Update on behalf of the OP: Since Native Access 2 is not supported on Windows 7, the solution is to downgrade to Native Access 1 and open it in a safe mode as per this article.

    How did it go for you @doohickey?

Back To Top