Kontakt 7 Unusable on my Mac Studio After Updating to Kontakt 7.10.0

Options
robbiemacman
robbiemacman Member Posts: 5 Member
edited June 12 in Kontakt

I just updated tonight and now libraries take about 20-30 seconds to load and fully show the GUI and any controls take about 10 seconds to register trying to make any changes to them & suddenly jump to setting.. This has basically rendered Kontakt 7 useless and its my main instrument which I need daily for my job... Please help anyone ?

I have a Mac Studio M1 Ultra with 64 gig ram and running Ventura 13.6.1 with latest version of Logic X.. A ll my libraries are on an external SSD in thunderbolt 3 chassis as they have been for years and worked flawlessly before.

Best Answers

  • Adil_NI
    Adil_NI Member Posts: 12 Product Team
    Answer ✓
    Options

    Hi all,

    We’ve just published Kontakt 7.10.1, which we believe addresses the issues introduced in 7.10. If you are running 7.10, please update to this version, and respond to this message if you are still encountering performance issues.

    Thanks again for the patience and understanding whilst we’ve worked to resolve this.

    Have a great weekend,

    Adil

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,396 mod
    edited May 8 Answer ✓
    Options

    Kontakt 7.10.2 is live and should fix any issue related to 7.10.

«1345

Answers

  • emasters
    emasters Member Posts: 2 Member
    Options

    Same here - after updating to Kontakt 7.10.0 in NA, Kontakt is unusably slow (both stand-alone and AU plugin). MacBook Pro Intel, Sonoma 14.4.1, Logic 10.8.1. Reverting the Kontakt 7 app and Kontakt AU plugin to 7.9.0 (via Time Machine) works fine again. Something is broken with the 7.10.0 release.

  • robbiemacman
    robbiemacman Member Posts: 5 Member
    Options

    Oh Joy …. let’s hope this gets fixed today otherwise I don’t know what I am going to do … arghhh

  • joecomposer
    joecomposer Member Posts: 2 Member
    Options

    It's an absolute disaster, completely unusable.

  • littlealone100
    littlealone100 Member Posts: 11 Member
    Options

    Same situation on windows 10. The speed is too slow. When I click on the keyboard, it takes a few seconds for the UI to respond. Moving windows is also choppy.

  • kinomood
    kinomood Member Posts: 1 Newcomer
    Options

    Same situation here: Kontakt 7.10.0 unusable with persistent lags in Studio One 6.6.0

    MacOS Sonoma 14.4.1 - iMac i9

    I hope they resolve it as soon as possible because it is not possible to work with these slowdowns!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,396 mod
    Options

    Yes, I can confirm, we also had a lot of reports over night. we informed the Kontakt team.

    Here are the installers for the previous version: KONTAKT 7.9.0

    Sorry about the trouble.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,987 mod
    edited April 19
    Options

    Can confirm this too and also the browser in Kontrol III is not working well with them now, it keeps jumping several libraries and presets at once (working better in KK)

  • littlealone100
    littlealone100 Member Posts: 11 Member
    Options

    I'm afraid not only Kontakt 7, but also all the plug-ins updated this time will have problems, right?

    I just loaded Raum and Replika XT and they all crashed.

    I use FL Studio 21, win10.

  • littlealone100
    littlealone100 Member Posts: 11 Member
    Options

    Oh I found the solution. Raum and Replika XT must use vst3. Using vst2 will crash.

  • Electromusicproject
    Electromusicproject Member Posts: 13 Member
    Options

    I can confirm, after upgrading to Kontact 7.10, nothing works in Maschine or logic. 2-3 second delay on changing any parameter, and the playhead refreshes every few seconds - rendering my whole system useless. Also happens in the Kontakt standalone. Browser works then as soon as an instrument is loaded, 2-3 second lag on changing any parameter at all. Will try the downgrade now and report back.

  • Electromusicproject
    Electromusicproject Member Posts: 13 Member
    Options

    Didn't need to uninstall Kontakt 7.10, just used the 7.9 installer, and it let me choose to downgrade-- everything working fine again.

    So 7.10 unusable on Ventura 13.6.6 Mac M2, in standalone, logic or maschine

  • mattse
    mattse Member Posts: 17 Member
    Options

    I'm interested to know how new versions of the software are publicly released when there's big usability problems with them, as in this instance. When there's jumps from 2-3 second load time to 20-30 seconds in top spec machines, how would this not be noticed in NI testing, presuming both Mac and PC systems are used. Is it a case of putting it out there and then relying on feedback for reactive changes?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,396 mod
    Options

    Hey all, quick update, the issue was identified, Kontakt 7.10 has been removed from Native Access. A hotfix will be available later today.

    If you have updated already and need the previous version here rae the installers for Mac & Windows: KONTAKT 7.9.0

    Our apologies for the inconvenience.

  • PK The DJ
    PK The DJ Member Posts: 1,290 Expert
    Options

    LOL I must have gone in just before it was removed then, because I read this thread then checked to see which version I had, and there was the 7.10.0 update.

    I installed it as I was curious to see just how "unusable" it was, and if "nothing works" as stated.

    Maschine seemed to be unaffected. I opened up Kontakt in Maschine and loaded a couple of plugins. Yes possibly it was a little bit laggy, but it wasn't unusable and things did seem to work.

  • robbiemacman
    robbiemacman Member Posts: 5 Member
    Options

    I have rolled back to 7.9.0 its much much better but still laggy compared to the lightning fast response of older non re-batch saved libraries loaded up in Kontakt 6

Back To Top