Kontakt on logic ocassionally plays random keys or wrong velocity while input from midi keyboard

Options
gavinef
gavinef Member Posts: 2 Newcomer

Has anyone encountered this issue, where Kontakt plays random keys or wrong velocity while input from midi keyboard?

I have tried sampler in Logic, and it works smoothly with my midi keyboard. but when use kontakt or komplete it doesn't seem stable. also notice the latency is significantly higher than built-in logic vsts. any thoughts how to solve this problem? thanks.

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    Options

    @gavinef Can you reproduce this behaviour outside of Logic? If you open Kontakt in stndalone, is it the same?

    What MIDI keyboard is it?

    Logic has a lot of MIDI assignments possible, and sometimes users assign MIDI parameters by accident. Resetting Logic to default usually gets rid of this. It's explained here:

    Delete the Logic Pro PLIST file

    1. In Logic Pro, note any custom preference settings that you’ve made, and save any custom key commands that you've created.
    2. Quit Logic Pro.
    3. In the Finder, choose Go > Go to Folder.
    4. Enter ~/Library/Preferences, then click Go.
    5. Remove the "com.apple.logic10.plist" file from the Preferences folder.
    6. If you upgraded from Logic 9 or earlier to Logic Pro, also remove the "com.apple.logic.pro" file.
    7. Restart your Mac.

    After deleting the PLIST file, open your project and try to reproduce the issue that you were experiencing. If the issue no longer occurs, choose Logic Pro > Settings (or Preferences), reapply your custom settings, and import your custom key commands.

    From this article from Apple:


Back To Top