OBS still plays audio when I press headphone only button

Bint007
Bint007 Member Posts: 2 Newcomer

Im using Traktor pro3, DJ Hercules instinct series s, obs, monitor, and desktop.

My issue:

I want to hear sound ONLY in my headphones while mixing, while another track is playing, HOWEVER obs still plays the headphone-only button function in master.

I have tried every option possible and it's always the same. When I press the headphone only, it still plays in master and you can hear what I'm doing.

My setup:

DJ mixer - Hercules, at the bottom I plug in my headphones, at the top I have a aux for speakers and left right RC. I have the left right in my Hercules and the cable goes into the monitor.

OBS recognises my monitor and Hercules as 2 audio sources.

Traktor has ASIO4ALL, HERCULES, NVIDIA audio sources, shared and exclusive.

I do have to mention that when I go to external, I lose the volume buttons function (up down)

I put the cable into the desktop PC and still same. IF anyone has any info how I can fix this, please let me know.

Tagged:

Answers

  • just_jump
    just_jump Member Posts: 76 Helper

    Seems odd that you would even send your headphones / cue monitoring to OBS. Normally you just give it the mix out. I’d just mute the monitoring in OBS or not bring it into your scene at all.

  • PK The DJ
    PK The DJ Member Posts: 1,074 Guru
    edited April 4
  • Bint007
    Bint007 Member Posts: 2 Newcomer

    Yes, I followed the guide. I do want to mention that in traktor, when switching from INTERNAL to EXTERNAL in the audio preference tab, I lose the option of fading track A and B, so the faders that go from top to bottom and vice versa disappear in EXTERNAL. I fully understand that OBS doesn't need to get the headphone only input and that I need to route the DJ hercules in such a way that out for headphones is only headphones... But like I said, I have tried every combination. And I can only work in INTERNAL setting as explained.

  • lord-carlos
    lord-carlos Member Posts: 2,302 Expert

    Only use "external mixing mode" with an external mixer, not with a DJ controller.

    Look at the guide PK gave you, I think I also linked it to you on reddit. You can take a cable from the master out of controller and put that into a line in on your computer.

    If you have asio4all, you could also combine the hercules and your normal computer interface. But if I remember correctly I also explained to you on reddit? Did you try that?

Back To Top