Kontakt 5

jgardner
jgardner Member Posts: 8 Newcomer

I have Kontakt 5.8.1 ( the only version which will work with my Mac Sierra , i tried Kontakt 6 but its not compatible ),

will Abbey Rd Drums work with it ?

I cant seem to find an answer anywhere on the Native Instruments site .

Best Answer

Answers

  • mykejb
    mykejb Moderator Posts: 1,174 mod

    Just to be sure, do you mean Abbey Road Drums or Abbey Road Drummer? They're different products.

    The Abbey Road Drummer series works on Kontakt 5 here. I'm on Windows, but I don't think that'll make a difference.

    Abbey Road 60s Drums came with Komplete 8 along with Kontakt5, so you should be OK with those too. I don't have an installer for them though, so I can't test them.

  • jgardner
    jgardner Member Posts: 8 Newcomer

    Thanks for the reply . Yes i meant Abbey Rd Drummer. It would be great if they offered a trial version to check all this out . Thanks again 😊

  • mykejb
    mykejb Moderator Posts: 1,174 mod
    Answer ✓

    I found an official statement about compatibility at the bottom of the pricing page here - Drums : Abbey Road Drummer Collection : Pricing | Komplete (native-instruments.com)

    System Requirements

    Free KONTAKT PLAYER version 5 and higher (free Download on the NI website!) or KONTAKT version 5 and higher. The instrument will not work in earlier versions!

    I couldn't find a downloadable demo unfortunately

  • jgardner
    jgardner Member Posts: 8 Newcomer

    Thank you , thats exactly what I’ve been looking for . I must have not looked very carefully!

Back To Top