Issue with sustain pedal on Massive X VST3

Johan-v
Johan-v Member Posts: 3 Sine
edited April 27 in Massive X & Synths

I have a problem with massive x vsti3 and sustain pedal in reaper.

Steps:

  • Play a few notes after each other with sustain pedal.
  • Keep finger on last note.
  • Release sustain pedal.

Problem:

That last note should keep playing but it does stop with the release of the sustain pedal.

Tagged:

Answers

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 674 mod
    edited April 27

    Hello @Johan-v Unfortunately it is a known bug (MASSIVEX-1426). It is in the backlog, I don't have a date for a bug fix. Is this happening for all Masssive X presets or only some ?

  • Johan-v
    Johan-v Member Posts: 3 Sine

    Hello,

    The sustain pedal problem is not consistent.

    Sometimes it works in a preset for some chords but the next chord can be wrong again.

    Kind regards,

    Johan

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 674 mod

    Hey Johan, can you tell me in which presets this happens so I can try and reproduce the issue ?

  • Johan-v
    Johan-v Member Posts: 3 Sine
    edited May 6

    Hello,

    The sustain pedal problem is not solved in the latest update.1.4

    Maybe a clue.

    I does happen when a note is repeated that was already in the pedal.

    For instance.

    sustain pedal C4 E4 G4 C4 (keep finger on C4) release pedal but keep finger on C4

    The C4 should keep sounding but does stop with the pedal release.

    Maybe a note on note off that is not remembered when the same note is repeated in the pedal?

    Kind regards,

    Johan

  • DS99
    DS99 Hannover, GermanyMember Posts: 11 Sine

    We´re waiting for a long time that this will be fixed.. The bug appears nearly in every patch when you´re playing chords. Sad that a basic feature like this one is still not working.

    The first original post about that issue is deleted, why? Was a great explanation.. Here´s another post from the old user forum:

    https://www.native-instruments.com/forum/threads/massive-x-systain-pedal-stops-note-playback.448465/#post-2147789

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 674 mod

    @Johan-v @DS99 As I said earlier, this is still in the backlog. @DS99 the first original post was in the support only community we had for a moment. this support community was deleted entirely, it's the only reason. I understand it's frustrating. I will forward your comments and discontentment to the teams involved.

  • DS99
    DS99 Hannover, GermanyMember Posts: 11 Sine

    @Jeremy_NI Thank you! Would be really great to have this bug finally fixed ;)

Back To Top