NI access updates are still not working for almost three months

Shadowlife
Shadowlife Member Posts: 27 Sine
edited April 22 in Native Access

hello everyone, I've had the same issue with native access for a while now. na is showing that i have seven updates to install, so after installing the updates I close out of na, and when I open up na again it's still showing the same seven updates. I've tried removing one plugin(driver) that needs to be updated with the na uninstall tool, go back to ni access and try reinstalling, but still the same results. I've contacted ni support about this, and all they said was to use the uninstall tool, which I did from the beginning, I also uninstalled the plugins from my programs.

So, I tried to delete the MSI files but when I go do program data, a whole list pops up that are unnamed, so I have to highlight each one to see what it is, then when I open it up, I'm not seeing any exe or aaxplugin files to delete, and I definitely don't want to take any chances with trial and error, and deleting things that I'm not supposed to. here are a couple of screenshots. thank you very much.


Tagged:

Comments

  • ShelLuser
    ShelLuser NetherlandsMember Posts: 133 Tri

    I can't help be convinced that this isn't N.A.'s doing, but rather caused by the state of your OS. I conclude as much from your comment "so I deleted the MSI files", but doing that can only cause more corruption on your system (the databases in specific, as well as your registry).

    Normally you uninstall something using the apps section in the settings. If that fails for some reason then the "pro" way of handling this is to either try PowerShell, Remove-AppxPackage in particular, or you feed the GUID into msiexec.exe (use the /x command line parameter for this). You can find the GUID in the registry.

    Basically: msiexec /x {guid}

    Even so... which updates are we talking about here? And where do you install your software to, are you using customized locations by any chance? When you close NA, did you make sure it's really fully done? Because from what I can make out of your story these updates do seem to show up, right?

    Are you by any chance using Windows Defender, the ransomware protection in specific? Because that can someitmes hinder install / updates.

  • Shadowlife
    Shadowlife Member Posts: 27 Sine

    hi, I'm not entirely convinced that its ni preventing me from installing my updates either... but I've went through numerous emails back and forth and their responses were extremely simple, and I don't think they've even read or understood what I was trying to explain, but it's all good. upon some advice I had received, I said that I was going to delete the msi files, but never did because I wasn't going to take the chance on something I wasn't familiar with. I'm just trying to install ni,s basic periodical updates, I put up some screenshots. As far as the antivirus goes, I'm not using windows defender, I'm using PC matic, which might still be a problem, but I also allowed anything from ni to be excluded from being blocked by super shield, and if there's anything more to it than that I'm going to have to contact support just to make sure. Thank you

  • BrainSuperGlue
    BrainSuperGlue Member Posts: 1 Noise

    Hi Shadowlife,

    Out of curiousity, do you have your Windows Downloads folder on a network share?

    I've found a bug with Native Access.

    Whilst you can Download the Native Access installer from NA and install it so it gives you a shortcut, when you then run Native Access, it will look for a later version of it on their website, try to download it and upgrade it.

    Due to the size of downloads, samples etc I have, I used the feature of Windows to move the location of the Downloads folder from C: over to my network drive on M:

    When running Native Access, I get an error saying it cannot download the upgrade.

    If I then change the location of my Windows Downloads folder back to the default C: location, Native Access downloads its upgrade, starts up and shows me my library of apps I can install it, Kontact etc.

    Are you using a network drive?

    BSG

  • Shadowlife
    Shadowlife Member Posts: 27 Sine
    edited April 14

    hi, sorry I didn't get back sooner... to answer your question I've never had my windows downloads folder on network share, and I'm not using a network drive that i know of, but ill check. btw, just to give you an update, when i tried to install the updates again and the kontakt and komplete kontrol updates did work ! so that definitely means something, but the others are still the same. I'll definitely try what you've mentioned and let you know how i made out. thank you !

  • Shadowlife
    Shadowlife Member Posts: 27 Sine

    Hi,I just wanted to get back to you on my issue with the ni updates. So,I did install ni access again, but it was already updated to the latest version,but I didn't transfer the location of it, because I don't think that's the problem, it just doesn't make sense that the kontakt and komplete kontrol updates worked but the others still won't update. I guess I'll have to email support again The first time I did contact them on this issue was a complete waste of time,all of the back and forth emails didn't solve a thing, they never listened to anything I said, they kept sending me useless information. Thanks for the help

Back To Top