S4 Mk1 Driver not working and website won't let me download

ermac4482
ermac4482 Member Posts: 6 Sine

So I have a mid 2011 iMac running Mac Sierra 10.12.6 with the Native Instruments Control S4 Mk1 ( the first one) and Pro 3. Works great . I have a mid 2012 MacBook Pro running the same Sierra 10.12.6 but when I go to the NI downloads page to re download the driver Mac 10.9-10.11, I get error "404 Not Found" .It give me the same error when I try to download the Mac OS 10.8 Driver.

So I tried to download the earlier versions for Mac 10.6 ,10.7 . It lets me , and I Install the DMG File. Restart and it still doesn't recognize my controller which is also a sound card.


So then I look at my file Directory on my Old iMac and try to port over files. There is one in Midi driver called plugin, then another in Library extensions , and some Plist files in Audio. Still doesn't reconize my controller . Probably because I never installed it correctly because I could NOT download it from the website. Does NI not let you download that anymore . I even tried to download the driver on the Ni website from My IMAC which it already works on that and I still get the same error. How do I get this driver ?why won't it work when I port the files over ? Did I not find all the correct files to bring over? Also because my Laptop is Mid 2012 will that effect not working with a driver that is listed as 10.9-10.11 ?

Best Answer

  • Ryan_NI
    Ryan_NI BerlinCustomer Care Posts: 157 mod
    Answer ✓

    Hey there - we're currently experiencing an issue with our downloads page for our drivers and other files, and are working to fix it as soon as possible.

    Additionally, to get your S4 MK1 to work with macOS 10.12, you'll need to follow the steps in the link below:

    Operation of NI Legacy Hardware Devices on macOS 10.12 - 10.14

Answers

  • Ryan_NI
    Ryan_NI BerlinCustomer Care Posts: 157 mod
    Answer ✓

    Hey there - we're currently experiencing an issue with our downloads page for our drivers and other files, and are working to fix it as soon as possible.

    Additionally, to get your S4 MK1 to work with macOS 10.12, you'll need to follow the steps in the link below:

    Operation of NI Legacy Hardware Devices on macOS 10.12 - 10.14

Back To Top