How to save Setup (MidiCh:Omni & MidiSplit) in KompleteKontrol: Vintage Organs?

TWhunter74
TWhunter74 Member Posts: 3 Sine

Hey Musicians :-)

It seems like an easy question on Vintage Organs, but I can't figure it out myself:

How could I save my "Setup" in Vintage Ordens (within Komplete Kontrol) so that I simply could browse through the presets without changing MidiChannel to "Omni" and from KeySplit to MidiSplit?

Background: I've got to 2 keyboards and a Bass-Pedal - ideal for Hammond Organ etc. To use them all, I have to switch MidiChannel (in the top left corner when "view" is at least in "Additional View") to Omni AND switch the knob "keySplit" to "Midi Split".

When this is done, I can go through all the Presets saved in this Sound with the red keys on the lower manual. Great! But what if I switch a Sound/Preset Browser (left)? Then I again have to do the same again an again...How could I save these over Presets as a "default" state?

Bonus-Question:

It seems, that nearly none of the presets use the Pedal-Sounds. Yes, I could switch them how I want to sound them...and save it in the existing presets (the red keys on the left). But first of all it seems weird to me, that the NI-Presets don't have the Bass Pedal already used...and second: Is there a way to let a Bass-Pedal Sound "On" for every Preset I choose?

(Well, if not, I will just use another Instrument in my DAW for the Bass-Pedal as a workaround)

Thanks ahead for any help :-)


Thomas

Best Answers

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 852 Saw
    Answer ✓

    There are no global settings to change the items you need to change… you would need to make the changes to the instrument, then save the .nki. For the Midi channel thing, did you try setting all your controllers to transmit on the same midi channel? If you have to change to Omni, then that indicates they are transmitting on different channels.

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 852 Saw
    Answer ✓

    you are right about the Midi channel assignment not holding the Omni setting when changing patches...I forgot that in order to change that, you need to go into Edit mode and select all groups and select Omni as the midi input for all groups and save, the Midi channel display can be confusing at this point because it will say "A1 + Groups" not Omni, but Omni is still a selection from the channel dropdown...not sure why...

Answers

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 852 Saw
    Answer ✓

    There are no global settings to change the items you need to change… you would need to make the changes to the instrument, then save the .nki. For the Midi channel thing, did you try setting all your controllers to transmit on the same midi channel? If you have to change to Omni, then that indicates they are transmitting on different channels.

  • TWhunter74
    TWhunter74 Member Posts: 3 Sine

    Hi Blindeddie!

    Thanks for your fast Response! :-) You're right: Upper is sending on Ch1, Lower on Ch2 and BassPedal on Ch3. And I like it like that way for all the rest of my Setup.

    But I learned a lot from your post and trying some things again: (works with Kontakt standalone, Komplete Kontrol standalone and via KompleteKontrol within a DAW (Logic) - I write it down here for the next one who struggle's at this point

    1.) Only if I use "Edit-Mode" in View, you can see the rest of the Kontakt6-Menu's - and there are the "missing" Back and Forwards-Keys within the instrument (on the right of the Sound-Name)

    2.) Before I used the Browser on the left. That caused, that Omni always went back to "Ch1" when switching Sounds, Now I use the mentioned Back and Forwards-Keys - Then Omni "stays" in Place every time I switch the Preset.

    3.) There I changed the mode to "MidiSplit" and saved/replaced (Disc-symbol) the Preset under the original Name (.nki). (By the way: Omni is NOT saved here)


    --> I have to do this for every preset - but then I can switch every preset without changing these two points every time on and on again.


    Thanks again for the hint in the right direction.


    Thomas

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 852 Saw
    Answer ✓

    you are right about the Midi channel assignment not holding the Omni setting when changing patches...I forgot that in order to change that, you need to go into Edit mode and select all groups and select Omni as the midi input for all groups and save, the Midi channel display can be confusing at this point because it will say "A1 + Groups" not Omni, but Omni is still a selection from the channel dropdown...not sure why...

  • TWhunter74
    TWhunter74 Member Posts: 3 Sine

    Fantastic :-)

    That works as described - I had to go (again) through the +-100 Presets to change that...and now I can just play Music and switch through Presets normaly on the KK-S61.

    It's still a bit of a Pain, that in nearly every Preset the Bass-Pedal is missing (Drawbars at Zero - and why NI did that is a bit of a mystery)...but nevertheless... this could be fixed easy with a separate track with only the bass-Pedal.

    Thank you very much again!

    Thomas

Back To Top