* MIDI BROKEN * in Kontakt 5 & 7 / Cubase Pro 9.5

NDEE
NDEE Member Posts: 10 Member

Hello folks,

Long time user here of Kontakt 5 with Cubase Pro 9 without problems for many years.

I recently bought a new PC dedicated to my DAW (updated to Cubase Pro 9.5 /Kontakt 5 & 7), PC all tweaked and optimized for DAW work, but I started having this weird MIDI issue in both Kontakt 5 and 7 when loaded in Cubase 9.5.


Despite all instruments in Kontakt 5 and 7 having separate MIDI channels, and associated MIDI tracks in Cubase Pro 9.5, Kontakt just acts as if EVERYTHING is in OMNI MIDI CHANNEL !!!

Meaning, if I press play in Cubase to play a MIDI file that has a precise MIDI channel with a corresponding Kontakt instrument, ALL the loaded Kontakt instruments respond to this MIDI track despite being on separate MIDI channels.

Same problem with the onscreen Kontakt keyboard, if I select/highlight an instance / instrument amongst several loaded instruments in Kontakt (all on separate MIDI channels), ALL THESE INSTRUMENTS react to the MIDI played from the Kontakt keyboard, as opposed to the single highlighted Kontakt instrument normally.


Also old projects that work perfect in my old Cubase 9 / Kontakt 5 computer, are all messed-up in the new PC with Cubase 9.5 / Kontakt 5 & 7. All the loaded Kontakt instruments responds to ALL the MIDI from Cubase, no matter what MIDI channel it's on, and results in a cacophony of every MIDI channel being played by ALL INSTRUMENTS AT ONCE!!!

I cannot work on ongoing Cubase 9 / Kontakt 5 projects that I started in my old computer because the Kontakt MIDI is all messed-up in the new PC...

Anyone experiencing such MIDI MISH-MASH with Kontakt 5 or 7 in Cubase 9.5 ?????????

All my projects worked fine in Cubase Pro 9, but in Cubase Pro 9.5 Kontakt is broken...

I lost several hours of work these past weeks trying to fix this KONTAKT MIDI problem but couldn't, I had to load only 1 instrument per Kontakt instance in order to have separate MIDI channels to work in Cubase 9.5.

IS THIS A KNOWN PROBLEM, and HOW TO FIX THIS KONTAKT MIDI MISH-MASH???


My new PC: AMD Ryzen 7 5800H with 8 core /16 threads, 32 GB RAM, has fresh install of Windows 10 Pro, it's optimized for DAW, nothing else in it, fresh install of Cubase Pro 9.5 and all Native Instruments stuff (Komplete/Kontakt 5&7) all from recent versions, latest as of a couple of weeks ago, and RME Babyface with latest driver.


HELLLLLLPPP !!!!!!!!!!!!!!!!

Best Answer

  • NDEE
    NDEE Member Posts: 10 Member
    Answer ✓


    !!!!!!!!!!!!! PROBLEM SOLVED !!!!!!!!!!!!!!!

    And here's the kicker:

    I was looking for a video about the KSP factory MIDI monitor multiscript that Stephen24 was talking about, but that I'm not familiar with and so I Googled and BOOM, 1st video that shows up is a guy with the same Kontakt problem I had but he found the solution and did a video about it!

    So I found the solution to my problem and I never got to see a video about KSP Kontakt MIDI monitor thing!!!

    Basically, it's a Kontakt problem, a parameter was changed (in an update?) that made Kontakt be in GROUP mode, which was responsible for the OMNI MIDI Mish Mash I was getting in Kontakt.

    I was able to fix my old Kontakt 5 projects, but Kontakt 7 doesn't somehow have the menu I need to get into to fix this. The WRENCH icon on the top left of a Kontakt instrument instance, is not there in Kontakt 7 for some world percussion instruments of the Kontakt library, weird. It was there in Kontakt 5, but gone in 7...

    Anyhow, problem fixed in Kontakt 5 so I can get back to work now.

    So pass the word around folks about this parameter change in Kontakt if you hear people having a MIDI Mish Mash problem in Kontakt.

    I don't know if we are allowed to post links here so I wont post the full link to the short video that solved the problem. Just add the following to the youtube dot 3 letters address: /watch?v=zOwSmPF9UFM

    You should see the video that explains the Kontakt problem but most importantly the solution.

    The video is 5 years old by the way so I don't know what Native Instruments has been doing all this time about this problem...

    So thanks to all who chimed-in to help me. PROBLEM SOLVED!

    And thanks to Stephen24 who got me on this path to look for a video that I never found because I stumbled on the solution along the way!!!

    Synchronicity!

    Godspeed folks and make great music !!!!!!!!!!!!!!!

Answers

  • Triggi
    Triggi Member Posts: 48 Helper

    Hi Ndee,

    did you have kontakt7 at the old pc?

    perhaps its a simple fail in the cubase 9.5 global settings. Unfortunatly no more ideas.

    Why do you have both versions on new pc?

    Best regards!

  • stephen24
    stephen24 Member Posts: 252 Advisor

    I don't think there is any way this can be a Kontakt issue, especially if it happens with both versions. (You could check this with the KSP factory MIDI monitor multiscript which you can set to monitor activity on individual channels).

    It's got to be a setting in Cubase, about which I know nothing. Suggest you search for "omni" in the Cubase manual, or even Google.

  • stephen24
    stephen24 Member Posts: 252 Advisor
    edited January 20

    Does this help?

    Setting the MIDI Channel and Output


    The MIDI channel and output settings determine where the recorded MIDI is routed during playback. They are also relevant for monitoring MIDI in Cubase. You can select the channel and output in the track list or in the Inspector.


    Procedure

    In the track list, select the track to which you want to assign a MIDI channel and output.

    In the topmost Inspector section, open the Output Routing pop-up menu and select an output.The available outputs on the menu depend on the type of MIDI interface that you are using. If you hold down Shift-Alt, the selected MIDI output is used for all selected MIDI tracks.

    Open the Channel pop-up menu and select a MIDI channel.

    Note If you select the Any MIDI channel, the MIDI material is routed to the channels that are used by your MIDI instrument.


  • NDEE
    NDEE Member Posts: 10 Member

    Hi Triggi, thanks for chiming in!

    I did not intend to install both Kontakt 5 AND 7, I installed only 7 at first, but upon seeing my old projects not working properly in Kontakt 7 as described in my 1st comment, (MIDI Mish Mash) then I installed Kontakt 5 thinking it would solve the problem of the old projects playback, but no...

    And to answer your question, no, Kontakt 7 was not in old PC, only in the new one.

    As for a fail in the Cubase 9.5 global settings, I've looked around quite a bit in the Cubase Preferences, MIDI set-up, MIDI plug-ins slots, MIDI monitor and did not find anything, yet I'm not a MIDI guru outside normal use of MIDI for projects like I described in my 1st comment.

    I feel it might be some hidden parameter that was maybe not in Cubase 9 but introduced in 9.5 that messes-up Kontakt, (?) but I could not find anything on the Cubase forum about this...

    Or maybe some installation woe that messed-up something...

    I'm thinking that if I can't fix this, I'll install Cubase 9 and see if it works. It did in my old computer.

  • NDEE
    NDEE Member Posts: 10 Member

    Hi Stephen24, thanks for chiming in!

    I will look into this KSP Kontakt MIDI monitor thing, I don't know how it works but will look it up in the manual. However, I did monitor my MIDI in Cubase 9.5 using the MIDI Event List, that lists all MIDI events, and sure enough my MIDI channels/tracks were assigned their correct MIDI channel, but Kontakt did the big MIDI Mish Mash thing again despite the separate MIDI channels...

    Weird!

    As for the Cubase MIDI set-up info you posted from the Cubase manual: That's what I've been doing for years to assign my Kontakt instruments or other VST instruments and it always worked, but not in my new computer with Kontakt in Cubase 9.5 somehow.

    The omni problem could come from a bug in the MIDI Output Track menu as there is an option for the track to broadcast its MIDI data on ANY MIDI channel, so that would give me the Kontakt MIDI Mish Mash I'm getting, but I'm getting the problem despite the output MIDI tracks having their dedicated MIDI channel, with a matching MIDI channel and Instrument in Kontakt.

    I will go check that Kontakt KSP MIDI Monitor thing, maybe it'll tell me if it's receiving the correct MIDI channels from Cubase 9.5, or if it's getting some OMNI MIDI channel thing.

    As for the bug to be in Cubase 9.5 rather than from Kontak because of the same behavior in both Kontakt 5 and 7, I've looked in the Cubase forum but I could not find that issue reported anywhere, at least from the wording I used for my search...

    Will go boot-up the DAW computer now and test this out.

    Thanks again for chiming-in.

  • NDEE
    NDEE Member Posts: 10 Member
    Answer ✓


    !!!!!!!!!!!!! PROBLEM SOLVED !!!!!!!!!!!!!!!

    And here's the kicker:

    I was looking for a video about the KSP factory MIDI monitor multiscript that Stephen24 was talking about, but that I'm not familiar with and so I Googled and BOOM, 1st video that shows up is a guy with the same Kontakt problem I had but he found the solution and did a video about it!

    So I found the solution to my problem and I never got to see a video about KSP Kontakt MIDI monitor thing!!!

    Basically, it's a Kontakt problem, a parameter was changed (in an update?) that made Kontakt be in GROUP mode, which was responsible for the OMNI MIDI Mish Mash I was getting in Kontakt.

    I was able to fix my old Kontakt 5 projects, but Kontakt 7 doesn't somehow have the menu I need to get into to fix this. The WRENCH icon on the top left of a Kontakt instrument instance, is not there in Kontakt 7 for some world percussion instruments of the Kontakt library, weird. It was there in Kontakt 5, but gone in 7...

    Anyhow, problem fixed in Kontakt 5 so I can get back to work now.

    So pass the word around folks about this parameter change in Kontakt if you hear people having a MIDI Mish Mash problem in Kontakt.

    I don't know if we are allowed to post links here so I wont post the full link to the short video that solved the problem. Just add the following to the youtube dot 3 letters address: /watch?v=zOwSmPF9UFM

    You should see the video that explains the Kontakt problem but most importantly the solution.

    The video is 5 years old by the way so I don't know what Native Instruments has been doing all this time about this problem...

    So thanks to all who chimed-in to help me. PROBLEM SOLVED!

    And thanks to Stephen24 who got me on this path to look for a video that I never found because I stumbled on the solution along the way!!!

    Synchronicity!

    Godspeed folks and make great music !!!!!!!!!!!!!!!

  • Triggi
    Triggi Member Posts: 48 Helper

    👏👏very nice one!!

  • stephen24
    stephen24 Member Posts: 252 Advisor
    edited January 21

    Glad you got it sorted.

    So Kontakt is actually changing the settings of an instrument when loading it? (These instruments worked OK before and this has now changed?)

    This must be a pretty fastidious bug, if it's present in K5 which has been around for many years, and as far as I can see there has ever been only one previous report of it. It's effect is going to be pretty devastating so it's unlikely to have been overlooked.

    Maybe you should submit a bug report to NI.

Back To Top