cannot reuse previously loaded tracks

userX
userX Member Posts: 1 Newcomer

My music collection stored on local NAS. I can browse and load tracks just fine, but once Traktor is restarted, and I want to reload same tracks, it says "File cannot be played: the file might be missing, corrupt or unsupported". If I remove the file from collection, and then reload it again, it works. Any ideas?

TraktorPro V3.11 now, although I've experienced this issue since at least 3.8, maybe earlier.

Tagged:

Answers

  • zephry
    zephry Member Posts: 560 Pro

    Try right clicking on Collection and saving. Then restart and see if the file paths are correct.

    I don't know much about the intricacies of sharing Network files. But I wouldn't be surprised if Traktor hasn't been properly tested for that. Although Beatport Link streaming is essentially doing that.

    If you can somehow look at the file paths with the missing track and compare to what it is after adding it again. That could give some clues into what is happening.

  • HoFr
    HoFr Member Posts: 1 Newcomer
    Hi,

    I also ran into the same problem.

    > @zephry said:
    > If you can somehow look at the file paths with the missing track and compare to what it is after adding it again. That could give some clues into what is happening.

    That hint brought me to the solution. TRAKTOR has problems to restore the filepath, when it is in UNC.
    When you import your files, it has correct path for example \\Myserver\music\somefile.mp3.
    After restart, TRAKTOR use \Mysserver\music\somefile.mp3 (missing second \). So it is not a UNC server adress, but a relativ path and therefore cannot find the files.

    Greetings
    HoFr
Back To Top