S49 Firmware Update Failed, "Looks Like Something Went Wrong" Firmware 0.0.1

corbonqlus
corbonqlus Member Posts: 9 Newcomer
edited January 17 in Komplete Kontrol

I have had this issue on TWO different Kontrol S49s.

The initial firmware update ran for 4-5 hours. I power cycled the keyboard, for a firmware update taking 4-5 hours is absolutely ridiculous. The keyboard then booted into the recovery mode pictured above, and now the installed firmware shows as 0.0.1.

I followed all the steps on ni.de/kontrol-setup, I used the provided usb-s cable as the data cable and I used a power supply as well, even though that should not be needed for the s49. On successive attempts to update I have tried other cables, other power supplies, other computers, even different operating systems. Nothing makes any difference. I have been utterly unable to update the firmware.

Sweetwater kindly responded to my support request, unlike NI for which I have had an unanswered support request open for 8 days!!! Sweetwater sent me a replacement keyboard, and viola, the exact same behavior as the first. I let the firmware update go for over 6 hours and no luck. Power cycled, and back to recovery mode and no path forward.

I have read all the threads regarding this, there is no issue with the driver in device manager on my machine. Sweetwater also reached out to Native Instruments for this 8 days ago, and Native Instruments did not respond to them either.

Comments

  • Lautaro Tanok
    Lautaro Tanok Member Posts: 28 Member

    The customer service at native instruments is terrible, the s88 mk2 came out defective with a sustain problem and they never solved it, I hope you can solve your problem soon.

  • corbonqlus
    corbonqlus Member Posts: 9 Newcomer

    I frankly am completely unsure how to proceed. I have tried everything in the forums here, I have even tried a replacement keyboard :(

  • corbonqlus
    corbonqlus Member Posts: 9 Newcomer

    It finally updated, if you see the firmware 0.0.1 and "Looks like something went wrong" on the keyboard screen, simply let the update run overnight, my firmware update took nearly 10 hours, I have no clue why.

  • Matt_Future_Primate
    Matt_Future_Primate Member Posts: 1 Newcomer
    ..Solved my own Firmware Issues.
    It is essential to insure the S Series is connected to an additional USB-C PSU in order for most of us to update the firmware.
    I had the same set of Error messages, Firmware Update Failed ETC.
    Mac Ultra, the unit did not respond to any update until I used a separate PSU - In My Case an Apple USB-C from my phone charger collection :).
    The First time I extra juiced the unit, screen came back on Blank and White. (New experience!)
    Ran the update, failed...
    Switched off the unit :/.
    Powered On the unit... same gut wrenching failure message on the keyboard display about failed.
    Reopened the Mac Updater software and ran it again..........woooosaaaaaaaaaa....
    3 minutes later and bingo, back in business...
    I hope this helps someone, it is a horrible moment when this happens, I have a bricked Econ XS due to inadequate software it seems, for a moment in time I thought I had yet another lovely looking but expensive door stop!!.....
Back To Top