Need Kontakt 6.7.1 Download link

Steph Copeland
Steph Copeland Member Posts: 2 Member

Anyone know where I can find this link on NI's website? Having trouble finding archives for a safe download

Answers

  • Milos
    Milos Member Posts: 1,825 Pro

    Me personally, I don't know.

    But it is not really safe to use Kontakt 6.7.1, because most of the libraries you have now, especially if they have the latest version, Kontakt 6.7.1. won't play them because it is old.

    You know what they say: Adapt or die.

    I know how you feel about that, and I can relate.

    It is better to just install Kontakt 7 Player.

  • Steph Copeland
    Steph Copeland Member Posts: 2 Member

    I only have one plugin that I bought that isn't working on Kontakt 6 and Catalina and that's Slate & Ash's Spectres. I'll get around to upgrading soon just need this today.

  • Milos
    Milos Member Posts: 1,825 Pro

    Sure thing!

Back To Top