Daw connection in Pro Tools 23.12

bzone
bzone Member Posts: 35 Member

Issues with getting the peripherals to show daw in set up insert. Intel Mac, Ventura . In audio midi set up the mk3 is listed main/daw/ext. When in protools session you can not select daw as a separate category. In Logic no problem. When in a session if you select the daw button on the mk3 it stays locked and you can’t go back to browser or plug in. Never any control of these instance buttons on the mk3. When select different tracks the mk3 plug-in window doesn’t show the track plug-in selection. Any one on an Intel Mac in Ventura with an mk3 having these issues? Can you get your peripherals to show main/daw/ext when selecting mk3 in the pull down menu?

Comments

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    Hey @bzone I think we've adressed this in another post. You are also in contact with my colleague, he should get back to you as soon as possible.

  • bzone
    bzone Member Posts: 35 Member

    Please get an Intel Mac in Ventura in ProTools 23.12 with your drivers and software. Then show me the peripherals with main/daw/ext in a picture. I was so disturbed by this that Saturday I took 14 hours to remove all NI from my computer. All plists, preferences, cleaned out all midi set ups , deleted everything. Re set the mk3. Saved the NI sound contents on external SSD’s. Completely removed Pro Tools Ultimate from my system all software and drivers. Then clean installed Pro Tools with drivers, and your NI drivers and software all updated to the latest releases. Everything loaded properly in complete disk access. Everything in the right place including the mk3 with a USB cable that I searched for that works for power and data transfer.

    Now everything works at this level in Pro Tools; Browser/Plug-in/Daw now functions. When you select different instrument tracks, the plug-in now shows on the mk3. However it would be nice to have it record arm like in Logic. Still have to click the track record. It would also be nice to implement in the monitor view once you select the track, that the same window as the mk3 would be displayed on the monitor. Also you can not use any other HUI controllers with the mk3 in the midi controls if you want it to function properly IN Pro Tools. I had 3 HUI controllers in the first 3 slots and the mk2 in the 4th and all was fine. You can not do that with the MK3. We need that control for session implementation. It works in Logic with other HUI and the mk3 all selected?

    Now the biggest point in my system, in peripherals, the mk3 populates I guess in daw, but it does not show that, if you go into the rest of the menu it shows, main and ext. In stand alone you have the choice to select main/daw/ext. Not in ProTools 23.12 on OS Ventura. However it functions. I was a good idea to clean my system up from all the past instances of NI and Pro Tools. It cleaned up all the conflicts.


    My suggestions all monitor windows show the same selection as the mk3 .

    Get it to function with other HUI populated.

    Tell the exact cable USB C with lengths that will work, power, data, voltage.

    Not all of us work with lab tops. I do not want to have a separate computer for the mk3. I already have one for my rmu for Atmos. I’m running a Mac Intel 7.1 with 384 gig ram, OS Ventura HDX3 with sonnet 4x8 card 8 4T 990 Pro SSD’s

    PERIPHERALS DO NOT POPULATE WITH MAIN/DAW/EXT AS SELECTIONS IN PRO TOOLS 23.12 OS VENTURA

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod
    edited January 15

    As I said before, this is way too complex to address in the community, no need to post it over and over again. My colleague will get back to you to find out what is happening on your system. And again, it is very very unlikely it is related to what USB C cable you are using.

  • bzone
    bzone Member Posts: 35 Member

    I was posting to see if anyone else could solve the issue. No one from NI has gotten back to me with an exact intelligent response. I wish you had a download package that had the installers that populated the midi correctly. If I spend money on something I would like it to work as advertised. I understand your programming for the future with the new M1 and M2 Mac’s. However I’m stuck in Intel until their M3 or M4 comes out with over 300g ram , as my templates are to large to load and need them for past projects. This could also be an Avid problem, I’ll contact them as they get back to me within a hour. That way I can find out what the software implementation is. Thanks for trying.

  • MDMA02
    MDMA02 Member Posts: 1 Newcomer

    I have the same problem. The NI S88 MK3 in standalone works without any problems. When I want to integrate it to DAW (ProTools Studio latest version) it does not allow me to do so. In the peripheral dropdown I only see Port 1 and not DAW. So it is impossible to use the DAW function from the keyboard.... honestly it is frustrating to spend €1300 and have these problems. 

    I hope they solve soon if not I will be forced to return it. 

  • bzone
    bzone Member Posts: 35 Member

    Please take a look at the last column in midi, it allows you to select the input device, you can check on main/ext. Perhaps this may solve your issue. On you mk3 keyboard you can also select midi 2. In stand alone see if you can select main/daw/ext. Are you on an Intel or M1? Good Luck, Avid has given them all the right data, it’s NI that has not programmed correctly.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    @MDMA02 The integration should work, make sure to give full disk access to Pro Tools and Komplete Kontrol. How to Enable Full Disk Access on macOS

    Can you post a screenshot of that? "In the peripheral dropdown I only see Port 1 and not DAW."

    @bzone My colleague is waiting for the result of your support tool in order to troubleshoot your issue.

  • bzone
    bzone Member Posts: 35 Member

    As I told NI, you can not have access to my system at any time. You are more than welcome to give a detailed explanation to all specific items and where they should be. I spent hours removing and reinstalling everything. The issue is your software and midi or HUI drivers in Ventura and Intel Macs. I can use it stand alone on Kontak or in Logic perhaps. However I have had enough and just may throw it in the trash. Look at all the complaints here . It’s so unprofessional. I can’t waste any more time. I will look at NAMM this week and if you have any Mac’s running an mk3 and look into the system personally. If I can’t find it , I just can’t support NI any further. From cables to incompetent support.

Back To Top