How to turn on time / clock display?

When I first had Traktor Pro 3 installed back in April, it used to show the clock / time (as in an actual clock with time of day). This was in the top bar next to the battery / charging indicator. Sometime in the fall this disappeared.. can I get this back?!

Obviously it is very helpful to see the time without needing to use my mouse to show the menu bar at the top of my mac!!

Tagged:

Answers

  • mykejb
    mykejb Moderator Posts: 817 mod
    edited January 1

    I see it here on mine, although it's on PC - does yours not show anything there ?

    I just checked on Mac (Sonoma) with the latest 3.10.1 build and it's present there as well.

    -- Mike

  • DJDancinDave
    DJDancinDave Member Posts: 21 Member

    exactly that is where it USED to be (thank you for the screenshot confirming my memory is not crazy lol)

    And it just.. poof.. disappeared one day in the last few months.

  • mykejb
    mykejb Moderator Posts: 817 mod

    That's weird - it's showing on my Mac and I can't see any option to turn it off anywhere. I'm on an Intel Mac, but I wouldn't have thought it'd make a difference. I have no controller plugged in either, but again I don't think that should matter. None of which is particularly helpful, sorry!

    -- Mike

  • DJDancinDave
    DJDancinDave Member Posts: 21 Member

    I just opened the app and noticed the clock was there for half a second on start-up and then disappears...?!

  • DJDancinDave
    DJDancinDave Member Posts: 21 Member

    found the answer!

    The update to MacOS Sonoma killed the clock. The timing matches my experience. Too bad. Maybe NI will come out with Sonoma support sometime in 2024?!

    Trying to link to reddit where I found that out, but I'm not allowed to post links. "No clock after update to Sonoma" on the Traktorpro subreddit will get you there.

  • mykejb
    mykejb Moderator Posts: 817 mod

    According to NI it's already supported so it's probably worth dropping a ticket in to NI support about it. Have you tried the latest beta just in case it fixes it? Traktor Pro Public Beta — Community (native-instruments.com)

    -- Mike

  • DJDancinDave
    DJDancinDave Member Posts: 21 Member
    edited January 1

    aha! I didn't realize 3.9 or 3.10 came out. I've been on Traktor Pro 3.8 for awhile. Was expecting auto-updates. Downloading now, but that update didn't fix the clock issue. Good to know the app should be more stable generally, though.

    3.11 Beta still has no clock.

    What version of MacOS are you on?

  • c0nsul
    c0nsul Member Posts: 290 Pro

    Do you have a custom screen resolution?

    I use a MBP 14" w/ M1Pro, latest Sonoma 14.2.1, latest Traktor beta release 3.11.044 (RC2) and the clock is showing. I´m on Sonoma since day 1 and I always installed the recent Traktor version (betas and official releases), never had your issue. Clock was always showing.

  • mykejb
    mykejb Moderator Posts: 817 mod

    I'm on Sonoma, but an Intel based Mac Mini rather than one of the new ones

    -- Mike

  • viper9711
    viper9711 Member Posts: 67 Helper
    edited January 2

    Clock was always showing. Sonoma 14.2.1. MacBook Pro M1, Traktor 3.10

  • DJDancinDave
    DJDancinDave Member Posts: 21 Member

    @c0nsul nope! Standard 1440 x 900 px.

    In version 3.8, the clock would flash "0:00" while Traktor was starting up and then disappear.

    With v3.10 and 3.11 it doesn't even flash 0:00.

    Traktor Beta 3.11 .044

    Hardware Overview:

     Model Name: MacBook Air

     Model Identifier: MacBookAir10,1

     Model Number: Z12A000FKLL/A

     Chip: Apple M1

     Total Number of Cores: 8 (4 performance and 4 efficiency)

     Memory: 16 GB

  • Sixten
    Sixten Member Posts: 1 Member

    Nope. Time is not showing after installing Sonoma. Still doesn't show after installing Traktor 3.11.

    I'm convinced that Traktor is left behind in general (no flexible grids, no Tidal integration, and so on). They don't even care to fix minor bugs (like the time display)… Too bad…

  • DJDancinDave
    DJDancinDave Member Posts: 21 Member

    So I finally have confirmation that this is NOW A KNOWN NI BUG

    [Via email support ticket]: "This is a bug introduced with Sonoma. Our team is working on it so it can be fixed on a future release.

    We'll change the ticket status to “Solved” as there is not much we can help with for now. Should you want to check on the fixing status, simply respond to the ticket at your earliest convenience referring to the bug ID and it will activate once more for us to review and get back to you"

    I asked if this is likelye to come out in a future 3.11 release, or not til future versions.. we'll see if they can answer that!

Back To Top